-ERR [AUTH] Problem mit GMAIL

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • -ERR [AUTH] Problem mit GMAIL

    Ich habe mir jetzt ein GMAIL-Konto (in TB! 6.7.38.2 64 Bit) als POP3 eingerichtet und dabei die Einstellungen von GwenDragon aus Probleme mit v1.62r und stunnel bei gmail-Konto bzw. aus der Standard-Konfigurationsanleitung von support.google.com/mail/troubl…?hl=de#ts=1665119,1665162 verwendet. Also für den Posteingang pop.gmail.com mit Port 995 und "Geschützt auf dediziertem Port TLS", Authentifikation "Standard", für den Postausgang smtp.gmail.com auf Port 587 und "Geschützt auf Standardport STARTTLS" Authentifikation nach RFC 2554. Hier habe ich auch Port 465 mit "Geschützt auf dediziertem Port TLS" versucht. Bei GMAIL selbst habe ich den POP3-Versand und -Empfang freigegeben. Aber egal, welche Einstellung ich wähle, ich bekomme immer die Meldung "FETCH - Server meldet Fehler. Die Antwort ist: -ERR [AUTH] Web login required: support.google.com/mail/bin/answer.py?answer=78754". Ich muss erst auf myaccount.google.com/ gehen und dort den "Zugriff für weniger sichere Apps" freigeben, dann bekomme ich eine Verbindung, was ich aus Sicherheitsgründen natürlich nicht möchte.

    Hat jemand eine Idee, woran das liegen könnte? Also nochmal kurz die Einstellungen zusammengefasst:

    SMTP-Server smtp.gmail.com
    Geschützt auf Standard-Port (STARTTLS)
    SMTP-Port 587
    POP v3 Server für eingehende Nachrichten pop.gmail.com
    Geschützt auf dediziertem Port (TLS)
    Server-Port für eingehende Nachrichten 995
    Zeitüberschreitung für Verbindung 300 Sek.
    TheBat! Pro 8.x (64 Bit) • Win 10 Pro x64 • keine PlugIns

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von GwenDragon () aus folgendem Grund: Schlagworte

  • TLS und 465 habe ich auch ausprobiert. Gleiches Ergebnis.
    Die Zwei-Faktor-Authentifizierung benutze ich nicht.
    Gibt's da noch irgendwas bei den Authentifikationseinstellungen in TB!, was man beachten sollte? Also jeweils den rechten Button bei den Einstellungen. Ich habe die auf der Standardeinstellung gelassen.
    TheBat! Pro 8.x (64 Bit) • Win 10 Pro x64 • keine PlugIns
  • Der Link zur offiziellen GMail-Anleitung steht bei uns im Thread "Adressen von Mail-Servern". Eventuell ist es der gleiche wie von dir oben gepostet.

    Wie es dort steht, muss man zuerst in den GMail-Einstellungen im Reiter "Weiterleitung und POP/IMAP" unter "POP-Download" die Option "POP für alle Nachrichten (auch bereits heruntergeladene) aktivieren" aktivieren. Darauf hin müsste unter Status in grün "POP ist für alle Nachrichten aktiviert, die seit <hier steht das Aktivierungsdatum> eingegangen sind" stehen. Soweit ich mich erinnere, muss dort nichts mehr gemacht werden.

    Die POP- und SMTP-Einstellungen in TB! sehen wie folgt aus:

    Quellcode

    1. 1. POP
    2. Serveradresse: pop.gmail.com
    3. Verbindung: TLS
    4. Port: 995
    5. Authentifikation: Standard
    6. Benutzername: <eMail-Adresse> / manchmal geht's auch ohne den @gmail.com-Zusatz
    7. Passwort: <GMail-Passwort>
    8. 2. SMTP
    9. Serveradresse: smtp.gmail.com
    10. Verbindung: TLS
    11. Port: 465
    12. Authentifikation:
    13. [x] SMTP-Authentifikation nach RFC 2554
    14. [x] Gleiche Einstellungen wie zum Nachrichtenempfang verwenden
    Alles anzeigen

    Die Log zeigt dann so etwas:

    Quellcode

    1. 1. POP
    2. FETCH - Empfange Nachrichten
    3. FETCH - Verbinde mit POP3-Server pop.gmail.com auf Port 995
    4. FETCH - Einleitung TLS-Handshake
    5. FETCH - Zertifikat S/N: 2BF1B34A12670682, Algorithmus: RSA (2048 Bits), ausgestellt von 27.02.2015 20:06:32 bis 28.05.2015, für 1 Host(s): pop.gmail.com.
    6. FETCH - Besitzer: "US", "California", "Mountain View", "Google Inc", "pop.gmail.com".
    7. FETCH - Aussteller: "US", "Google Inc", "Google Internet Authority G2".
    8. FETCH - Root: "US", "GeoTrust Inc.", "GeoTrust Global CA"
    9. FETCH - TLS-Handshake vollständig
    10. FETCH - Verbunden mit dem POP3-Server
    11. FETCH - bestätigt (Standard)
    12. FETCH - 1 Nachricht(en) im Postfach, davon 1 neue
    13. FETCH - Nachricht empfangen von <eMail-Adresse>
    14. FETCH - 1 Nachrichten vom Server gelöscht
    15. FETCH - Verbindung beendet - 1 Nachricht(en) empfangen
    16. 2. SMTP
    17. SEND - Sende Nachricht(en) - 1 Nachricht(en) in der Warteschlange
    18. SEND - Verbinde mit SMTP-Server smtp.gmail.com auf Port 465
    19. SEND - Einleitung TLS-Handshake
    20. SEND - Zertifikat S/N: 19C305EE37953280, Algorithmus: RSA (2048 Bits), ausgestellt von 15.07.2014 08:40:38 bis 04.04.2015 15:15:55, für 1 Host(s): smtp.gmail.com.
    21. SEND - Besitzer: "US", "California", "Mountain View", "Google Inc", "smtp.gmail.com".
    22. SEND - Aussteller: "US", "Google Inc", "Google Internet Authority G2".
    23. SEND - Root: "US", "GeoTrust Inc.", "GeoTrust Global CA"
    24. SEND - TLS-Handshake vollständig
    25. SEND - Verbunden mit dem SMTP-Server
    26. SEND - authentifizieren (Login)...
    27. SEND - Sende Nachricht an <eMail-Adresse>
    28. SEND - Verbindung beendet - 1 Nachricht(en) versandt
    Alles anzeigen

    Getestet mit verschiedenen GMail-Adressen.

    Was zeigt denn deine Log?
  • smtp.gmail.com TLS Port 465
    pop.gmail.com TLS Port 995
    komplette Mailadresse as Username



    Geht wunderbar mit gmail.

    Vielleicht ist das Problem ein Virenscanner/Spamfilter auf deinem PC?
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • Sanyok, gerade mal getestet. Das Logfile zeigt:

    15.03.2015, 19:46:17: FETCH - Empfange Nachrichten
    15.03.2015, 19:46:17: FETCH - Verbinde mit POP3-Server pop.gmail.com auf Port 995
    15.03.2015, 19:46:17: FETCH - Einleitung TLS-Handshake
    >15.03.2015, 19:46:17: FETCH - Zertifikat S/N: 2BF1B34A12670682, Algorithmus: RSA (2048 Bits), ausgestellt von 27.02.2015 20:06:32 bis 28.05.2015, für 1 Host(s): pop.gmail.com.
    >15.03.2015, 19:46:17: FETCH - Besitzer: US, California, Mountain View, Google Inc, pop.gmail.com.
    >15.03.2015, 19:46:17: FETCH - Aussteller: US, Google Inc, Google Internet Authority G2.
    15.03.2015, 19:46:17: FETCH - TLS-Handshake vollständig
    15.03.2015, 19:46:17: FETCH - Verbunden mit dem POP3-Server
    15.03.2015, 19:46:18: FETCH - bestätigt (Standard)
    15.03.2015, 19:46:18: FETCH - 0 Nachricht(en) im Postfach, davon 0 neue
    15.03.2015, 19:46:18: FETCH - Verbindung beendet - 0 Nachricht(en) empfangen
    15.03.2015, 19:46:50: FETCH - Empfange Nachrichten
    15.03.2015, 19:46:50: FETCH - Verbinde mit POP3-Server pop.gmail.com auf Port 995
    15.03.2015, 19:46:50: FETCH - Einleitung TLS-Handshake
    >15.03.2015, 19:46:51: FETCH - Zertifikat S/N: 2BF1B34A12670682, Algorithmus: RSA (2048 Bits), ausgestellt von 27.02.2015 20:06:32 bis 28.05.2015, für 1 Host(s): pop.gmail.com.
    >15.03.2015, 19:46:51: FETCH - Besitzer: US, California, Mountain View, Google Inc, pop.gmail.com.
    >15.03.2015, 19:46:51: FETCH - Aussteller: US, Google Inc, Google Internet Authority G2.
    15.03.2015, 19:46:51: FETCH - TLS-Handshake vollständig
    15.03.2015, 19:46:51: FETCH - Verbunden mit dem POP3-Server
    !15.03.2015, 19:46:52: FETCH - Server meldet Fehler. Die Antwort ist: -ERR [AUTH] Web login required: support.google.com/mail/bin/answer.py?answer=78754
    TheBat! Pro 8.x (64 Bit) • Win 10 Pro x64 • keine PlugIns
  • GwenDragon, auch wenn ich NOD32 vorübergehend ganz ausschalte, klappt es trotzdem nicht. Gleiche Fehlermeldung. Un dich habe in NOD32 extra schon nach den Erfahrungen der letzten Zeit die SSL-Prüfung ausgeschaltet. Mein Konfigurationsfenster sieht etwas anders aus als bei Dir, aber liegt vielleicht daran, dass Du IMAP eingestellt hast. Ansonsten sind die Ports und so weiter die gleichen.
    TheBat! Pro 8.x (64 Bit) • Win 10 Pro x64 • keine PlugIns
  • Also soweit ich das sehen, funktioniert doch der Mailabruf über POP3.
    Aus deinem Log sehe ich das beim Abruf um 19:46:18. Dann kommt ein zweiter Mailabruf gut dreißig Sekunden später, um 19:46:51 und der schlägt dann fehl. Vielleicht einfach eine Sperre seitens Google, dass pro Zeiteinheit nur eine bestimmte Anzahl der Logins erlaubt ist. Prüfe mal, ob The Bat automatisch alle x Minuten Mails abholt (Terminplaner und in den Kontoeigenschaften unter Optionen / Postfachüberprüfung).
  • Ralf Brinkmann schrieb:

    FETCH - Server meldet Fehler. Die Antwort ist: -ERR [AUTH] Web login required: support.google.com/mail/bin/answer.py?answer=78754
    Ich habe das jetzt ausführlicher getestet und kann das Problem nachvollziehen. Mit Drittprogrammen wie AntiVirus etc. hat das nichts zu tun, vielmehr wohl mit der Sicherheitspolitik von Google, denn es liegt in der Tat an der Google-Option "Zugriff für weniger sichere Apps", die näher hier beschrieben ist. Bei mir war sie aktiviert. Ich habe sie jetzt deaktiviert und bekomme seitdem ebenfalls die o.g. Fehlermeldung.

    Nach welchen Kriterien Google welche Apps bzw. Programme als "wenig sicher" einstuft, ist die Frage. Auf der o.g. Seite werden z.B. u.a. Thunderbird und Outlook als Programme aufgeführt, die die neuesten Sicherheitsstandards nicht unterstützen. Ich kann mir vorstellen, dass damit TLS 1.2 gemeint ist. Dann gehört TB! in der Tat auch zu diesen wenig sicheren MUA, denn es unterstützt kein TLS 1.2. Wir haben uns neulich darüber in dem Thread "Welche SSL-Cipher kann The Bat?" unterhalten.

    Laut Changelog wurde ja bekanntlich in v6.2 lediglich die Unterstützung von TLS 1.1 eingefügt. Von TLS 1.2 ist bisher nichts zu hören. In dem o.g. Thread gibt es einen Link zum entsprechenden BT-Wunscheintrag. Hier ist er nochmals: #0000520: Update SSL connections to TLS v1.2 with more secure ciphers + Forward Secrecy. Wer TLS 1.2 braucht, sollte ihn bestätigen.

    Ansonsten muss man momentan bei Google den Zugriff für weniger sichere Apps zu Lasten der Sicherheit aktivieren, um eine Verbindung mittels TB! herstellen zu können. Anders geht's wohl nicht.


    Edit:
    Meine Vermutung wird durch die E-Mail bestätigt, die ich von Google erhalten habe:
    Hallo,

    Vor Kurzem wurde ein Anmeldeversuch in Ihrem Google-Konto blockiert.

    Details zum Anmeldeversuch
    Datum & Uhrzeit: ...
    Standort: ...

    Falls der Anmeldeversuch nicht von Ihnen stammt
    Bitte überprüfen Sie Ihre Seite für die Kontoaktivität unter security.google.com/settings/security/activity auf verdächtige Aktivitäten. Die Person, die versucht hat, sich in Ihrem Konto anzumelden, kennt Ihr Passwort. Wir empfehlen Ihnen daher, das Passwort umgehend zu ändern.

    Falls der Anmeldeversuch von Ihnen stammt
    Sie können zu einer Google-App wie Gmail wechseln, um auf Ihr Konto zuzugreifen (empfohlen), oder Ihre Einstellungen unter google.com/settings/security/lesssecureapps ändern, sodass Ihr Konto nicht mehr durch moderne Sicherheitsstandards geschützt ist.

    Weitere Informationen erhalten Sie unter support.google.com/accounts/answer/6010255.

    Mit freundlichen Grüßen
    Ihr Google Konten-Team

    Also entweder die GMail App nutzen oder die o.g. Option aktivieren.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von sanyok () aus folgendem Grund: Vgl. Edit.

  • Danke fürs Testen. Scheint dann wohl so zu sein.

    MSE, da ist mir wohl ein Fehler passiert. Anscheinend hat sich da der Regelabruf (alle 15 Minuten) und mein händischer Abruf nach Umschalten auf "sicher" überschnitten und ich habe versehentlich beide Logteile mitgeschickt.
    TheBat! Pro 8.x (64 Bit) • Win 10 Pro x64 • keine PlugIns
  • @Ralf Brinkmann
    Nein, mein Konto ist POP3, das ist ein Anzeigefehler der Sprachdatei bei The Bat!.

    @sanyok
    Ich habe gestern ern frisches Test-GMail-Konto beim Gockel erstellt.
    Seltsam, bei mir kommt keine Meldung über irgendwelche unsicheren Apps. Ich kann Mail per POP3 gleich abholen ohne irgendwas freigeben zu müssen.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.