The Bat und Zertifikate

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • The Bat und Zertifikate

    The Bat! Professional Edition
    Version 7.3.6 (64-bit)

    Quellcode

    1. Verbinde mit POP3 ... auf Port 587
    2. Server meldet Fehler. Die Antwort ist: 502 5.5.2
    Die Experten unter euch werden mit der Fehlermeldung auch die Lösung kennen, aber ich kriege ums Verrecken nicht das Konto konfiguriert. Mit Thunderbird war das kein Problem, weil ich da schon bei der Einrichtung des Kontos mein selbst signiertes Zertifikat als Ausnahmeregel importieren konnte. The Bat sträubt sich da heftig und die allwissende Tante hilft mir auch nicht weiter.

    Bitte um Hilfe.
  • BatBoy schrieb:

    mit POP3 ... auf Port 587
    POP3 mit 587? Welcher Server ist das denn? 587 verwendet man normalerweise nur mit SMTP (Nachrichtenversand). Bei POP3 (Nachrichtenempfang) sind's hingegen entweder 110 (bei einer unverschlüsselten und damit nicht empfohlenen Verbindung) oder 995 (bei TLS).

    Du solltest daher deine Einstellungen in den Kontoeigenschaften unter "Transport" überprüfen. Für die bekanntesten Mailprovider haben wir Links zu den Seiten mit Einstellungen in FAQ zusammengefasst.
  • Selbstsignierte SSL-Zetrifikate sind kein Problem solange der Hostname des Mailservers zum Zertifikat passt.
    Da musst du das Zertifikat dann als Eintrag im Zertifikatsadressbuch "Trusted Root CA" hinzufügen.

    Dass POP3 aber nicht auf Port 587 verbindet ist logisch.
    Richtige wäre entweder Port 110 mit STARTTLS oder Port 995 mit SSL.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • Zertifikat installieren

    Eigentlich sollte doch The Bat! meckern, wenn es beim Epfangen doer senden un unbekanntes Zertifikat hat, un dann kannst du es doch zu den Vertrauenswürdigen hinzufügen.
    Ist das bei dir nicht?

    Das öffentliche Zertifikat deines Mailservers herunter laden
    In The Bat! Adressbuch öffnen
    Menü Ansicht -> Zertifikatsdatenbanken
    Den Zweig "Trusted Root CA" wählen
    Ctrl+T für "Neue Adresse"
    Für das Feld "Nachname" die Domain deines Zertifikats wählen
    Reiter "Zertifikate" wählen
    Button "Zertifikat-Import"
    Im Dateifnster die Datei mit dem Zertifikat wählen
    Button "Öffnen"

    Das ist alles.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von GwenDragon ()

  • GwenDragon schrieb:

    In The Bat! Adressbuch öffnen
    Menü Ansicht -> Zertifikatsdatenbanken
    Den Zweig "Trusted Root CA" wählen
    Vielen, vielen Dank für Deine Erklärung, jetzt habe ich zumindest mal die Zertifikate gefunden. Mein Zertifikat ist auch dabei.


    GwenDragon schrieb:

    Eigentlich sollte doch The Bat! meckern, wenn es beim Epfangen doer senden un unbekanntes Zertifikat hat, un dann kannst du es doch zu den Vertrauenswürdigen hinzufügen.
    Ist das bei dir nicht?
    Einzig den Fehler 502 5.5.2 schreibt mir The Bat ins Logfile. Ein ungültiges Zertifikat wird nicht bemängelt. Jetzt lese ich hier, dass die Zertifikatsdatenbank "Trusted Root CA" die Zertifikate verwaltet, diese aber, um als vertrauenswürdig zu gelten, in den windowseigenen Zertifikatsspeicher importiert werden müssen. Korrekt, oder ist das ein Holzweg?
  • BatBoy schrieb:

    Einzig den Fehler 502 5.5.2 schreibt mir The Bat ins Logfile. Ein ungültiges Zertifikat wird nicht bemängelt.
    Sieht nach einem Authentifizierungsproblem aus.
    Wie ist die Fehlermeldung?

    BatBoy schrieb:

    Jetzt lese ich hier, dass die Zertifikatsdatenbank "Trusted Root CA" die Zertifikate verwaltet, diese aber, um als vertrauenswürdig zu gelten, in den windowseigenen Zertifikatsspeicher importiert werden müssen. Korrekt, oder ist das ein Holzweg?
    Kein Holzweg, das ist auch eine weitere Lösung.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • GwenDragon schrieb:

    BatBoy schrieb:

    Einzig den Fehler 502 5.5.2 schreibt mir The Bat ins Logfile. Ein ungültiges Zertifikat wird nicht bemängelt.
    Sieht nach einem Authentifizierungsproblem aus.
    Ich schäme mich. Eigentlich hätte ich schon mit den Hinweis von sanyok in Post 2 auf meine Fehlkonfiguration kommen sollen, aber ich habs nicht gesehen. Eingang und Ausgang vertauscht, das war es. Kommt wohl davon, dass ich jahrelang mit Thunderbird gearbeitet habe. Da wird nämlich zuerst der Posteingang und dann der -ausgang konfiguriert. In The Bat ist das genau andersrum. Wer lesen kann ist tatsächlich klar im Vorteil.

    Vielen Dank für eure Hilfen.
  • BatBoy schrieb:

    Asche auf mein Haupt. Der Provider bin ich selbst.
    Hahaha, hihihi. Das staubt bestimmt, das graue Zeugs. Aber bitte nicht vor dem Server machen, der hustet dann so beim Betrieb. ;)

    Da muss ich als Admina mehrerer Mailserver schon leicht facepalmen.
    Bei sowas schau ich doch erst mal in Logfile des eigenen Mailservers wenn es hakt. Und 502 5.5.2 ist doch auch ziemlich eindeutig.

    Aber du hast es ja doch noch gemerkt.
    Kein Problem, Menschen machen Fehler und sind auch mal unaufmerksam. :)
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • Als Versuch meiner Ehrenrettung möchte ich doch anmerken, dass die Fehlkonfiguration nicht serverseitig war. Den Eintrag im Maillog:

    Quellcode

    1. postfix/smtpd[1469]: < -.t-ipconnect.de[91.56.-]: CAPA
    2. postfix/smtpd[1469]: > -.t-ipconnect.de[91.56.-]: 502 5.5.2 Error: command not recognized
    sehe ich zum ersten Mal. Verstehen kann ich den noch nicht. Im Leben nicht wäre ich auf die Idee gekommen, dass "CAPA" auf eine Fehlkonfiguration des Clients hinweist. Die Spur mit den Zertifikaten habe ich nur deswegen aufgenommen, weil ich im Client keine Zertifikate gefunden habe. Auf die Idee, im Adressbuch auf Ansicht zu klicken, bin ich einfach nicht gekommen. Da warst Du mir eine große Hilfe. Dankeschön.
  • BatBoy schrieb:

    Da wird nämlich zuerst der Posteingang und dann der -ausgang konfiguriert
    Wenn man den Einrichtungsassistenten startet ("Konto | Neu..."), wird in TB! ebenfalls zuerst der Posteingang und danach der Postausgang eingerichtet. Oder wie hast du das Mailkonto erstellt?


    BatBoy schrieb:

    502 5.5.2 Error: command not recognized
    Im Internet gibt's genug Einträge dazu. Die meisten deuten auf eine Falschkonfiguration hin.
  • @BatBoy Was soll der arme Postfix auch als SMTP-Server mit POP3-Befehlen anfangen?
    Das weiß man, wenn man länger Server betreibt und mit Mailclients zu tun hat.

    Pass schön auf deine Ehre auf, dass sie nicht Drachenfeuer fängt und du anschröllst ;)


    Und eigentlich kann man, wenn man es nicht gerade extrem eilig hat oder zu wenig 0xCAFEE intus oder völlig abgelenkt ist, The Bat! gar nicht fehlokonfigurieren.
    Na ja. Passiert halt doch.

    Ansonsten, ich helf doch gern :)
    Auch, wenn nicht zu umfangreich, bei Serverproblemen.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • sanyok schrieb:

    Im Internet gibt's genug Einträge dazu. Die meisten deuten auf eine Falschkonfiguration hin.

    sanyok schrieb:

    BatBoy schrieb:

    Da wird nämlich zuerst der Posteingang und dann der -ausgang konfiguriert
    Wenn man den Einrichtungsassistenten startet ("Konto | Neu..."), wird in TB! ebenfalls zuerst der Posteingang und danach der Postausgang eingerichtet. Oder wie hast du das Mailkonto erstellt?

    BatBoy schrieb:

    502 5.5.2 Error: command not recognized
    Im Internet gibt's genug Einträge dazu. Die meisten deuten auf eine Falschkonfiguration hin.
    Ich hatte zunächst einen Freemail-Provider konfiguriert. Das ging mit dem Assistenten flott. Später dann das Konto angepasst. Wie man das so macht, mit TAB durch die Einstellungen gerauscht, String-v für die Adresse, Ports eingegeben, Zertifikat weiß ich gar nicht mehr, Nachrichten abholen, Bämm: 502 5.5.2. Such mal mit google nach "The Bat" +502 +5.5.2. Zertifikat gesucht, nichts gefunden, Holzweg. Aber nun ist ja alles gut.
  • Dafür ist unser The Bat!-Forum immer ganz nützlich. Manchmal machen Nutzende seltsame Fehler und hängen dann fest, weil sie das Vorgehen von anderen Programmen anders kennen oder eben wie du schnell was rüber kopiert haben.

    Freu dich, dass es jetzt geht.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.