Adressbuch mit CardDav synchronisieren

  • Adressbuch mit CardDav synchronisieren

    Hallo Community,

    ich probiere grade TB aus und habe ein Problem mit Adressbuch mit meinem Zimbra Adressbuch via CardDav zu synchronisieren.

    Serverseitig sollte alles klappen, da andere EmailClients und auch meine Android-Geräte die Synchronisation hinbekommen.

    The Bat! schafft es aber leider nicht. Meine Serverlogs zeigen nicht mal einen Verbindungsversuch. <X

    Hier einmal die Fehlermeldungen aus dem Log von The Bat!:

    Quellcode

    1. 12.05.2017 15:17:02 HTTP request - OPTIONS https://hostname/dav/username/Contacts
    2. 12.05.2017 15:17:02 Anfrage konnte nicht ausgeführt werden. Verbindungsfehler
    3. 12.05.2017 15:17:02 CardDAV - Sende PROPFIND für "current-user-principal"
    4. 12.05.2017 15:17:02 HTTP request - PROPFIND https://hostname/dav/username/Contacts
    5. 12.05.2017 15:17:02 Anfrage konnte nicht ausgeführt werden. Verbindungsfehler
    6. 12.05.2017 15:17:02 CardDAV - kein Ergebnis für Suche nach "current-user-principal"
    7. 12.05.2017 15:17:02 CardDAV - CardDAV - empfange Entity Tags von https://hostname/dav/username/Contacts
    8. 12.05.2017 15:17:02 HTTP request - PROPFIND https://hostname/dav/username/Contacts
    9. 12.05.2017 15:17:02 Anfrage konnte nicht ausgeführt werden. Verbindungsfehler
    10. 12.05.2017 15:17:02 CardDAV - CardDAV - keine Entity Tags empfangen
    11. 12.05.2017 15:17:02 CardDAV - Synchronisation beendet (0 heruntergeladen, 0 hochgeladen, 0 gelöscht)
    Alles anzeigen

    Die Host und Userdaten habe ich für das Posting hier geändert.

    Hat jemand eine Idee? Das Forum bietet bisher leider nichts.

    Danke und Gruß
    Kai

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von GwenDragon ()

  • bei einem getesteten Horde ist die URL https://webmail.******.de/rpc.php/principals/test@******.de/
    Funktioniert, die Synchronsierung vom WebCard → The Bat!.
    TheBat! Pro 7.x BETA (32bit) • Win 10 Pro x64 • GnuPG 2.0.x • XMP,Regula


    Ich bin Gwendolyn. Wer mich der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von GwenDragon ()

  • @GwenDragon, danke für Deine Mühe,

    das werde ich tun. Ich werde nur vorher noch einmal die 32bit Version testen.
    Da Du auf 32bit bist und anscheinend zumindest mit Horde keine Probleme hast. Bei mir scheint nicht mal ein Packet den Rechner zu verlassen, es kommt gleich die Fehlermeldung, also bezweifel ich, dass es an meinem Zimbra liegt, der mit anderen Clients gerne zusammenspielt...

    Gruß
    Kai
  • Mir scheint es so, als ob The Bat entweder Probleme mit SNI oder aber mit meinen Serversettings in Bezug auf SSL hat, die sind sehr strickt und erlauben kaum Abwärtskompatibilität... Der Syn kommt auf Netzwerkebene noch zustande, aber dann gibt es einen Reset.
    Habe es testweise mal mit Baikal ausprobiert, das gleiche Problem, daher denke ich mal es liegt am SSL...
  • Ok, nach ein wenig probieren habe ich es nun.

    The Bat! zickt bei zu neuen Ciphern.

    Aktuell will mein Server folgendes durchsetzen:

    ssl_protocols TLSv1.2;
    ssl_ciphers EECDH+AESGCM:EECDH+AES;

    damit funktioniert es nicht. Lockert man die Bedingungen bekommt man einen connect und die Anzeige das 70 (oder wie viele auch immer) Kontakte heruntergeladen wurden.

    Leider bleibt das Adressbuch leer.
    Der Upload klappt....

    Gruß
    Kai