Schnellvorlage Datei anfügen funktioniert nicht

  • Schnellvorlage Datei anfügen funktioniert nicht

    Habe nach Vorgabe eine Schnellvorlage erstellt, die früher mal das Verzeichnis zum Auswählen von Nachrichten öffnete.
    Nun passiert jedoch gar nichts. Was ist falsch?

    Quellcode

    1. %_FL=#%XMP_DlgOpen(1,"Attachments öffnen...","C:\")#%-
    2. %_FC=#%XMP_StrItemCnt("%_FL","|")#%-
    3. %IF:$%_FC$>$0$:$Anlagen:
    4. %XMP_For("x","1","%_FC","%-
    5. %%_FN=#%%XMP_StrItem('%%_FL','|','%%_x')#%-
    6. %%_FS=#%%XMP_FileSize('%%_FN') Byte, %-
    7. %%XMP_FileName('%%_FN','T')#%-
    8. %%ATTACHFILE('%%_FN')%-
    9. %%XMP_StrIns(' ','%%_x','R')) %-
    10. %%XMP_FileName('%%_FN') (%%_FS)
    11. ")$:$$
    Alles anzeigen
    //modedit: Code korrekt eingesetzt, Post verschoben.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von GwenDragon ()

  • Geht bei mir mit 7.4.16 32bit auf Win 10.

    Ich habe die Schnellvorlage als Gemeinsame Vorlage mit dem Kürzel datei angelegt im Format Text.
    Wenn ich datei in den Mailbody eingebe und Ctrl+Leertaste eingebe, öffnet bei mir die Dateiauswahl, nach Auswahl einer Datei wird die auch als Anhang samt Text für Größe und Art eingefügt.

    XMP geht nur mit The Bat! 32bit. Außerdem braucht es im Programmordner von The Bat! die Datei pcre.dll.
    Und hast du XMP auch in The Bat! als Plugin angemeldet?



    Ach so, ja:
    Schnellvorlage in HTML geht nicht. Ist ein Bug mit MAkros und HTML :(
    Siehe BUG: bt.ritlabs.com/view.php?id=521
    TheBat! Pro 7.x BETA (32bit) • Win 10 Pro x64 • GnuPG 2.0.x • XMP,Regula


    Ich bin Gwendolyn. Wer mich der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von GwenDragon ()

  • GwenDragon schrieb:

    XMP geht nur mit The Bat! 32bit. Außerdem braucht es im Programmordner von The Bat! die Datei pcre.dll.Und hast du XMP auch in The Bat! als Plugin angemeldet?

    Ach so, ja:
    Schnellvorlage in HTML geht nicht. Ist ein Bug mit MAkros und HTML :(
    Siehe BUG: bt.ritlabs.com/view.php?id=521
    Hm... habe 64bit... Dann wirds so wohl leider nix mehr? Schade, in der alten Version ging es ja bei 64bit...
    Mail wäre "nurText", als Plugin angemeldet? ka, denke nicht aber wie egesagt, wenns unter 64bit eh nicht geht... :( :(
  • Wichtelmann schrieb:

    Hm... habe 64bit... Dann wirds so wohl leider nix mehr? Schade, in der alten Version ging es ja bei 64bit...
    64-Bit Windows oder 64-Bit TB!? Unter 64-Bit TB! kann man das XMP Plug-in nicht einbinden. Es klappt daher mit keiner 64-Bit TB! Version und hat auch nie. Mehr zum XMP 64-Bit im Thread "XMP 64-Bit". Es wird also keine geben.

    Benutzt du hingegen zwar eine 64-Bit Windows-, jedoch eine 32-Bit TB!-Version, dann kannst du das Plug-in einbinden. Dass es dennoch nicht klappt, könnte aber an dem o.g. Bug liegen.
  • sanyok schrieb:

    Wichtelmann schrieb:

    Hm... habe 64bit... Dann wirds so wohl leider nix mehr? Schade, in der alten Version ging es ja bei 64bit...
    64-Bit Windows oder 64-Bit TB!? Unter 64-Bit TB! kann man das XMP Plug-in nicht einbinden. Es klappt daher mit keiner 64-Bit TB! Version und hat auch nie. Mehr zum XMP 64-Bit im Thread "XMP 64-Bit". Es wird also keine geben.
    Benutzt du hingegen zwar eine 64-Bit Windows-, jedoch eine 32-Bit TB!-Version, dann kannst du das Plug-in einbinden. Dass es dennoch nicht klappt, könnte aber an dem o.g. Bug liegen.

    The Bat! Professional Edition
    Version 7.4.16 (64-bit)
    Copyright © 1998-2017 Ritlabs, SRL
    Alle Rechte vorbehalten.
  • Wichtelmann schrieb:

    Gibts denn irgendwelche anderen Nachteile mit TB32bit?
    Wieso Nachteile? XMP funktioniert ja mit TB! 32-Bit. Und vom o.g. Bug #0000521 sind sowohl 32- als auch 64-Bit TB!-Versionen betroffen. Schließlich kann man Makros ja auch ohne XMP verwenden.


    Wichtelmann schrieb:

    Kann ich das ggf noch korrigieren?
    Du könntest den o.g. Eintrag im BT bestätigen. Wie es geht, steht im Thread "BugTracker-Verwendung".


    Wichtelmann schrieb:

    Hatte glaube ich in der 5er Vorgängerversion auch Anti Virus und Junk Plugins aktiviert...
    TB! 64-Bit kam erst mit v6.7. v5.x war nur als 32-Bit verfügbar. Da konntest du natürlich XMP problemlos einbinden und verwenden.
  • Das was du da machen willst, geht nur mit XMP-Plugin. Die Vorlage oben hat ja %XMP_… Makros drin, also brauchst du es dazu.
    Das geht nur mit The Bat! 32bit. Deinstalliere die 64bit und Installiere die 32bit.
    TheBat! Pro 7.x BETA (32bit) • Win 10 Pro x64 • GnuPG 2.0.x • XMP,Regula


    Ich bin Gwendolyn. Wer mich der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • Wichtelmann schrieb:

    Du sagtest ja Makros funktionieren auch ohne...
    Es gibt Makros, die von TB! bereits standardmäßig ohne jegliche Plug-Ins funktionieren. Die offizielle Makros-Liste mit Erklärungen findet man in der Online-Hilfe. Deine Vorlage besteht aber aus XMP-Makros und wird daher ohne XMP nicht funktionieren.

    Du hast daher zwei Möglichkeiten. Entweder, wie von Gwen vorgeschlagen, steigst du von TB! 64- auf TB! 32-Bit um und verwendest deine Vorlage mit dem XMP Plug-in. Oder du bleibst bei TB! 64-Bit, musst aber deine Vorlage anpassen, also nur die von TB! unterstützten Makros verwenden. Ob das überhaupt geht, weiß ich allerdings nicht. Schließlich wurde XMP ja entwickelt, weil TB! selbst nicht alles kann.