[erledigt] [Bug] Falsches Erstellt-Datum, wenn DATE im Header fehlt

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • [erledigt] [Bug] Falsches Erstellt-Datum, wenn DATE im Header fehlt

    Es kommt ab und zu vor, dass man eine Nachricht erhält, bei der das Nachrichtenkopfdatenfeld (Header) DATE fehlt, also z.B.

    Quellcode

    1. Date: Sun, 28 Jan 2018 09:04:08 +0100 (CET)

    In TB! wird dieses Datum in der Spalte "Erstellt" angezeigt. Damit die Spalte nicht leer bleibt, zeigt z.B. Thunderbird stattdessen das RECEIVED, also Erhalten-Datum. Das ist immer noch besser als das, was TB! macht, denn es zeigt dort z.B. 31.12.1899 an. Abgesehen davon, dass damals noch keine eMails existierten, führt das dazu, dass diese eigentlich neue Nachricht im Ordner mit mehreren Nachrichten wegen eines so alten Datums ganz am anderen Ende angezeigt wird und daher nicht sofort gefunden werden könnte, falls man nach "Erstellt" sortiert. IMO sollte TB! das daher zumindest wie Thunderbird handhaben.

    Getestet mit v7.4.16, v8.2.4 und v8.2.4.2. Dieses Verhalten habe ich aber auch schon vor Jahren mit sehr alten TB!-Versionen bemerkt, so dass es wohl bei TB! schon immer so war.

    Im BT habe ich eine Test-Mail angehängt, die man importieren könnte. Alternativ kann man auch selbst so eine Mail erstellen. Einfach irgendeine Nachricht erstellen, auf "Als Entwurf speichern" klicken, im Ordner AUSGANG die betreffende Nachricht markieren und als eine EML-Datei speichern, sie danach mit einem Text-Editor öffnen und dort die komplette Zeile Date: ... löschen, speichern und die EML anschließend in TB! importieren. In der Spalte "Erstellt" müsste dann das o.g. Datum stehen.