8.5.4 protocol error BuildClientKeyExchange

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • 8.5.4 protocol error BuildClientKeyExchange

    Hi Leute,

    Quellcode

    1. [-] TLS protocol error: Internal error BuildClientKeyExchange (BETA issue)
    Das hier hat jetzt mich erwischt. Seit heute mit der "8.5.4".

    Leider kann ich, außer den Meldungen zur Behebung des Problems, keine relevanten Sachen finden. Was hat es damit auf sich und gibt es ein Lösung die ich selbst umsetzen kann? Kann man TheBat auch downgraden?

    Vielen Dank und schönen Tag noch.
    adios, Stefan

    [modedit] Thread verschoben

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von GwenDragon ()

  • Du kannst auf geschlossen Threads alter Versionen nicht antworten. Eigentlich solltest du auch bei Problemen mit Final-Versionen von The Bat! dann korrekterweise unter Therapieplatz Version 8.x nachfragen.

    Geht es hier um Voyager oder The Bat!? Und welche Version genau?
    Verwendest du ein Programm, dass die SSL-Verbindung (Antivirus, Desktopfirewall, Internet Security Suite) überwacht?
    Welcher Server ist das?
    Kannst du bitte den Bug an Ritlabs Maxim Masiutin <max@ritlabs.com> melden?

    Du könntest The Bat! auch mal über den Kommandozeilenparamter thebat....exe /DISABLE_TLS12 starten.
    Gehts dann?
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von GwenDragon ()

  • Hallo Lilo,

    danke für die schnelle Antwort. Die Benachrichtigungen habe ich wohl ausgeschaltet, hab's nicht mitbekommen.

    1. Es geht um The Bat! Professional Edition Version 8.5.4 (64-bit)
    2. Als Scanner benutze ich ein Avira, ich glaube aber nicht, dass das die SSL-Verbindungen hackt. Oder doch? Muss ich rausfinden.
    3. Die Gegenstelle ist ein dedi bei Hetzner.
    4. thebat64.exe /DISABLE_TLS12 hat leider nicht geklappt
    5. Ticket bei Ritlabs steht noch aus, kommt ganz darauf an wie es sich weiterentwickelt.


    tschüss, Stefan

    Nachtrag:

    Quellcode

    1. 05.07.2018, 13:58:09: IMAP - Verbinde zum IMAP-Server dedixxx.your-server.de auf Port 993
    2. 05.07.2018, 13:58:09: IMAP - Einleitung TLS-Handshake
    3. >05.07.2018, 13:58:09: IMAP - Zertifikat S/N: 04CDA2809408117ABF92E3C27E37C4D7, Algorithmus: RSA (2048 Bits), ausgestellt von 18.06.2018 bis 03.11.2018 12:00:00, für 2 Host(s): *.your-server.de, your-server.de.
    4. >05.07.2018, 13:58:09: IMAP - Besitzer: "*.your-server.de".
    5. >05.07.2018, 13:58:09: IMAP - Aussteller: "US", "DigiCert Inc", "www.digicert.com", "RapidSSL TLS RSA CA G1". Gültig ab 02.11.2017 12:24:33 bis 02.11.2027 12:24:33.
    6. >05.07.2018, 13:58:09: IMAP - Root: "US", "DigiCert Inc", "www.digicert.com", "DigiCert Global Root G2" Gültig ab 01.08.2013 12:00:00 bis 15.01.2038 12:00:00.
    7. 05.07.2018, 13:58:09: IMAP - TLS-Handshake vollständig
    8. 05.07.2018, 13:58:09: IMAP - Verbunden mit IMAP-Server (dedixxx.your-server.de)
    9. >05.07.2018, 13:58:09: IMAP - Courier-IMAP ready. Copyright 1998-2011 Double Precision, Inc. See COPYING for distribution information.
    10. 05.07.2018, 13:58:09: IMAP - Authentifiziere (Benutzer: "xxx@xxx.de", Methode: "LOGIN")...
    11. 05.07.2018, 13:58:09: IMAP - IMAP-Server Authentifikation OK - IMAP-Server meldet: "LOGIN Ok."
    12. 05.07.2018, 13:58:59: SEND - Sende Nachricht(en) - 1 Nachricht(en) in der Warteschlange
    13. 05.07.2018, 13:58:59: SEND - Verbinde mit SMTP-Server xxx.your-server.de auf Port 465
    14. 05.07.2018, 13:58:59: SEND - Einleitung TLS-Handshake
    15. >05.07.2018, 13:58:59: SEND - Zertifikat S/N: 04CDA2809408117ABF92E3C27E37C4D7, Algorithmus: RSA (2048 Bits), ausgestellt von 18.06.2018 bis 03.11.2018 12:00:00, für 2 Host(s): *.your-server.de, your-server.de.
    16. >05.07.2018, 13:58:59: SEND - Besitzer: "*.your-server.de".
    17. >05.07.2018, 13:58:59: SEND - Aussteller: "US", "DigiCert Inc", "www.digicert.com", "RapidSSL TLS RSA CA G1". Gültig ab 02.11.2017 12:24:33 bis 02.11.2027 12:24:33.
    18. >05.07.2018, 13:58:59: SEND - Root: "US", "DigiCert Inc", "www.digicert.com", "DigiCert Global Root G2" Gültig ab 01.08.2013 12:00:00 bis 15.01.2038 12:00:00.
    19. !05.07.2018, 13:58:59: SEND - TLS-Protokollfehler: Interner Fehler BuildClientKeyExchange
    Alles anzeigen
  • Vielleicht ist Bug in der 64bit The Bat!? Ich hab nur 32bit.
    Ob Avira eine Mai Protection bei SSL hat, musst du rausfinden. Ich schalte jegliche Scan bei SSL immer bei meinem Antivirus ab.

    IMAP klappt bei dir, aber SMTP nicht.
    Aha, Root-Server. Ist das deiner? Spezielle Postfix-Konfig oder ist das Exim?
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • > Vielleicht ist Bug in der 64bit The Bat!?

    Vielleicht. Kann ich den z.B. einfach eine frühere Version "drüberbügeln"? Wenn ja, wo kann ich den ältere Versionen runterladen? Enthält das Backup von TheBat eigentlich alle Einstellungen etc, damit ich mich wiederherstellen könnte falls das schiefgeht?

    Exim. Ja, ist meiner, ein Managed Server bei Hetzern, wenn die Sonderbarkeiten im Mailsystem haben, weiß ich das nicht.
  • Ich wüsste nicht wie du an die alten versionen kommst.
    Probier doch mal:
    Deinstalliere die 64bit
    installiere die 32bit der 8.5.4,
    dann kannst du schauen ob es an 64bit liegt. Hat keine Nachteile.

    Wenn es dein Server ist, erstelle doch den Ritlabsern nach dem Melden des Bugs ein Testmailkonto.
    Sowas habe ich auch bei meinem Hetzer-Root gemacht, damit die testen konnten.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • Ich habe den gleichen Fehler auch und bin zurück auf die 8.5.2, da geht es wieder.

    Nachtag: Ich habe gerade gerade gesehen, dass der OP wohl auch bei Hetzner ist (Mail-Server mail.your-server.de).

    Vielleicht liegts auch daran. Ich versuchs mal mit der 32Bit und melde mich dann wieder.
    Schöne Grüße
    IABC
    --
    Windows 7 x64 SP1 / Windows 10 x64

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von IABC ()

  • Ältere Versionen bekommst du hier:

    ritlabs.com/de/products/thebat/archive-versions.php

    Drüberinstallieren geht nicht. Du musst in das TheBat-Verzeichnis gehen und dort die thebat64.exe löschen oder umbenennen (z.B. thebat64.old). Dann bügelst du den Installer der 8.5.2 einfach drüber. d.h. du wählst dann Reparieren. Danach ist die ältere Version wieder drauf.


    Nachtrag: Mit der 32Bit-Version geht es auch nicht:

    Quellcode

    1. 05.07.2018, 19:25:34: SEND - Sende Nachricht(en) - 1 Nachricht(en) in der Warteschlange
    2. 05.07.2018, 19:25:34: SEND - Verbinde mit SMTP-Server mail.your-server.de auf Port 465
    3. 05.07.2018, 19:25:35: SEND - Einleitung TLS-Handshake
    4. >05.07.2018, 19:25:35: SEND - Zertifikat S/N: 04CDA2809408117ABF92E3C27E37C4D7, Algorithmus: RSA (2048 Bits), ausgestellt von 18.06.2018 bis 03.11.2018 12:00:00, für 2 Host(s): *.your-server.de, your-server.de.
    5. >05.07.2018, 19:25:35: SEND - Besitzer: "*.your-server.de".
    6. >05.07.2018, 19:25:35: SEND - Aussteller: "US", "DigiCert Inc", "www.digicert.com", "RapidSSL TLS RSA CA G1". Gültig ab 02.11.2017 12:24:33 bis 02.11.2027 12:24:33.
    7. >05.07.2018, 19:25:35: SEND - Root: "US", "DigiCert Inc", "www.digicert.com", "DigiCert Global Root G2" Gültig ab 01.08.2013 12:00:00 bis 15.01.2038 12:00:00.
    8. !05.07.2018, 19:25:35: SEND - TLS-Protokollfehler: Interner Fehler BuildClientKeyExchange
    9. 05.07.2018, 19:25:48: SEND - Sende Nachricht(en) - 1 Nachricht(en) in der Warteschlange
    10. 05.07.2018, 19:25:48: SEND - Verbinde mit SMTP-Server mail.your-server.de auf Port 465
    11. 05.07.2018, 19:25:48: SEND - Einleitung TLS-Handshake
    12. >05.07.2018, 19:25:48: SEND - Zertifikat S/N: 04CDA2809408117ABF92E3C27E37C4D7, Algorithmus: RSA (2048 Bits), ausgestellt von 18.06.2018 bis 03.11.2018 12:00:00, für 2 Host(s): *.your-server.de, your-server.de.
    13. >05.07.2018, 19:25:48: SEND - Besitzer: "*.your-server.de".
    14. >05.07.2018, 19:25:48: SEND - Aussteller: "US", "DigiCert Inc", "www.digicert.com", "RapidSSL TLS RSA CA G1". Gültig ab 02.11.2017 12:24:33 bis 02.11.2027 12:24:33.
    15. >05.07.2018, 19:25:48: SEND - Root: "US", "DigiCert Inc", "www.digicert.com", "DigiCert Global Root G2" Gültig ab 01.08.2013 12:00:00 bis 15.01.2038 12:00:00.
    16. !05.07.2018, 19:25:49: SEND - TLS-Protokollfehler: Interner Fehler BuildClientKeyExchange
    Alles anzeigen
    Mit meinem T-Online-Konto geht es, es muss also wohl mit dem Server von Hetzner zu tun haben.
    Schöne Grüße
    IABC
    --
    Windows 7 x64 SP1 / Windows 10 x64

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von IABC ()

  • Vielen Dank.

    Hat aber scheinbar funktioniert. Mails kann ich wieder verschicken.

    Unter ritlabs.com/de/products/thebat/archive-versions.php findet man nur bis 7.x.

    Das macht aber nichts, ich habe den letzten Download noch gefunden v8.5.2. Die thebat64.exe habe ich entfernt und den Installer laufen lassen. Eine "Reparatur" hat er mir nicht angeboten.

    Wenn ich das changelog für die 8.5.4er anschaue, geht es ja hauptsächlich um TLS.

    Quellcode

    1. TLS 1.2. Folgende Verschlüsselungssammlungen werden unterstützt:
    2. TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256 TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHATLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA TLS_ECDHE_RSA_WITH_AES_128_CBC_SHATLS_RSA_WITH_AES_256_CBC_SHA256 TLS_RSA_WITH_AES_128_CBC_SHA256 TLS_RSA_WITH_AES_256_CBC_SHATLS_RSA_WITH_AES_128_CBC_SHA SSL_RSA_WITH_RC4_128_SHA SSL_RSA_WITH_3DES_EDE_CBC_SHASSL_RSA_WITH_RC4_128_MD5

    Kann man den aus dem Protokollauszug mit dem Hetznerserver rauslesen, welche Methode verwendet wurde?

    hasta luego, Stefan
  • Gerade habe ich analysiert:
    Hetzners mail.your-server.de kann diese:
    * TLSv1_2 DHE-RSA-AES256-GCM-SHA384
    * TLSv1_2 ECDHE-RSA-AES256-GCM-SHA384
    * TLSv1_2 DHE-RSA-AES128-GCM-SHA256
    * TLSv1_2 ECDHE-RSA-AES128-GCM-SHA256
    * TLSv1_2 DHE-RSA-AES256-SHA256
    * TLSv1_2 DHE-RSA-AES256-SHA
    * TLSv1_2 DHE-RSA-CAMELLIA256-SHA
    * TLSv1_2 ECDHE-RSA-AES256-SHA384
    * TLSv1_2 ECDHE-RSA-AES256-SHA
    * TLSv1_2 DHE-RSA-AES128-SHA256
    * TLSv1_2 DHE-RSA-AES128-SHA
    * TLSv1_2 DHE-RSA-CAMELLIA128-SHA
    * TLSv1_2 ECDHE-RSA-AES128-SHA256
    * TLSv1_2 ECDHE-RSA-AES128-SHA
    * TLSv1_2 AES256-SHA
    * TLSv1_2 AES128-SHA
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • Ich kann dazu nix sagen, weil ich meine Hetzern-Root-Server bei IMAP und SMTP selbst konfiguriert habe und die TLS-Chiffren passen.

    Dann frage doch mal den Hetzner-Support, vielleicht ist da wirklich was nicht korrekt bei denen, du zahlst ja für deinen Managed Server.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • Der Support von Hetzner frägt nach, ob ich den im Client Einstellungen dazu hätte.

    In den Einstellungen konnte ich jetzt nix finden. Aber es gibt ja offensichtlich Kommandozeilen Parameter, von denen ich bisher auch nichts wusste.

    Wo gibt es den eine Übersicht über die verfügbaren Parameter und gibt es dort vielleicht Schalter die das Verhalten bezüglich TLS beeinflussen?

    /DISABLE_TLS12 hat bei mir keinen Auswirkung die ich erkennen könnte.