Signatur aus HTML einfügen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Signatur aus HTML einfügen

    modedit: abgeteilt von [Bug erledigt] HTML-Vorlagen inkompatibel, müssen anders geschrieben werden

    Nachdem das hier als gelöst angezeigt wird, kann mir mal jemand einen Tipp geben? Bei mir funktioniert %include weiterhin nicht in 8.6.
    Ich hab mir auch BT521 und BT1377 durchgelesen, aber ehrlich gesagt nur die Hälfte verstanden. Bei mir gehts auch nicht um Makros, ich will einfach eine statische Signatur anhängen. Signatur wurde in Textmaker und testweise auch Word erzeugt und als html abgespeichert. In 8.0.18 funktionierts noch. In den neueren Versionen kommt die neue mail dann mit

    HTML-Quellcode

    1. <!DOCTYPE html>
    2. <html lang="en" xml:lang="en" xmlns="http://www.w3.org/1999/xhtml">
    3. <head>
    4. <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    5. <meta charset="UTF-8" />
    6. <title></title>
    7. ...


    anstatt der Adresse. Der Ordner steht wie bisher in den Eigenschaften unter Format auf "Html (Rich Text)".
    Müsst ich da im Quellcode der html was verändern? Wäre einfacher als in allen Ordnern die Dateiverknüpfung gegen die Templates auszutauschen...

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von GwenDragon () aus folgendem Grund: Abteilung nach Theraplatz 8.x

  • %INCLUDE funktioniert nicht mit HTML-Dateien.

    Warum erzeugst du denn die Signatur nicht als in The Bat!-Schnellvorlage mit Kürzel sig1 o.ä. im HTML (Rich Text)-Format?
    Und in deiner Nachrichtehn-Vorlage (HTML-Format) mit %QINCLUDE="sig1" einfügen.

    Bei mir klappt das wenn Mails im Editor als HTML formatiert gesetzt sind.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von GwenDragon ()

  • bis einschliesslich 8.0.18 funktionierts mit HTML und das schon gefühlt 10 Jahre...

    Text wieder gelöscht, ich habs kapiert. Schnellvorlage war für mich immer manuell einfügen. QINCLUDE nimmt statt ner Datei eine Schnellvorlage und die ist so automatisierbar.Funktioniert dann auch in 8.6.
    Danke, das hilft. Auch wenn ich nicht verstehe, was das Problem ist, daß INCLUDE auf einmal nicht mehr HTML kann. Die Lösung mit einer Datei zentral für mehrere PCs hat mir besser gefallen.
  • @Dreggen Stimmt!, in der 7er gings noch eine HTML-Datei per Include in Vorlagen zu importieren.
    Ob das aber so vorgesehen war?

    Aber du kannst dich gern an Ritlabs wenden zwecks Support/Bug. Würde mich interessieren was die sagen.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • Und sieh da, es ist vollbracht: The Bat! 8.6.0.8 (BETA)

    Gerade getestet, fügt auch sowas ein:

    HTML-Quellcode

    1. <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN"
    2. "http://www.w3.org/TR/html4/strict.dtd">
    3. <html>
    4. <head>
    5. <meta http-equiv="content-type" content="text/html; charset=utf-8" />
    6. <title>HTML page</title>
    7. </head>
    8. <body>
    9. <p>Das ist ein Text.</p>
    10. <img src="%MAILDIR\a.jpg">
    11. </body>
    12. </html>
    Alles anzeigen
    Da ist dann Text und Bild drin :)
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von GwenDragon ()

  • Neu

    hab am Freitag die Nachricht bekommen, daß es behoben ist und mir noch Links zur Beta geschickt werden. GwenDragon war da wohl schneller als der Support :)

    War ja irgendwie klar, nachdem ich jetzt nach fast einem Jahr warten einen Workaround gefunden habe und schon 2 Konten auf die Schnellvorlagen umgestellt habe, wird der Bug dann doch repariert. Weiss grad nicht, ob ich mich freuen oder ärgern soll :)

    Danke auf jedenfall und das Problem ist dann wohl gelöst.
  • Neu

    Dreggen schrieb:

    hab am Freitag die Nachricht bekommen, daß es behoben ist und mir noch Links zur Beta geschickt werden.
    Ja, ist doch gut, dass der support auch öfters mal gut klappt.

    Dreggen schrieb:

    War ja irgendwie klar, nachdem ich jetzt nach fast einem Jahr warten einen Workaround gefunden habe und schon 2 Konten auf die Schnellvorlagen umgestellt habe, wird der Bug dann doch repariert. Weiss grad nicht, ob ich mich freuen oder ärgern soll
    Ach, du bist nicht der/die Einzige, die es nervt wenn Bugs nicht schnell erledigt werden.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.