Mails exportieren mit Betreff

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Mails exportieren mit Betreff

    Hallo.

    Wie kann ich Mails exportieren, als EMLs, mit dem originalen Betreff?
    Habe es versucht, TheBat (8.0.14) exportiert auch alle Mails wie gewünscht in einem Rutsch, nur statt der realen Betreffs, vergibt TheBat den Mails fortlaufende Nummerierungen (00000001-00001000 usw)

    Das ist natürlich absoluter Nonesens. Das braucht wahrlich kein Mensch so.

    Wie bewege ich TheBat dazu, 100 und mehr Mails auf einmal, mit Betreff abzuspeichern, statt mit vollkommen sinnlosen Nummern?

    Gruß
    Trevor
  • Mit einem Filter und Short cut geht es sehr gut. Der folgende Filter exportiert alle markierten Mails eines Ordners nach D:\export\2015\<Absendername>\<Empfangsdatum> <Absendername> <Betreff>.eml
    Eine Übersicht der Makros gibt es in der Hilfe. Ein Short Cut ist hinterlegt, sodass man die ausgewählten Mails direkt exportieren kann.
    Einfach den Quellcode kopieren und im Filtermanager einfügen.

    Quellcode

    1. $$$$ TB! Message Filter $$$$
    2. beginFilter
    3. UID: [E8950068.01CF0E1E.2B44B85F.0664D7DD]
    4. Name: Archiv_Export_Inbox
    5. Filter: {\0D\0A\20`21\0D\0A}
    6. ExportMessage IncrementExist FmtRFC822 filename D:\5Cexport\5C2015\5C%FROMNAME\5C%ORCVDATE\3D\22yyyy_mm_dd\22\20%FROMNAME\20%SUBJECT.eml filenamerelative D:\5Cexport\5C2015\5C%FROMNAME\5C%ORCVDATE\3D\22yyyy_mm_dd\22\20%FROMNAME\20%SUBJECT.eml
    7. IsManual
    8. IsHotkey
    9. IsHotkeyOnly
    10. Ignore
    11. IsSendQueue
    12. Hotkey 57417
    13. endFilter
    Alles anzeigen
  • mse schrieb:

    Mit einem Filter und Short cut geht es sehr gut. Der folgende Filter exportiert alle markierten Mails eines Ordners nach D:\export\2015\<Absendername>\<Empfangsdatum> <Absendername> <Betreff>.eml
    Eine Übersicht der Makros gibt es in der Hilfe. Ein Short Cut ist hinterlegt, sodass man die ausgewählten Mails direkt exportieren kann.
    Einfach den Quellcode kopieren und im Filtermanager einfügen.

    Quellcode

    1. $$$$ TB! Message Filter $$$$
    2. beginFilter
    3. UID: [E8950068.01CF0E1E.2B44B85F.0664D7DD]
    4. Name: Archiv_Export_Inbox
    5. Filter: {\0D\0A\20`21\0D\0A}
    6. ExportMessage IncrementExist FmtRFC822 filename D:\5Cexport\5C2015\5C%FROMNAME\5C%ORCVDATE\3D\22yyyy_mm_dd\22\20%FROMNAME\20%SUBJECT.eml filenamerelative D:\5Cexport\5C2015\5C%FROMNAME\5C%ORCVDATE\3D\22yyyy_mm_dd\22\20%FROMNAME\20%SUBJECT.eml
    7. IsManual
    8. IsHotkey
    9. IsHotkeyOnly
    10. Ignore
    11. IsSendQueue
    12. Hotkey 57417
    13. endFilter
    Alles anzeigen
    Danke für den Tipp.

    Weiß leider allerdings nicht so recht, wo konkret im Filtermanager ich den Quellcode überhaupt einfügen muss. Muss ich dazu einen neuen Filter erstellen? Falls ja, unter "gelesene Nachrichten" (oder wo sonst?) und dort dann wählen "Nachricht exportieren in Datei:" und da dann den Quelltext eintragen?

    Ich nehme an, das mit "Shortcut" eine bestimmte Tastenkomination gemeint ist wohl, für den Export-Befehl. Aber woher weiß ich welche Kombi konkret das ist?
  • Eigentlich ganz einfach, aber ja: Das ist nicht so schnell ersichtlich.

    Kopiere den obigen Quellcode mit Strg + C in die Zwischenablage, öffne in The Bat den Filtermanager, einfügen mit Strg + V könntest du ihn, wo du willst, aber ich denke der Zweig Gelesene Nachrichten ist wohl am sinnvollsten. Einen neuen Filter vorher erstellen musst du nicht, der entsteht automatisch beim Einfügen.

    Den Shortcut kannst du selbst definieren. Wenn die gewählte Tastenkombination schon vergeben ist, meldet sich The Bat, ansonsten wird sie gespeichert.
  • Sorry, aber ich raffs irgendwie absolut nicht.

    Zwar hat das mit dem einfügen des Quellcodes in den Filtermanger geklappt, nach Deiner Anleitung, Danke.
    Dieser Quellcode taucht jetzt im Zweig "Gelesene Nachrichten" auf. Es sind dann automatisch Haken gesetzt bei "Tastenkobination", als auch bei "Nur Tastenkobination".

    Aber wenn ich danach dann mein Postfach markiere und dann die Tastenkombi "Shift+Ctrl+Alt-I" (die bereits voreingetragene) betätige, passiert rein gar nichts (gelesene Nachrichten hab ich massig im Posteingang dieses Postfaches)

    Was mache ich falsch?
  • Stimmt, so ein Filter klappt nicht in Ordnern/Unterordnern, sie wirken nur auf selektierte Mails.

    Ich bin nicht sicher ob Filter überhaupt so auf Ordner wirken doer das ein fehlendes Feature oder Bug ist.
    Musst du den Ritlabs-Support fragen.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • Ich glaube, wir haben alle drei recht, aber wir meinen unterschiedliche Sachen. Mein Filter funktioniert schon, nur musst du bevor du ihn aufrufst, die Mails, die du exportiert haben willst, auswählen. Er klappt nicht, wenn ein Ordner ausgewählt ist. Prüfe auch mal, ob in den Filteroptionen die Checkbox bei "Filter ist aktiv" gesetzt ist.
  • Jetzt schaut das Ganze schon bedeutend besser aus. Nachdem ich den, wahrlich fehlenden, Haken bei "Filter ist aktiv" gesetzt habe (Danke für den Hinweis), funktionierte es einigermaßen, wenn auch noch nicht perfekt.

    Danach dann hatte ich 1594 gelesene Mails markiert, die sich alle im selben Ordner befanden, und daraufhin dann die Tastenkombi gedrückt. Es wurden in Folge, am gewünschten Speicherort, automatisch 18 Ordner angelegt, in denen sich am Ende dann 1150 Mails befanden.

    Aber 444 Mails fehlten! Nur warum?

    Hatte daraufhin noch einmal alles peinlichst genau überprüft, ob auch wirklich alle 1594 Mails als gelesen markiert waren, und ob auch alle zum exportieren ausgewählt und markiert worden waren, oder ob ich welche übersehen hatte zu markieren. Aber alle 1594 waren als gelesen und zum exportieren markiert gewesen, definitiv! Habe den ganzen Vorgang sogar noch einmal wiederholt um ganz sicher zu gehen. Wieder jedoch mit selbigem Ergebnis, das von 1594 Mails nur 1150 exportiert wurden.

    Habe nach irgendwelchen Auffälligkeiten bei den 1594 Mails Ausschau gehalten, die eventuell, auf das Nicht-mit-exportieren von den besagten 444 Mails hinweisen, wie z.B. extrem lange Betreff-Zeilen usw., habe aber keinerlei Auffälligkeiten endeckt.

    Was kann da schief laufen?
  • Könnte es sein, dass die 1151ste Mail eine HTML-Mail ist?
    Ich habe hier beim Testen auch eine Mail gefunden, die sich nicht exportieren ließ (neben gut 15000 die problemlos auf die Platte gewandert sind). Was an dieser einen Mail anders ist, weiß ich noch nicht, aber andere HTML-Mails ließen sich hier exportieren.

    Der Export geht der Reihe nach. Selektiere mal in deiner Nachrichtenliste von oben nach unten die ersten 1150 Mails. Die sollten sich alle exportieren lassen. Wähle dann die 1151ste aus zum Exportieren. Wenn die dann hakt, liegt es an dieser Mail, der Exportvorgang bricht dann ab. Versuche dann mal ein paar Mails ab 1152 zu exportieren. Das würde mich jetzt interessieren, was da passiert...
  • Habs durchgeführt wie Du sagtest.

    Du bist devinitiv clever!

    Es ist haargenauso wie Du vermutest.

    Die ersten 1150 kann ich problemlos exportieren lassen.

    1151-1154 jedoch alle nicht.

    1155-1594 lassen sich wieder problemlos exportieren.

    Will wohl heissen dann, von 1151-1154 die, sind alle 4 HTML-Mails!?
    Woran erkenne/sehe ich das aber?
    Habe immer "Nur Text anzeigen" eingestellt, dauerfaft. Niemals HTML.

    Und den 4 speziellen Mails, die sich nicht exportieren lassen, sehe ich es nicht an, dass die sich von den Anderen unterscheiden.

    Gibt es eine Lösung dafür, dass TheBat die mit-exportiert, in einem Rutsch mit den ganzen Nicht-HTML Mails, oder muss ich da jetzt immer die von Dir beschriebene Methode anwenden? Das wäre etwas umständlich. Gut, in einem Einzefall aber auch weniger tragisch eigentlich. Hm...
  • Jep, das wäre super umständlich.

    Also, ich habe bei meinen Tests bisher genau eine Mail gefunden, die sich nicht exportieren ließ; es war eine HTML Mail, aber das heißt nicht, dass alle HTML-Mails Probleme machen. Ich habe auch definitiv andere HTML-Mails erfolgreich exportieren können. Herauszufinden, was an deinen vieren jetzt bockt, wird wohl richtig anstrengend.

    Stelle mal die Benutzereinstellungen so ein wie im Screenshot gezeigt. Wenn eine Mail einen HTML-Teil enthält, siehst du dann unterhalb der Nachrichtenvorschau zwei Tabs in denen du dir nur den HTML-Teil im HTML-Tab und den Text-Teil im Text-Tab anzeigen kannst; siehe zweiter Screenshot.
    Bilder
    • html und text.png

      48,18 kB, 1.190×865, 12 mal angesehen
    • tabs.png

      1,2 kB, 300×105, 9 mal angesehen
  • Ich glaub ich habs rausgefunden warum die Vier nicht funzen.
    Die habe die längsten Betreff-Zeilen von allen.
    Und gehören zusammen auch.

    Ich versuche mal ob ich den Betreff kürzen kann, ob es dann ginge.

    Es ist nämlich nach dem Export Versuch alles da, sämtlich Ordner, bis auf die 4 Mails selber.

    Wie schaffe ich das den zu kürzen, weiß das jemand?

    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von Trevor ()

  • ich weiß nicht ob XMP-Makros auch im Filter laufen.
    Aber %XMP_StrLeft("Zeichenkette", Länge) kürzt Strings. Nein, geht leider nicht :(
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von GwenDragon ()

  • Trevor schrieb:

    Die habe die längsten Betreff-Zeilen von allen.
    Und gehören zusammen auch.

    Ich versuche mal ob ich den Betreff kürzen kann, ob es dann ginge.

    Es ist nämlich nach dem Export Versuch alles da, sämtlich Ordner, bis auf die 4 Mails selber.
    Hmm. Wie lang war denn der Betreff.
    Übersteigt denn dann LW+Pfad +Dateiname >260 Zeichen?

    Es müsste doch wenigstens eine Meldung kommen dass nicht exportiert werden kann oder was im Log im Mailverzeichnis, ansonsten ist das ein Bug im Filtermanager!
    Ich würde das an Ritlabs-Support melden.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • mse schrieb:


    Stelle mal die Benutzereinstellungen so ein wie im Screenshot gezeigt. Wenn eine Mail einen HTML-Teil enthält, siehst du dann unterhalb der Nachrichtenvorschau zwei Tabs in denen du dir nur den HTML-Teil im HTML-Tab und den Text-Teil im Text-Tab anzeigen kannst; siehe zweiter Screenshot.
    Habe ich gemacht. Bei den 4 wird zwar HTML Inhalt dann angezeigt, aber ebenso bei zig anderen Mails davor auch, die alle erfolgreich exportiert wurden.
  • GwenDragon schrieb:

    Trevor schrieb:

    Die habe die längsten Betreff-Zeilen von allen.
    Und gehören zusammen auch.

    Ich versuche mal ob ich den Betreff kürzen kann, ob es dann ginge.

    Es ist nämlich nach dem Export Versuch alles da, sämtlich Ordner, bis auf die 4 Mails selber.
    Hmm. Wie lang war denn der Betreff.
    Übersteigt denn dann LW+Pfad +Dateiname >260 Zeichen?
    Die 4 Mails haben eine Zeichenlänge (LW+Pfad +Dateiname) von: 254, 257, 258 und 259 (Leerzeichen bereits inklusive)

    Also kanns daran dann doch nicht liegen.