[erledigt] [Bug] Adressbuch baut Informationen sehr langsam auf

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • [erledigt] [Bug] Adressbuch baut Informationen sehr langsam auf

    Hallo zusammen,

    beobachtet noch jemand das Phänomen, dass sich die Informationen im Adressbuch ungewöhnlich langsam aufbauen?

    Wenn ich aus dem Hauptfenster das Adressbuch aufrufe, erscheint noch gewohnt schnell das Fenster mit allen Bedienelementen. Im linken Bereich stehen normalerweise untereinander die Adressbücher. Diese Liste wird nur langsam aufgebaut, ca 3 Einträge pro Sekunde von oben nach unten. Man kann dabei zusehen. Eines der Adressbücher ist vorausgewählt und dessen Einträge werden im rechten Teil des Fensters angezeigt. Wenn man nun ein anderes Adressbuch anklickt, dauert es ca 1 Sekunde in der die blaue Markierung vom zuvor ausgewählten Adressbuch verschwindet und danach beim aktuell ausgewählten wieder erscheint. Die Einträge des Adressbuchs im rechten Bereich erscheinen ca 3 Sekunden nach dem Klick. Die Prozessorauslastung steigt in diesem Zeitraum von etwa 3 % Grundlast auf etwa 30% an.

    System Windows 10 64 bit, SSD und 8 GB RAM. Das restliche System und auch The Bat sind rasend schnell. Es ist nur das Adressbuch.
  • Teils teils. 4 lokale und 3 mittels CardDAV zu MAilbox.org synchronisiert. Aber guter Punkt. Ich hab mal ein GIF draus gemacht. In der Realität ist es minimal schneller, das Aufzeichnen hat ein wenig Leistung gekostet.
    Das komplette Adressbuch ist langsam. Auch wenn ich das Fenster mit der Maus woanders hinziehe auf dem Desktop, lahmt es. Kontextmenü und Hauptmenü genauso.
    Bilder
    • Adressbuch langsam.gif

      126,19 kB, 1.646×772, 105 mal angesehen
  • Ich kann eine so langsame Anzeige in 8.7.0 Final und 8.7.0.17 32 BETA nicht feststellen. Weder mit CardDAV noch lokal.
    Adressbücher im LAN oder auf einer Freigabe? Vielleicht Virenscanner o.ä. Oder Grafikkartentreiber und Windows-Version.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von GwenDragon ()

  • Ja, das muss mit irgendeiner anderen Software zusammenhängen. Ich weiß nur nicht mehr wirklich, was in den letzten Tagen ich an Einstellungen oder Installationen geändert habe. An ein .NET-Update erinnere ich mich, das über die Windows Updates reinkam. Bei Version 8.8 ist es jetzt so, dass das Adressbuch sich gar nicht mehr öffnen lässt und nur noch einen "Out of System Resources"-Fehler anzeigt. Ich schreibs mal in die Beta-Liste, da ist die Masse der Leute größer in Ritlabs kann vielleicht mit dem dem ex-log was anfangen.
  • Heureka! Problem gelöst; aber die eigentliche Ursache bleibt unklar.

    Ich habe die ADDRBOOK.INI umbenannt, neu gestartet, Adressbuch geöffnet: Klappt. The Bat hat beim Start eine neue ADDRBOOK.INI mit Standardwerten angelegt.
    Danach alle vorher vorhandenen Adressbücher geladen; die Dateien sind ja auf der Festplatte. Klappt auch.

    An dieser Stelle hätte ich dann eigentlich aufhören können. Aber dann habe ich mir die beiden unterschiedlichen ADDRBOOK.INI genauer angesehen. Nachdem ich nach dem Neuanfang alle alten Adressbücher geladen hatte, waren die beiden Dateien sehr ähnlich. Nur ein Unterschied fiel auf: Im Abschnitt [TreeColumns] waren in der alten INI teils astronomische Zahlen eingetragen, in der neuen waren sie in normalem Rahmen. Siehe screen shot; links die kaputte INI, rechts die gute.

    Ich hab dann trotzdem die alte, kaputte INI wiederhergestellt und dann statt der riesigen Zahlen einfach die aus der anderen Datei eingetragen. Jetzt klappt alles wieder. Und ich hab erst keine Ahnung, was die falschen Einstellungen in der INI verursacht hat.
    Bilder
    • ADDR INI Vergleich.jpg

      60,54 kB, 916×289, 40 mal angesehen
  • nur kaputte Parameter in der Ini, also hat sich The Bat! zu Tode gerechnet mit der Fenstergröße.
    Aber wie das kommt. Das hast doch keine UltraHiDPI Monitore, oder?
    Vielleicht hat mal ein Absturz was kaputt gemacht.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • Ja, ich kann mich erinnern, dass mal in The Bat! fixes bei hochauflösednen Ausgabemonitoren gemacht wurden.
    Kann sein, dass eine alte 8.x-version mal ein automatisch eine "Anpassung" gespeichert hat.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • Habe auch das Adressbuch-Problem bei meiner Bekannten - habe ihr ja gerade erst die Version 8.8 installiert. the bat selbst lässt sich anstandslos starten, nur beim Adressbuch gibts immer wieder mal Probleme. Seit der Aktualisierung gabs schon zweimal das Problem, dass beim Aufruf des Adressbuchs die Meldung

    out of system ressources

    kam. Und man konnte nicht mehr auf die Adressen zugreifen. Die Lösung jedesmal: ADDRBOOK.ini löschen. Beim Start von thebat wird diese Datei dann wieder neu erstellt, alle Adressen sind wieder zugänglich, aber die vorher astronomischen Einträge unter [TREE COLUMNS] sind wieder auf ein normales Maß geschrumpft.

    Ist ja schön, dass man das Problem schnell beheben kann, aber eigentlich sollte das doch gar nicht erst entstehen.

    Ich werde auf jeden Fall bei meiner Bekannten bei nächster Gelegenheit updaten, aber ich sehen auch in der aktuelleren 8.8.2-Version nichts, was darauf hindeutet, dass das Problem jetzt gelöst wäre ... wisst ihr mehr?