[Bug] 120MB großes thebat64_Exceptions.log (durch RSS?)

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • [Bug] 120MB großes thebat64_Exceptions.log (durch RSS?)

    Hallo Zusammen,

    mit ist aufgefallen daß die Log-Datei thebat64_Exceptions.log auf inzwischen 120MB angeschwollen ist.
    Seit 2015 gibts den eigentlich immer gleichen Eintrag:

    Habe in den TheBat-Einstellungen die Standard-Anwendungen nochmal zugewiesen, hat aber nichts geändert.

    Hat jemand von Euch eine Idee was die Ursache hierfür ist?


    Gruß,
    Thomas
    (TheBat 8.8)

    --------------------------------
    Date: 15 Feb 2019 11:26:24
    OS: Windows 7 Professional SP1 X64 (AMD or Intel) build 7601
    PhysMemFreeTotal: 0000026327/0000032590 MB
    VirtMemFreeTotal: 0008386092/0008388607 MB
    MAPI #0: Microsoft Outlook [Microsoft Outlook]; Path: C:\Program Files (x86)\Microsoft Office\root\VFS\ProgramFilesCommonX86\system\msmapi\1031\msmapi32.dll (not valid)
    MAPI #1: [Software]; Path: (not valid)
    MAPI #2: The Bat! [The Bat!]; Path: C:\Program Files\The Bat!\tbmapi32.dll (not valid)
    MAPI #3: The Bat! Simple MAPI 32-bit [The Bat! Simple MAPI 32-bit]; Path: C:\Program Files\The Bat!\tbmapi32.dll (not valid)
    MAPI #4: The Bat! Simple MAPI 64-bit [The Bat! Simple MAPI 64-bit]; Path: C:\Program Files\The Bat!\tbmapi64.dll (valid)
    MAPI #5: [Windows Mail]; Path: (not valid)
    Default Profile:
    Address: 000000000140A5B7
    ClassName: EConvertError
    Message: Invalid HTML encoded character (& ) at position 68
    IsOSException: 0
    Modules:
    0000000000400000 20190212103153 C:\Program Files\The Bat!\thebat64.exe
    Stack:
    000000000140A5B7 [0000000000400000]
    000000000140A5B2 [0000000000400000]
    0000000000411F00 [0000000000400000]
    000000000140A5B2 [0000000000400000]
    000000000041049D [0000000000400000]
    0000000000443717 [0000000000400000]
    000000000140A5B2 [0000000000400000]
    0000000000411F2C [0000000000400000]
    000000000140A5B2 [0000000000400000]
    00000000014088C5 [0000000000400000]
    0000000001411F8B [0000000000400000]
    000000000140E87D [0000000000400000]
    000000000140E5BF [0000000000400000]
    0000000000419AC2 [0000000000400000]
    0000000001410E7B [0000000000400000]
    0000000001414AEE [0000000000400000]
    0000000001410BE8 [0000000000400000]
    00000000014104B4 [0000000000400000]
    0000000000532880 [0000000000400000]
    0000000000412B0A [0000000000400000]
    --------------------------------
  • tcj schrieb:

    ClassName: EConvertError
    Message: Invalid HTML encoded character (& ) at position 68
    Seit vier Jahren wird immer wieder dieser Fehler eingetragen?

    Deutet auf irgendein Zeichenkonvertierungsproblem hin. Position 68 müsste Zeile 68 sein, wohl in einer HTML-Nachricht. Kannst du damit etwas anfangen?

    Sonst schicke die Log-Datei an Ritlabs (vgl. Wie kann man Fehler oder Wünsche an Ritlabs weitergeben?).
  • Falls du nicht weißt, welche HTML-Mail den Fehler immer wieder generiert:

    The Bat beenden
    thebat64_exceptions.log umbenennen und The Bat neu starten.
    Rufe nacheinander ca 5 HTML-Mails auf und schaue, ob Einträge in der log-Datei dazukommen
    Wenn nicht, die nächsten 5 nacheinander bis du einen Eintrag findest.

    Andere Variante: Besorge dir ein Programm, das Dateiänderungen überwacht und sofort meldet. Damit lässt du die log-Datei überwachen und wenn dann ein Popup erscheint, weißt du gleich, welche Aktion gerade den Eintrag in der log bewirkt hat.

    Wenn du den Verursacher gefunden hast, würde ich die Mail, falls möglich, in anonymisierter Form im BT-Report anhängen.
  • Hallo mse,

    danke, habe ich getestet und konnte es noch etwas eingrenzen.

    Der Eintrag im Logfile entsteht z.B. jedesmal wenn ich emails (z.B. mit Alt-F2/"Nachrichten von allen Konten abrufen") abrufe.
    Auf den ersten Blick aber nicht wenn der zyklische automatische Abruf erfolgt.
    Es ist dabei egal welches Konto und welche Nachricht ich gerade markiert habe. Und passiert auch wenn keine
    neuen Nachrichten vorliegen, also nichts übertragen wird.

    Warum TheBat dabei einen HTML-File parst weiß ich nicht.

    Gruß,
    Thomas
  • Hallo Thomas,

    interessant...
    Kommt das mit allen abgerufenen Konten, oder ist das immer nur mit einem bestimmten? Mit Alt+F2 fragst du ja alle Konten ab.
    Rufe die Konten mal einzeln mit F2 ab und schaue, ob bei einem bestimmten Konto ein Eintrag in der Log dazukommt.

    Sind das IMAP oder POP-Konten?
  • Hallo mse,

    gute Idee.
    Es passiert beim Abruf des RSS-Feeds!
    Ich habe als einzigen RSS-Feed den Heise-Newsticker aktiv.

    Feed-URL ist heise.de/newsticker/heise-atom.xml

    Wenn der RSS-Feed (z.B. per F2 oder alle paar Minuten zyklisch) abgerufen wird dann gibts den Eintrag im Log.

    Könntest Du den RSS-Feed auch mal bei Dir reinhängen und schauen ob das bei Dir auch so geht?

    Unabhängig davon nervt der RSS-Reader von theBat sowieso. Alle Nachrichten werden bei mir
    direkt als "ganzer Text" (siehe Reiter unter dem Nachrichtenfenster) angezeigt, wenn man von Nachricht
    zu Nachricht springt dann dauert es eigentlich immer mehrere Sekunden bis sich das Bild aktualisiert.
    Je länger TheBat läuft umso langsamer geht es - bis zur Unerträglichkeit.
    Nur bei frisch gestartetem TheBat geht es schneller. Wie schon berichtet geht der sehr langsame RSS-Reader
    dann auch mit riesigem Speicherbedarf von TheBat (im Taskmanager) einher.
    Vielleicht sollte ich auf den TheBat-RSS-Reader einfach verzichten.

    Gruß,
    Thomas
  • tcj schrieb:

    Könntest Du den RSS-Feed auch mal bei Dir reinhängen und schauen ob das bei Dir auch so geht?
    Erledigt. Und Ja:

    --------------------------------
    Date: 17 Feb 2019 14:05:21
    OS: Windows 10 X64 (AMD or Intel) build 17763
    PhysMemFreeTotal: 0000002047/0000002047 MB
    VirtMemFreeTotal: 0000001745/0000002047 MB
    MAPI #0: Windows Live Hotmail [Hotmail]; Path: C:\Program Files (x86)\Internet Explorer\hmmapi.dll (valid)
    MAPI #1: Microsoft Outlook [Microsoft Outlook]; Path: C:\PROGRA~2\MICROS~1\Office14\OLMAPI32.DLL (valid)
    MAPI #2: [PackagedMail]; Path: mmgaclient.dll (not valid)
    MAPI #3: The Bat! [The Bat!]; Path: C:\Program Files (x86)\The Bat!\tbmapi32.dll (valid)
    Default Profile: Outlook
    Address: 01080D52
    ClassName: EConvertError
    Message: Invalid HTML encoded character (& ) at position 9
    IsOSException: 0
    Modules:
    00400000 20190212103114 C:\Program Files (x86)\The Bat!\thebat32.exe
    Stack:
    01080D52 [00400000]
    01080D4D [00400000]
    0040727C [00400000]
    0107F905 [00400000]
    010863D6 [00400000]
    00F955CF [00400000]
    01083CA8 [00400000]
    01083B35 [00400000]
    01085772 [00400000]
    01088265 [00400000]
    0108827F [00400000]
    010855B8 [00400000]
    010850D5 [00400000]
    004CFB11 [00400000]
    0040C0B4 [00400000]
    --------------------------------


    Packe die Infos doch mal gesammelt in deine Support-Meldung dazu. Jetzt wissen wir ja, woran es liegt. Der Heise Newsticker ist auch für Ritlabs problemlos zugänglich. Ob es jetzt an The Bait liegt, oder an Heise, die evtl tatsächlich was mit der Zeichenkodierung versäumt haben ("Invalid HTML encoded character (& ) at position 9") kann Ritlabs sicher besser rausfinden. Schreib doch dazu, dass andere Nutzer von batboard.net das Verhalten auch nachstellen konnten.

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von mse ()

  • tcj schrieb:

    Ritlabs hat den Bug bestätigt und im Bugtracker eingetragen.
    OK. Betrifft also RSS-Feeds und dabei wohl vor allem oder nur den von Heise.

    Ich verschiebe dann aus "Therapieplatz" in "Wishes & Bugtracker".


    tcj schrieb:

    Ob andere User den Bug dann noch bestätigen sollten damit es repariert wird
    weiß ich nicht.
    Wenn der BT-Eintrag die blaue Farbe erhalten hat, dann wurde der Bug offiziell von Ritlabs anerkannt und einem Mitarbeiter zwecks Behebung zugewiesen. Das ist der letzte Schritt vor "Erledigt". Also gibt's auch ohne weitere Bestätigungen gute Aussichten. Aber du kannst ihn auch selbst bestätigen (vgl. BT-Verwendung), insbesondere weil du ihn ja nicht selbst erstellt hast. ;)
  • de-bugger schrieb:

    das ging ja schnell
    Das passiert, wenn man ein Problem direkt an Ritlabs über Support weiterleitet und sie es sofort bestätigen können. Oft tragen sie es selbst in BT ein, wohl damit sie es nicht vergessen, und beziehen sich dabei auf die Support-Ticket-Nummer (TID). Ob so ein Eintrag auch schneller erledigt wird, ist aber eine Frage.

    Ich habe z.B. auch einen "blauen" Eintrag seit TB! v7.3 und damit seit ca. drei Jahren - #0000940: Format can't be changed in the print template.
  • Tja, so schnell gehts.

    Der Developer aslius hat den Bugreport mit folgendem Text als resolved gekennzeichnet.

    aslius schrieb:

    RSS generated by site is not valid , in program there is a Exception handler and trap this issue so application is working, about 1 GB of RAM - this is another issues and is not related to wrong RSS
    Ich schaue jetzt ob ich auf den TheBat-RSS-Reader verzichten kann, er ist schnarchlangsam (und wird immer langsamer), damit zu lesen macht 'eh keinen Spaß.
  • seit ich alle RSS-Threads in TheBat gelöscht habe schwillt der Speicherbedarf von TheBat auch nicht mehr innerhalb 24-48h auf 1-3GB an
    sondern bleibt bei ~200kb.

    Von wegen:

    aslius schrieb:

    about 1 GB of RAM - this is another issues and is not related to wrong RSS

    Oder muß man hier optimistisch bleiben daß das Speicherproblem tatsächlich noch behoben wird und er nur darauf hinweisen will daß
    es nichts mit "wrong RSS" zu tun hat - sonder allgemein mit RSS?
    Naja, den Optimismus spare ich mir.

    Gruß,
    Thomas
  • tcj schrieb:

    sonder allgemein mit RSS?
    Oder allgemein mit dem Programm. Auf die Schnelle konnte ich jetzt im BT keinen Eintrag dazu finden. Wenn ein Benutzer einen BT-Eintrag erstellt und dann von einem Ritlabs-Mitarbeiter so eine Antwort erhält, dann schreibt der Mitarbeiter normalerweise auch, dass z.B. für das andere Problem ein neuer BT-Eintrag erstellt werden sollte. "Dein" Eintrag wurde aber von einem Ritlabs-Mitarbeiter erstellt und mit dem o.g. Hinweis geschlossen. Ob er jetzt selbst den anderen Eintrag macht oder du dich darum kümmern musst, ist nicht klar. Den alten wiedereröffnen kannst du jedenfalls nicht. Wenn du eine Antwort über Support erhalten hast, dann frage sie, wie es aktuell mit diesem "1 GB RAM" Problem steht.