TheBat! startet nicht mehr! Versionen 8.8. und 8.8.0.2

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • TheBat! startet nicht mehr! Versionen 8.8. und 8.8.0.2

    Und zwar sieht das so aus: TheBat! hängt beim Starten und muß schließlich gekillt werden (ein Klick auf den Splash ruft einen Dialog hervor, wonach TheBat nicht mehr reagiere, und man das Programm schließen könne, oder weiter warten.

    Im ex_log.txt steht dann sowas:

    Quellcode: ex_log.txt

    1. v8.8 32-bit LION7/lws 23.02.2019 19:06:54.521 AddrBook:13 EDosStreamError Datei "C:\Program Files (x86)\The Bat!\LDAP#1.ABD" konnte nicht geöffnet werden Zugriff verweigert (while trying to save C:\Program Files (x86)\The Bat!\LDAP#1.ABD)
    2. v8.8 32-bit LION7/lws 23.02.2019 19:06:54.540 AddrBook:13 EDosStreamError Datei "C:\Program Files (x86)\The Bat!\LDAP#2.ABD" konnte nicht geöffnet werden Zugriff verweigert (while trying to save C:\Program Files (x86)\The Bat!\LDAP#2.ABD)
    3. v8.8 32-bit LION7/lws 23.02.2019 19:06:54.576 AddrBook:13 EDosStreamError Datei "C:\Program Files (x86)\The Bat!\LDAP#3.ABD" konnte nicht geöffnet werden Zugriff verweigert (while trying to save C:\Program Files (x86)\The Bat!\LDAP#3.ABD)

    Die Environment-Variable EMAIL verweist auf ein anderes Verzeichnis, und darin befinden sich diese drei LDAP-Adressbücher (alle 3 leer).

    Heute vormittag lief das Progrmam noch, mittags hab ich TheBat! und den Rechner runtergefahren, und nach dem Neustart trat dies Problem auf.

    Heute morgen lief die Version 8.8.0.2, ich hab dann nach den Problemen am späten Nachmittag die 8.8.0 wieder drüberinstalliert (als "repair", und dazu mußte ich die EXE löschen). Dasselbe Problem.

    Ich hab die thebat32.exe dann mal als Administrator ausgeführt, womit eine Installationsprozedur begann, dich ich aber wieder abgebrochen hatte, weil ich fürchtete, die existierende Installation zu beschädigen.

    An die Beta-Liste kann ich ohne funktionierendes eMail-Programm nun auch nicht schreiben, und deswegen frag ich hier, ob jemand eine Idee hat, woran's liegen könnte oder was ich tun könnte.
  • Du nutzt doch bestimmt keine LDAP-Adressbücher oder?
    Du könntest mal ins Mailverzeichnis schauen und dort in der ADDRBOOK.INI die LDAP...ADB rausnehmen,
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • Ich hatte so was vorgestern beim Testen ebenfalls. Ich weiß nicht, ob es genau die selben Testvoraussetzungen waren. Jedenfalls hatte es etwas mit den Zugriffsberechtigungen zu tun. Ich hatte keinen Schreibzugriff auf die ADDRBOOK.INI. Nach einer entsprechenden Änderung lief es dann. Alles unter Windows 10x64.
    TheBat! Pro 8.x (64 Bit) • Win 10 Pro x64 • keine PlugIns
  • Ralf Brinkmann schrieb:

    Ich hatte keinen Schreibzugriff auf die ADDRBOOK.INI.
    Den hab ich, aber der User, unter dem ich TheBat! ausführe hat keinen Schreibzugriff auf das Programmverzeichnis.

    Der Fehler in ex_log.txt lautet ja:
    Zugriff verweigert (while trying to save C:\Program Files (x86)\The Bat!\LDAP#3.ABD)

    sanyok schrieb:

    klappt's mit dem Startparameter /NOLOGO?
    Nein, nur seh ich es nicht auf dem Desktop, sondern nur im Task Manager.

    Ich fürchte, daß ich doch die EXE als Administrator ausführen und den Installationsprozeß durchmachen muß.


    Vielleicht spielt eine Rolle, daß ich heute vormittag die Filter bearbeitet und eine Reihe davon gelöscht habe. Ich hatte nämlich kürzlich ein Problem mit den Filtern. Bei der Bearbeitung hatte ich plötzlich einen SUB-Filter erzeugt, ohne zu wissen, wie ich dazu gekommen war. Ich hab CTRL-Z gedrückt oder sowas ähnlichers gemacht. Danach waren erstmal alle Filter verschwunden. Da gibts so eine Funktion im Filtermanager, verschwundene Filter zu suchen. Das schien aber nichts zu ändern. Aber kurz darauf hatte ich die Filter alle doppelt, und einen Teil davon anscheinend in umgekehrter Reihenfolge. Seitdem bin ich dabei, darin aufzuräumen. Wo sind die Filter eigentlich gespeichert?
  • L.Willms schrieb:

    Wo sind die Filter eigentlich gespeichert?
    Unsere FAQ meint dazu auf Wo befinden sich welche Einstellungen/Informationen?
    ACCOUNT.SRB (neu seit v3.0) / ACCOUNT.SRX (alt) = Filter (ereichbar über "Konto | Filtermanager").
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • Die drei LDAP-Adressbücher sind Adressbücher, die The Bat standardmäßig mitbringt und zum Einbinden der extern zugeschalteten Zertifikatsdatenbanken von Certum, Netcenter und Verisign genutzt werden. MAn kann wohl den Speicherpfad ändern, aber ich weiß nicht, ob der nach einem Update wieder zurückgesetzt wird. Käme auf einen Versuch an.
  • Den Schreibzugriff auf das Programmverzeichnis hat meine UserID noch nie gehabt, und bis gestern mittag hat es damit keine Probleme gegeben.

    Was hat sich da geändert, bzw. was hab ich aus Versehen geändert?

    GwenDragon schrieb:

    Welche technische Notwendigkeit erfordert es die LDAP- und andere Adressbücher ins The Bat!-Programm(!)verzeichnis zu speichern?
    Als wenn ich das denn wüßt.

    Die sind ja im EMAIL-Verzeichnis, und erst seit der gestrigen Nachmittagssitzung will TheBat! die unbedingt im Programmverzeichnis haben. Da gehören die aber nicht hin, meiner bescheidenen Auffassung nach. Die Fledermaus sucht sogar die ADDRBOOK.INI im Programmverzeichnis.

    Rätselhaft ist mir auch, daß die Änderung zwischen der ersten und der zweiten Ausführung von TheBat! 8.8.0.2 eintrat. Wodurch?

    Es gibt die Environment-Variable EMAIL im USER-Bereich HKEY_CURRENT_USER\Environment, die wird aber offenbar nicht ausgewertet, oder erst lange nach dem Start. Will TheBat! die EMAIL-Variable vielleicht aus dem Systembereich holen
    (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment)? Da gibts die nicht. Vielleicht sollte ich dort mal eine anlegen.

    In der LNK-Datei zum Start des Programms ist als "Ausführen in" das Programmverzeichnis angegeben.
  • GwenDragon schrieb:

    Aus Interesse: Welche technische Notwendigkeit erfordert es die LDAP- und andere Adressbücher ins The Bat!-Programm(!)verzeichnis zu speichern?
    Die waren bei mir schon immer da. Ich habe das nicht selbst bestimmt. Nach einem Import der Outlook-Kontakte lagen sie einfach im Programmverzeichnis. Und dann muss logischerweise auch Schreibzugriff darauf bestehen.

    Ups, ich muss mich wohl korrigieren: Ich habe mal in einer älteren Sicherung nachgesehen, da befanden sich sowohl die Importdatenbank als auch die ADDRBOOK.INI im Mailverzeichnis. Dann ist das vielleicht der neue Fehler.
    TheBat! Pro 8.x (64 Bit) • Win 10 Pro x64 • keine PlugIns

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Ralf Brinkmann ()

  • mse schrieb:

    MAn kann wohl den Speicherpfad ändern, aber ich weiß nicht, ob der nach einem Update wieder zurückgesetzt wird
    Ich habe sie wohl noch in v3-v4 komplett gelöscht und sie kamen nicht wieder. Sie sind ja nicht im Setup enthalten, sondern werden wie Trusted Root CA automatisch generiert. Wenn sie einmal gelöscht werden, wird das wahrscheinlich in der ADDRBOOK.INI und/oder Registry vermerkt und bleibt so für die Zukunft.


    L.Willms schrieb:

    Die Environment-Variable EMAIL verweist auf ein anderes Verzeichnis, und darin befinden sich diese drei LDAP-Adressbücher (alle 3 leer).
    Lösche sie mal im TB!-Adressbuch über die rechte Maustaste. Dann wird wahrscheinlich auch das Startproblem verschwinden.

    Hier noch die Übersicht:
    • LDAP#1.ABD = Netcenter Member Directory
    • LDAP#2.ABD = Verisign
    • LDAP#3.ABD = Certum CA Directory
  • sanyok schrieb:

    Lösche sie mal im TB!-Adressbuch über die rechte Maustaste.
    Das ist eine schöne Idee für den Fall, daß The Bat! überhaupt nicht startet. :whistling:

    Wo ist das Mailverzeichnis? Bisher dachte ich immer, das würde durch die USER-Environment-Variable EMAIL bestimmt, aber die hatte ich geändert, um eine Kopie meines Email-Verzeichnisses zu benutzen, aber EMAIL wurde immer wieder wieder geändert, und das alte Verzeichnis benutzt.

    Inzwischen hab ich in der Registry unter HKCU\Software\RIT\The Bat! gaaanz unten die Variable "Working Directory" gefunden, und die hat das Sagen.

    Oben in diesem Registry-Zweig wird ADDRBOOK.INI erwähnt, in "AddressBookProfilePath", und da steht bei mir einfach nur "ADDRBOOK.INI", ebenso in "AddressBookProfilePath Unicode". Den Eintrag unter "AddressBookProfilePathRelative" hatte ich im Zuge der Fehlersuche geändert auf "%EMAIL%\ADDRBOOK.INI", aber die Variable "EMAIL" ist in dem Moment, wo auf diese Registry-Einträge zugegriffen wird, vermutlich überhaupt noch nicht bekannt, sondern wird danach gesetzt entsprechend dem Schlüssel "Working Directory".


    Vielleicht müßte ich unter "AddressBookProfilePath" den absoluten Pfadnamen eintragen, und bei "Relative" statt "%EMAIL%" den Namen des Schlüssels "Working Directory" verwenden.

    Könnten die Kollegen hier mal auf ihrem Rechner nachschauen, was da in der Registry für die "AddressBookProfilePath"s steht, und das hier mitteilen?
  • L.Willms schrieb:


    Könnten die Kollegen hier mal auf ihrem Rechner nachschauen, was da in der Registry für die "AddressBookProfilePath"s steht, und das hier mitteilen?
    Bei mir heißt das Ding AddressBookProfilePath Unicode und da ist bei mir nur ADDRBOOK.INI eingetragen, kein Pfad.

    Im Working Directory steht bei mir %ALLUSERSPROFILE%\The Bat!\Mail\. Da ist mein Mailverzeichnis mit den Accounts.
    TheBat! Pro 8.x (64 Bit) • Win 10 Pro x64 • keine PlugIns
  • Ich habe mal versucht, die ADDRBOOK.INI und die Importdatenbank IMPOL.ADB aus dem Programmverzeichnis in das Mailverzeichnis zu verschieben, sie wurden dann jedoch vom Programm bei erneutem Öffnen nicht erkannt. Im Adressbuch habe ich dann als Pfad des Persönlichen Adressbuchs den der IMPOL.ADB im Mailverzeichnis angegeben. Das wurde zwar auch übernommen (überschrieben!), aber als leer angezeigt. Bei einem erneuten Import der Kontaktdaten landete wieder alles im Programmverzeichnis.
    TheBat! Pro 8.x (64 Bit) • Win 10 Pro x64 • keine PlugIns
  • L.Willms schrieb:

    Das ist eine schöne Idee für den Fall, daß The Bat! überhaupt nicht startet
    Dann lösche sie auf der Festplatte und passe die ADDRBOOK.INI an. Davor steht drin im Abschnitt PROFILE so etwas wie:

    Quellcode

    1. Address Book #1=TheBat.ABD
    2. Address Book #2=LDAP#1.ABD
    3. Address Book #3=LDAP#2.ABD
    4. Address Book #4=LDAP#3.ABD
    5. Address Book #5=RootCA.ABD
    6. Address Book #6=IntermCA.ABD
    7. Address Books=6

    und danach:

    Quellcode

    1. Address Book #1=TheBat.ABD
    2. Address Book #2=RootCA.ABD
    3. Address Book #3=IntermCA.ABD
    4. Address Books=3

    In der Registry wird übrigens nichts zu den Adressbüchern gespeichert, sondern nur der Pfad zur ADDRBOOK.INI, so z.B. bei mir im Wert "AddressBookProfilePath", "AddressBookProfilePath Unicode" und "AddressBookProfilePathRelative".