IMAP - TLS-Handshakefehler bei mail.teknik.io

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Standard und Port 25 haben nicht geklappt. Habe jetzt alle Ports und Settings durch. Senden und Empfangen derzeit nicht möglich.

    25.02.2019, 16:01:19: IMAP - Verbinde zum IMAP-Server mail.teknik.io auf Port 993
    25.02.2019, 16:01:20: IMAP - Einleitung TLS-Handshake
    >25.02.2019, 16:01:20: IMAP - Zertifikat S/N: 04B0F87155EC5CC209615ED9022CA491E3EA, Algorithmus: ECC (256 Bits), ausgestellt von 03.02.2019 07:50:42 bis 04.05.2019 07:50:42, für 2 Host(s): *.teknik.io, teknik.io.
    >25.02.2019, 16:01:20: IMAP - Besitzer: "*.teknik.io".
    >25.02.2019, 16:01:20: IMAP - Aussteller: "US", "Let's Encrypt", "Let's Encrypt Authority X3". Gültig ab 17.03.2016 16:40:46 bis 17.03.2021 16:40:46.
    >25.02.2019, 16:01:20: IMAP - Root: "Digital Signature Trust Co.", "DST Root CA X3" Gültig ab 30.09.2000 21:12:19 bis 30.09.2021 14:01:15.
    !25.02.2019, 16:01:20: IMAP - TLS-Handshakefehler. Ungültiges Serverzertifikat (Das Zertifikat kann für diesen Zweck nicht genutzt werden)

    aber dann:

    25.02.2019, 16:06:34: IMAP - Verbinde zum IMAP-Server mail.teknik.io auf Port 143
    25.02.2019, 16:06:35: IMAP - Verbunden mit IMAP-Server (mail.teknik.io)
    >25.02.2019, 16:06:35: IMAP - IMAPrev1
    25.02.2019, 16:06:35: IMAP - Authentifiziere (Benutzer: "xxxx@teknik.io", Methode: "LOGIN")...
    25.02.2019, 16:06:35: IMAP - IMAP-Server Authentifikation OK - IMAP-Server meldet: "LOGIN completed"

    Dann geht (temporär) der Empfang...
    Ich werde hier nicht mehr schlau. Ich bediene das Konto jetzt mit Thunderbird. Da klappt alles einwandfrei!
  • honndo schrieb:

    Senden und Empfangen derzeit nicht möglich.
    Kannst du bitte TB! auf Englisch umschalten, eine Verbindung mit teknik.io aufbauen und dann das gesamte Protokoll auf Englisch hier posten, damit wir es im BugTracker posten? Oder mache es bitte dort selbst (s. Infos oben).

    Edit:
    Ich sehe, dass jemand im BT das Protokoll auf Englisch bereits angehängt hat. Also hat sich das erledigt.
  • 27.04.2019, 01:03:43: IMAP - Verbinde zum IMAP-Server mail.teknik.io auf Port 993
    27.04.2019, 01:03:43: IMAP - Einleitung TLS-Handshake
    >27.04.2019, 01:03:44: IMAP - Zertifikat S/N: 09F39304, Algorithmus: RSA (512 Bits), ausgestellt von 08.08.2017 16:24:30 bis 03.08.2037 16:24:30, für 2 Host(s): *.teknik.io, teknik.io.
    >27.04.2019, 01:03:44: IMAP - Besitzer: "Domain Control Validated", "PositiveSSL Wildcard", "*.teknik.io".
    >27.04.2019, 01:03:44: IMAP - Root: "Domain Control Validated", "PositiveSSL Wildcard", "*.teknik.io" Gültig ab 08.08.2017 16:19:13 bis 03.08.2037 16:19:13.
    27.04.2019, 01:03:44: IMAP - TLS-Handshake vollständig
    27.04.2019, 01:03:44: IMAP - Verbunden mit IMAP-Server (mail.teknik.io)
    >27.04.2019, 01:03:44: IMAP - IMAPrev1
    27.04.2019, 01:03:51: IMAP - Authentifiziere (Benutzer: "xxxxx@teknik.io", Methode: "LOGIN")...
    27.04.2019, 01:03:51: IMAP - IMAP-Server Authentifikation OK - IMAP-Server meldet: "LOGIN completed"
    Bin nach langer Zeit mal wieder "drin". ;) Posteingang ist aktualisiert. Mails lassen sich lesen/löschen/verschieben.
    27.04.2019, 01:12:54: USER - Moved from folder "Eingang" to folder "INFO" 1 messages
    27.04.2019, 01:13:03: USER - Moved from folder "INFO" to folder "Eingang" 1 messages

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von honndo ()

  • @hondo Jetzt hast du aber irgendeinen Firewall/Virenscanner/Spamfilter dazwischen, denn das Zertifikat hat neimals
    > >27.04.2019, 01:03:44: IMAP - Zertifikat S/N: 09F39304, Algorithmus: RSA (512 Bits)
    Falsche Sereinnummer des Zertifikats.

    Bei mir ist die SN 045091b28e2a7bf0ff769be9bbc236bbcd11
    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • ... der Server scheint wieder zu funktionieren.

    >18.11.2019, 00:04:40: IMAP - Root: "Domain Control Validated", "PositiveSSL Wildcard", "*.teknik.io" Gültig ab 08.08.2017 16:19:13 bis 03.08.2037 16:19:13.
    18.11.2019, 00:04:40: IMAP - TLS-Handshake vollständig
    18.11.2019, 00:04:40: IMAP - Verbunden mit IMAP-Server (mail.teknik.io)
  • ..und weiter geht´s ...



    20.03.2020, 16:55:45: IMAP - Verbinde zum IMAP-Server mail.teknik.io auf Port 993
    20.03.2020, 16:55:45: IMAP - Einleitung TLS-Handshake
    >20.03.2020, 16:55:45: IMAP - Zertifikat S/N: 033858D2278265AFD94FF6156964817895DA, Algorithmus: ECC (256 Bits), ausgestellt von 29.01.2020 12:07:38 bis 28.04.2020 12:07:38, für 2 Host(s): *.teknik.io, teknik.io.
    >20.03.2020, 16:55:45: IMAP - Besitzer: "*.teknik.io".
    >20.03.2020, 16:55:45: IMAP - Aussteller: "US", "Let's Encrypt", "Let's Encrypt Authority X3". Gültig ab 17.03.2016 16:40:46 bis 17.03.2021 16:40:46.
    >20.03.2020, 16:55:45: IMAP - Root: "Digital Signature Trust Co.", "DST Root CA X3" Gültig ab 30.09.2000 21:12:19 bis 30.09.2021 14:01:15.
    !20.03.2020, 16:55:45: IMAP - TLS-Handshakefehler. Ungültiges Serverzertifikat (Das Zertifikat kann für diesen Zweck nicht genutzt werden)
  • honndo schrieb:

    ..und weiter geht´s ...
    Vor einem Jahr wurde noch ein ganz anders Zertifikat erfolgreich benutzt:

    Quellcode

    1. Zertifikat S/N: 09F39304, Algorithmus: RSA (512 Bits), ausgestellt von 08.08.2017 16:24:30 bis 03.08.2037 16:24:30, für 2 Host(s): *.teknik.io, teknik.io.
    Dieses soll noch bis 2037 gültig sein. Wieso bei dir immer wieder das falsche mit der S/N 033858D2278265AFD94FF6156964817895DA verwendet wird, ist nicht verständlich.

    Hast du noch das Protokoll vom letzten Mal, als es mit der Verbindung klappte? Welches steht drin?