TB! Update Assistent 1.19.8

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • TB! Update Assistent 1.19.8

    wie wäre es, wenn du irgendwo, ein Dropdown-Menü machst.. ältere Beta/Final-Versionen, falls man mal eine Beta etc. zurück möchte

    oder bei "Aktuelle Beta" und "Aktuelle Final" die Dropdownliste anbieten...
    und die aktuellste als als Vorauswahl :banane:
  • TB! Update Assistent 1.19.8

    Nach der 1.0.8 folgte ein Bugfix 1.0.8.1 ... joa, das ist nun auch wieder Geschichte. :) Die neue Version bietet einige nette Features, welche man beim Vorgänger so ähnlich auch schon finden konnte. Sollte da was nicht funktionieren, einfach Bescheid geben.

    Release - 1.0.9

    + das Programm minimiert nun ins Tray, und kann minimiert gestartet werden
    + automatischer Onlinecheck wird mit einem bestimmten Intervall durchgeführt
    + Sicherheitsfragen vor den Updates (kann deaktiviert werden)
    - The Bat! wurde, wenn gewünscht nach der Aktualisierung nicht gestartet
    - einige Tasten wurden an unerwünschten Stellen aktiviert

    Download: (Version 1.0.9) Mirror auf meiner Homepage oder über die eigene Updatefunktion (hier wird von der Vorgängerversion automatisch eine Sicherung angelegt).


    @Twilo: Jupp, den Bug hatte ich auch gefunden. Danke! Ist nun behoben. Ne History für die TB! Versionen werd ich denke mal nicht bieten. Der Aufwand ist einfach zu hoch. Ein Backup wird ja wenn gewünscht angelegt.
  • TB! Update Assistent 1.19.8

    Download: (Version 1.0.9) Mirror auf meiner Homepage oder über die eigene Updatefunktion (hier wird von der Vorgängerversion automatisch eine Sicherung angelegt).

    Update über den Updater funktioniert nicht
    siehe Sreenshot


    Ne History für die TB! Versionen werd ich denke mal nicht bieten. Der Aufwand ist einfach zu hoch. Ein Backup wird ja wenn gewünscht angelegt.

    so schwer bzw. kompliziert stelle ich mir das nicht vor ;)

    die Datei (Daten) die du abrufst, könnte ja ein anderes Format haben

    zur Zeit sieht es ja so aus

    thebatworld
    [Version]
    Beta=3.0.0.19
    Final=3.0.0.0


    batworld
    [Version]
    Beta=3.0.0.19
    Final=3.0


    soll das so sein, dass dort Unterschiede sind?

    die Datei könnte ja so aufgebaut sein

    [Version]
    Beta=3.0.0.19
    Beta=3.0.0.18
    Beta=3.0.0.16
    ...
    Final=3.0
    Final=2.12


    [gelöscht durch Administrator]
  • TB! Update Assistent 1.19.8

    Update über den Updater funktioniert nicht
    siehe Sreenshot

    Das lag wohl am Zeitpunkt, wo Du es versucht hast. Da hab ich nämlich rumprobiert. Das Update von der 8'er auf die aktuellere würde und wird funktionieren. Aber die 9'er hat nen Fehler in selbiger Funktion. Der sollte aber nun behoben sein.

    [Version]
    Beta=3.0.0.19
    Beta=3.0.0.18
    Beta=3.0.0.16...

    So geht das nicht, ne INI wird immer Paarweise ausgelesen, also kann man in diesem Fall dem Schlüssel "Beta" keinen Wert zuordnen. Zudem hat Tommy ein recht umfangreiches Archiv auf seiner Homepage... ich verstehe immer noch nicht, warum dies in einen Updater gehören könnte. :)

    --------------------
    Aus gegebenen Anlass kommt halt nun die 1.1.0 - die bekannten Fehler sind beseitigt, und ich denke mal, ich hab auch keine neuen eingebaut. :)

    Release - 1.1.0

    + geänderte Oberfläche, da der Platz für die Einstellungen knapp wurde
    + wenn die Sprachdatei nicht im Verzeichnis liegt, wird Deutsch genommen
    + auf Wunsch kann man nun The Bat! manuell aktualisieren, die RAR wird im TB!-Verzeichnis gespeichert
    - der Intervallcheck wurde bei einem bereits aktiven download aktiviert
    - das interne Update von v1.0.9 wird leider nicht funktionieren, Fehler nun behoben
    - die Version im Fenstertitel hat die Updatefunktion gestört

    Download: (Version 1.1.0) Mirror auf meiner Homepage oder über die eigene Updatefunktion (leider nicht von der 1.0.9).

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von eCerberus ()

  • TB! Update Assistent 1.19.8

    Update über den Updater funktioniert nicht
    siehe Sreenshot

    Das lag wohl am Zeitpunkt, wo Du es versucht hast. Da hab ich nämlich rumprobiert. Das Update von der 8'er auf die aktuellere würde und wird funktionieren. Aber die 9'er hat nen Fehler in selbiger Funktion. Der sollte aber nun behoben sein.

    ausschlaggend ist ja, dass es gestern bei mir nicht funktioniert hat :rolleyes:

    [Version]
    Beta=3.0.0.19
    Beta=3.0.0.18
    Beta=3.0.0.16...

    So geht das nicht, ne INI wird immer Paarweise ausgelesen, also kann man in diesem Fall dem Schlüssel "Beta" keinen Wert zuordnen.

    wie man das umsetzen würde, wäre mir relativ egal, hauptsache es funktioniert :pfeif:

    Zudem hat Tommy ein recht umfangreiches Archiv auf seiner Homepage... ich verstehe immer noch nicht, warum dies in einen Updater gehören könnte. :)

    ich würde es halt einfacher finden, wenn man sich ne ältere Beta per Upfdater einspielen könnte :)

    gut wäre auch, wenn man per Updater das Backup wieder zurpückspielen könnte

    dann würde man sich einige Arbeitsschritte sparen :ja:
    1. TheBat! schliessen
    2. thebat.exe löschen
    3. thebat.exe.bak in thebat.exe umbennen
    4. TheBat! starten
    :thx:
    :bye:
  • TB! Update Assistent 1.19.8

    gut wäre auch, wenn man per Updater das Backup wieder zurpückspielen könnte

    dann würde man sich einige Arbeitsschritte sparen :ja:
    1. TheBat! schliessen
    2. thebat.exe löschen
    3. thebat.exe.bak in thebat.exe umbennen
    4. TheBat! starten

    Die Idee halte ich für sehr gut. Hab ich notiert. Zudem überlegen wir gerade, wie man nen TB! Changelog zur Verfügung stellen könnte. Diesen kann man sich dann anzeigen lassen. Jedoch weiß ich da nicht recht, wo ich ne Plain-Text-Version der History herbekommen könnte.

    Zu den älten Versionen... was halten die anderen davon?

    Gibt es Probleme mit der 1.1.0?
  • TB! Update Assistent 1.19.8

    Wäre es aufwendig, wenn man bestimmte Zeilen im Log-Fenster farblich unterlegen würde, z.B. einen erfolgreichen Vorgang in hellgrün, ein vorhandenes Update in hellgelb, einen Fehler in hellrot?

    Und evtl. kann man ja noch nen keinen Knopf hinzufügen, der das Logfenster ausblendent.
  • TB! Update Assistent 1.19.8

    Wäre es aufwendig, wenn man bestimmte Zeilen im Log-Fenster farblich unterlegen würde, z.B. einen erfolgreichen Vorgang in hellgrün, ein vorhandenes Update in hellgelb, einen Fehler in hellrot?

    dafür wäre ich auch :punk:
    Und evtl. kann man ja noch nen keinen Knopf hinzufügen, der das Logfenster ausblendent.

    oder dass man in den Einstellungen eine Option hat... verkürzte LOG, oder ähnlich
    wo dann halt nur die wichtigesten Dinge drin vorkommen
    also starr
    29.09.04 - 13:14:31 - Serverprüfung erfolgreich abgeschlossen.
    29.09.04 - 13:14:31 - thebatworld.de -- 39 Bytes
    29.09.04 - 13:14:30 - batworld.net -- 35 Bytes
    29.09.04 - 13:10:31 - Sie verwenden die aktuellste Version des TB!UA.
    29.09.04 - 13:10:31 - Serverprüfung erfolgreich abgeschlossen.
    29.09.04 - 13:10:31 - Versionsdatei - TB! Update Assistent -- 73 Bytes
    29.09.04 - 13:10:11 - Serverprüfung erfolgreich abgeschlossen.
    29.09.04 - 13:10:11 - thebatworld.de -- 39 Bytes
    29.09.04 - 13:10:10 - batworld.net -- 35 Bytes
    29.09.04 - 13:10:09 - Sie verwenden die aktuellste Version des TB!UA.
    29.09.04 - 13:10:09 - Serverprüfung erfolgreich abgeschlossen.
    29.09.04 - 13:10:09 - Versionsdatei - TB! Update Assistent -- 73 Bytes
    29.09.04 - 13:10:08 - Temporäres Verzeichnis: C:\DOKUME~1\Kay\LOKALE~1\Temp\
    29.09.04 - 13:10:08 - The Bat! Verzeichnis: C:\Programme\The Bat!\
    29.09.04 - 13:10:08 - The Bat! Parameter wurden aus der Registry geladen.

    dann nur noch
    29.09.04 - 13:14:31 - Serverprüfung erfolgreich abgeschlossen.
    29.09.04 - 13:10:31 - Sie verwenden die aktuellste Version des TB!UA.
    29.09.04 - 13:10:31 - Serverprüfung erfolgreich abgeschlossen.
    29.09.04 - 13:10:11 - Serverprüfung erfolgreich abgeschlossen.
    29.09.04 - 13:10:09 - Sie verwenden die aktuellste Version des TB!UA.
    29.09.04 - 13:10:09 - Serverprüfung erfolgreich abgeschlossen.

    oder ähnlich

    und dann statt "Serverprüfung erfolgreich abgeschlossen." entweder "Sie verwenden die aktuelle Version von TheBat!" oder "Sie verwenden nicht die aktuelle Version von TheBat!"

    und das dann halt farbig :thx:
  • TB! Update Assistent 1.19.8

    Im Info-Feld steht übrigens Entickler und nicht Entwickler... :)


    Wenn du immer auf der Suche nach Verbesserungen bist, frag doch mal Achim, ob ihr nicht auch eine BayesFilter-Update-Funktion einbauen könnt.

    Wäre cool, wenn das Programm, so ein Allround-updater wird, ähnlich wie Wassup für Miranda.
  • TB! Update Assistent 1.19.8

    Bugfix Release - 1.1.1

    - Der erste Release Candidate für das Programm, und schon gibt ein Problem mit
    dem Versionsvergleich. Man sollte unbedingt auf diese Version wechseln. Um
    den Update Assistenten fehlerfrei per Updatefunktion zu aktualisieren, sollte
    man die INI-Datei löschen.
    Ansonten einfach die neue EXE drüber kopieren. Der Fehler tut mir Leid, war aber
    so nicht vorhersehbar. :-/


    Ich muss nun noch ein Problem mit der Registry prüfen, also melde ich mich nochmal.

    -> erledigt, gibt doch keine Probleme mehr.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von eCerberus ()

  • TB! Update Assistent 1.19.8

    @ecerberus
    Tolles Program für eine Faule wie ich ;)
    :thumbup:

    Wenn ich den DOwnload abbreche, nimmt der Updater dann den Download wieder an der Stelle auf oder fängst er wierder neu an? Kann ja mal passieren, dass die Verbindung gekappt wird.

    Also ist ein RESUME DOWNLOAD integriert?
    Wenn nicht, dann ist das der nächste Wish!
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von GwenDragon ()