TB! Update Assistent 1.19.8

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • TB! Update Assistent 1.19.8

    Danke für das Lob. :)

    Also ist ein RESUME DOWNLOAD integriert?
    Wenn nicht, dann ist das der nächste Wish!

    Ist ein toller Wish, wenn ich das programmiertechnische Know How hätte, würde ich das sofort ins Programm aufnehmen. :) Wenn jemand nen Hint hat... her damit!
  • TB! Update Assistent 1.19.8

    Hab eben ausgiebig getestet?! Kann das Problem nicht nachvollziehen... hab mehrere RC-Kombinationen ausprobiert. Mal die eine, mal die andere Seite aktueller.

    tbupdate.ecerberus.de/tbupdate.check.ini
    tbupdate.ecerberus.de/tbupdate.check2.ini :blink:

    Wie auch immer. Ich bau jetzt mal in das Programm. Vor alleom im Bereich der Versionsdekodierung und des Vergleiches ne Menge Meldungen ein, und geb die Testversion mal frei... bis denne.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von eCerberus ()

  • TB! Update Assistent 1.19.8

    So, anbei eine Testversion auf Basis der 1.1.1/b16. Sie unterscheidet sich eigentlich nur durch eine deutlich detailiertere Ausgabe beim Versionscheck, und das die Versions-INI von meinem Server kommen:

    tbupdate.ecerberus.de/tbupdate.check.ini (Batworld = Server 1)
    tbupdate.ecerberus.de/tbupdate.check2.ini (The Bat World! = Server 2)

    Download ist:

    Der Log sollte in etwa so ausschauen:
    [size=7]01.10.04 - 10:43:20 - Local < Beta
    01.10.04 - 10:43:20 - Beta > Final
    01.10.04 - 10:43:20 - Server 1 Beta < Server 2 Beta
    01.10.04 - 10:43:20 - (<=50 = Server 1 // >50 = Server2)
    01.10.04 - 10:43:20 - Zufallszahl zur Serverwahl: 1
    01.10.04 - 10:43:20 - Server 1 Final = Server 2 Final
    01.10.04 - 10:43:20 - Serverprüfung erfolgreich abgeschlossen.
    01.10.04 - 10:43:20 - Server 2 Beta: 3.0.1 RC2
    01.10.04 - 10:43:20 - Server 2 Final: 3.0
    01.10.04 - 10:43:20 - Server 1 Beta: 3.0.1 RC1
    01.10.04 - 10:43:20 - Server 1 Final: 3.0
    01.10.04 - 10:43:20 - thebatworld.de -- 36 Bytes
    01.10.04 - 10:43:20 - batworld.net -- 36 Bytes
    01.10.04 - 10:43:16 - Temporäres Verzeichnis: D:\DOKUME~1\Temp\User\
    01.10.04 - 10:43:16 - The Bat! Verzeichnis: C:\Programme\The Bat\
    01.10.04 - 10:43:16 - The Bat! Parameter wurden aus der Registry geladen.[/size]


    Was machen eure RC...irgendwas Fehler?

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von eCerberus ()

  • TB&#33; Update Assistent 1.19.8

    So, anbei eine Testversion auf Basis der 1.1.1/b16.

    Hallo,

    läuft hier auf NTSP6 einwandfrei

    Was machen eure RC...irgendwas Fehler?


    die 1er problemlos (allerdings ohne Plugins), die 2er muss ich noch testen

    Gruss
    Theo
    Gruss
    Theo

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von theotull ()

  • TB&#33; Update Assistent 1.19.8

    Release - 1.1.2

    + die runtergeladene RAR wird trotz Update, wenn gewünscht, nicht mehr gelöscht
    + der Speicherort der RAR-Datei kann gewählt werden
    + man kann zu einem weniger ausführlichen Log schalten
    + Fehler werden nun im Log rot, neue Versionen grün dargestellt


    Download und Update wie gehabt.
  • TB&#33; Update Assistent 1.19.8

    Die Version funktioniert mit beiden manuellen Speicherorten einwandfrei.
    Well done :thumbup:

    Nachtrag: auch das Autoupdate funktioniert hier einwandfrei


    Gruß
    Manni
    Gruß
    Manni
    [img]http://mannis.gmxhome.de/tbsig/TBSig1.gif[/img]

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Manni-B ()

  • TB&#33; Update Assistent 1.19.8

    So, anbei eine Testversion auf Basis der 1.1.1/b16.

    Hallo,

    läuft hier auf NTSP6 einwandfrei

    und zu Hause auf 98SE bekomme ich folgende Fehlermeldung:

    01.10.04 - 21:03:40 - Es konnten keine Parameter für das lokale TB! ermittelt werden.


    Da ich auch nicht weitermachen kann, ist der Uploader zu Hause erst mal nutzlos :denk:

    Gruss
    Theo
    Gruss
    Theo
  • TB&#33; Update Assistent 1.19.8

    <gekürzt>
    So, anbei eine Testversion auf Basis der 1.1.1/b16.

    und zu Hause auf 98SE bekomme ich folgende Fehlermeldung:

    01.10.04 - 21:03:40 - Es konnten keine Parameter für das lokale TB! ermittelt werden.


    Da ich auch nicht weitermachen kann, ist der Uploader zu Hause erst mal nutzlos :denk:

    Wie sieht es denn mit der Version 1.12 aus?


    Gruß
    Manni
    Gruß
    Manni
    [img]http://mannis.gmxhome.de/tbsig/TBSig1.gif[/img]
  • TB&#33; Update Assistent 1.19.8

    Hallo eCerberus,

    hätte da noch einen Verbesserungsvorschlag:

    Ich nutze u. a. dynbat. Die Verwendung des Updates mit dynbat klappt nicht hundertprozentig.

    Auf dem Rechner ist "The Bat" nicht lokal installiert. Ich kann den updater also nur starten, nachdem ich dynbat gestartet habe.

    Wenn dann die Option: "The Bat nach update starten" gewählt wird, wird nicht dynbat, sondern "thebat" gestartet.

    Könnte man dazu eine Abfrage oder eine Auswahlmöglichkeit einführen?

    Gruß

    Sascha
  • TB&#33; Update Assistent 1.19.8

    Okay okay... hier eine neue Button, und da eine neue Button. Eine untypische The Bat! Installation hier und eine da. Am Ende ist das Programm größer als TB. :) Es ist mir einfach unmöglich alle speziellen Fälle abzudecken.

    Leute, bei denen TB! nicht in der Reg erkannt wird - sei es ein Guard, oder irgend was anderes können befehlsweise auf den Startparameter, welcher in der Version 1.0.6 Beta/2 eingeführt wurde, zurück greifen. Im Fall von DynBat würde ich auf den automatischen Start verzichten.

    Hmm... ich bau demnächst erstmal die Möglichkeit ein, ein Backup zurückzuspielen.



  • TB&#33; Update Assistent 1.19.8

    Hallo,
    und anscheinend kann TheBat! meine Version(RC3) auch nicht mehr ermitteln:

    Hast Du TB! nach Update geschlossen und neu aufgerufen, damit die Reg.-Einträge erneuert werden?

    Ja klar,

    bin aber hier (Win98SE) wieder auf die RC1 zurück, wo es damit keine Probleme gibt.
    Nur der Uploader findet die installierte Version leider nicht.

    Heute auf der Arbeit, dort habe ich für mich auf NT die gleiche Version von TheBat!, lief alles problemlos.

    Gruss
    Theo

    Gruss
    Theo
  • TB&#33; Update Assistent 1.19.8

    Sorry, aber ich bin's nochmal.

    Bei mir funktioniert TB!UA definitiv NICHT - staendig wird "Serverprüfung fehlgeschlagen. Überprüfen Sie Ihre Onlineverbindung!" angezeigt - und ich bin staendig online. Firewall kann eigentlich auch nicht sein, denn in den Logs taucht nichts auf - ein normales "telnet www.batworld.de 80" funktioniert tadellos - also auch keine irgendwie gearteten Proxies o.ae.

    Kann es sein, dass Du vor dem eigentlichen http.get noch irgendwas ueberpruefst - z.B. ein ping auf bestimmte Rechner oder so? Evtl. Timeout zu gering eingestellt?!?

    Wie schonmal gesagt: Falls ich den Delphi-Source haette, koennte ich das ganze sicherlich genauer lokalisieren - so kann ich leider nicht mehr machen als sagen "geht nicht" - oder gibt's noch was anderes?!?

    Dabei scheint's wohl voellig egal zu sein, welche TB!UA-Version ich verwende - auch die neuste 1.1.2 geht nicht.

    Steff