The Bat! 4.2.44.2

  • Neue Final-Version:


    The Bat! 4.2.44


    http://www.ritlabs.com/en/products/thebat/download.php


    Mit den besten Grüßen aus Bayern!


    Konrad

    Einmal editiert, zuletzt von sanyok () aus folgendem Grund: Changelog hinzugefügt.

  • Wenn ein Mod oder Admin jetzt auch noch die komplette Versionsnummer in den Titel einträgt, dann wissen wir es gleich. ;)

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Ich habe vorhin TheBat! 4.2.36.4 mal komplett deinstalliert, also alles gelöscht, was mit RIT zu tun hat und alles neu mit Version 4.2.44.2 aufgesetzt - der Fensterbug ist aber bei mir immer noch da.


    Ich glaub ich geb auf und bleib bei 4.2.36.4. Erst wenn V5 Final da ist, nehme ich einen neuen Anlauf.


    Gruß
    IABC

    Schöne Grüße
    IABC
    --
    Windows 10 Pro x64 | TheBat! 8.x und 9.x jeweils x64

    2 Mal editiert, zuletzt von IABC ()

  • Ja, den Schlüssel unter HKEY_CURRENT_USER\Software\RIT habe ich komplett gelöscht, ebenso das Programm-Verzeichnis. Das einzige, was ich nicht gelöscht habe, sind meine Konten.


    Gruß
    IABC

  • So, ich habe mir jetzt ein Skript gebastelt, das den Fenster-Fehler "umschifft" und zwar mit dem Script-Programm Autoit (http://www.autoitscript.com/site/autoit/).


    Zur Erinnerung: Der Fehler tritt nur auf, wenn The Bat minimiert gestartet wird.


    Als erstes habe ich einen globalen Shortcut in TheBat angelegt (Optionen, Benutzereinstellungen, Tastenkombinationen (System). Dort unter "Aus Infobereich wiederherstellen/minimieren einen Shortcut angelegt (ich habe mal F4 genommen). Danach unter Benutzereinstellungen, Allgemein den Haken weggetickt, dass TheBat automatisch beim Windowsstart geladen werden soll.


    Dann habe ich Autoit installiert und folgendes Script angelegt:


    Opt("WinTitleMatchMode", 2) ;1=start, 2=subStr, 3=exact, 4=advanced, -1 to -4=Nocase
    Run("C:\Program Files (x86)\The Bat!\thebat.exe")
    WinWaitActive("The Bat")
    Sleep(5000)
    send("{F4}")


    Das Skript macht folgendes:
    Zuerst lege ich fest, wie der Fenstertitel angesprochen wird. Das Ausrufezeichen im Titel von TheBat! geht nicht, deswegen Option 2, d.h. irgendeine Übereinstimmung im Fenstertitel
    Dann wird The Bat geladen
    Dann wartet das Skript, bis das Programmfenster von The Bat sichtbar ist.
    Dann wartet das Skript 5 Sekunden
    Zuletzt schickt es den Shortcut F4 ans Programm, den ich vorher in The Bat festgelegt habe (s. oben).
    Damit wird dann das Programmfenster der Fledermaus minimiert.


    Dieses Skript habe ich dann in der Windows-Aufgabenplanung (aka Scheduler) so eingerichtet, dass es immer beim Anmelden an den Rechner ausgeführt wird.


    Voilà - es funktioniert jetzt, wie ich es haben will. Ich weiß: eine ziemliche Übung, aber mit dem Fehler konnte ich mich nicht arrangieren, ich wäre sonst bei der alten Version geblieben.


    Vielleicht ist der Tipp ja für den einen oder anderen nützlich.


    Gruß
    IABC

  • Nein, mit /minimize tritt der Fehler genauso auf wie auch mit /min.


    /minimize nutze ich schon seit vielen Jahren, seit der Version 1.x, und hatte bis jetzt noch nie Probleme - bis die Versionen nach 4.2.36.4 kamen. Ab da spinnt die Fenstereinstellung, sie wird nach jedem minimierten Start auf Default zurückgestellt. Ich konnte machen, was ich wollte, neu installieren, alles aus der Registry putzen, tbuser.def löschen - es half alles nichts.


    Jetzt habe ich den o.g. Weg gefunden, bei dem halt das Programm zuerst maximiert gestartet und dann über den Shortcut minimiert wird. So klappt's - jedenfalls für mich, die Fenstereinstellungen werden so nicht auf Default zurückgestellt.


    Ich weiß, dass es nur bei einigen Nutzern diesen Fehler gibt, aber was nützt mir das? Bei mir kommt er vor und mit dem Skript habe ich halt jetzt einen Workaround.

  • Ich weiß nicht, was los war. Nach der gestrigen Installation der Version 44.2 war der Bug weg (oder hatte zumindest den Eindruck, dass dem so war). Wenn ich mich allerdings recht erinnere, war bei meiner gestrigen Prüfung auch nur eine Mail im Postfach, die bei der RFC-822-Einstellung vielleicht den falschen Eindruck einer 2teiligen-Fenstereinstellung vermittelt hat. Wie dem auch sei: Heute war bei der 44.2-Version der Fenster-Bug wieder da. Ich habe die sattsam bekannte 36.4er-Version drübergebügelt, was problemlos gelang.