Spam markierte Mails sofort löschen, statt in den Spam Ordner verschieben

  • Hallo Zusammen,


    ich nutze Regula 2.2.7., TB 5.0.34


    Ich habe mir einen gemeinsamen Filter angelegt der eMails die beginnen im Subject mit "****SPAM****" ... oder "E-Mail blocked" ... direkt gelöscht werden. Jetzt ist es aber offensichtlich so, dass Regula vor dem Filter greift.


    Wie bring ich jetzt Regula bei, dass diese e-Mails als HAM deklariert werden, um sie danach vom gemeinsamen Filter ins Nirwana schicken zu können?
    Oder kann Regula diese e-Mails auch direkt löschen, so dass ich den Filter nicht mehr benötige.


    Danke.
    Alex

  • Warum verwendest du nicht gleich im Filtermanager
    Gemeinsamen Filter
    im Abschnitt Selektive Übertragung
    mit dem Entsprechenden Eintrag des Betreffs
    da kannst du den Spam gleich löschen lassen, bevor er abgeholt wird.

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Warum verwendest du nicht gleich im Filtermanager
    Gemeinsamen Filter
    im Abschnitt Selektive Übertragung
    mit dem Entsprechenden Eintrag des Betreffs
    da kannst du den Spam gleich löschen lassen, bevor er abgeholt wird.


    Ich hab doch einen gemeinsamen Filter bei eingehende Nachrichten:

    Code
    $$$$ TB! Message Filter $$$$
    beginFilter
    UID: [6F2FA38E.01CA4E8D.766649FF.622BB402]
    Name: Spam\20direkt\20loeschen
    Filter: {\0D\0A\20`2`0`****SPAM****\0D\0A1`2`0`E-Mail\20blocked\0D\0A}
    Delete
    DeleteFromServer
    IsActive
    Ignore
    endFilter


    Aber das funktioniert leider nicht, weil Regula vor dem Filter greift.
    Oder hab ich dich jetzt nicht richtig verstanden?

  • Ich habe gerade getestet mit folgendem Filter für eines meiner Konten:

    Code
    $$$$ TB! Message Filter $$$$
    beginFilter
    UID: [015284EC.01CCFC5B.2C2691E8.1744FD8D]
    Name: TEST\20SELEKTIV
    Filter: {\0D\0A\20`2`0`[SPAM]\20Blah\0D\0A}
    IsActive
    endFilter


    ergibt

    Code
    07.03.2012, 13:11:13: FETCH - Verbunden mit dem POP3-Server
    07.03.2012, 13:11:13: FETCH - bestätigt (Standard)
    07.03.2012, 13:11:13: FETCH - 1 Nachricht(en) im Postfach, davon 0 neue
    07.03.2012, 13:11:13: FETCH - Nachricht von blah@er.de an info@gwendragon.de mit Betreff: "[SPAM] Blah", (ID: , Größe: 1363 Bytes) wurde zum LÖSCHEN markiert durch Filter: "TEST SELEKTIV"
    07.03.2012, 13:11:13: FETCH - Verbindung beendet - 0 Nachricht(en) empfangen


    Nirgendwo wird das Mail in irgendeinen Ordner sortiert, sondern gleich auf dem Server gelöscht!
    Da greift nix sich Regula nix.

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Ich hoffe, dass ich jetzt meinen Fehler gefunden habe.
    Ich hatte den Filter bei "Eingehende Nachrichten" gespeichert - statt bei "Selektive Übertragung".


    Muss ich hier auch bei Optionen "Mit anderen Filtern fortfahren" enablen und bei Tab Anwenden auf Konten aktivieren?

  • Ich hatte den Filter bei "Eingehende Nachrichten" gespeichert - statt bei "Selektive Übertragung".

    Hat Gwen im ersten Post extra geschrieben.



    Muss ich hier auch bei Optionen "Mit anderen Filtern fortfahren" enablen und bei Tab Anwenden auf Konten aktivieren?

    "Anwenden auf Konten" auf jeden Fall, da der gemeinsame Filter sonst ins Leere geht. "Mit anderen Filtern fortfahren" ist hingegen entbehrlich, da die Nachricht sowieso bereits auf dem Mailserver gelöscht und nicht weiter gefiltert wird.

  • "Anwenden auf Konten" auf jeden Fall, da der gemeinsame Filter sonst ins Leere geht. "Mit anderen Filtern fortfahren" ist hingegen entbehrlich, da die Nachricht sowieso bereits auf dem Mailserver gelöscht und nicht weiter gefiltert wird.

    Komisch, Filter will bei mir nicht funktionieren. ?(


    Konto: Gemeinsame Filter
    Name: Selektive Übertragung
    Optionen: Filter aktiv
    Anwenden auf Konten: alle ausgewählt

    Code
    $$$$ TB! Message Filter $$$$
    beginFilter
    UID: [68E7BA6C.01CCFC58.50A5CEF9.59C5F2E1]
    Name: Spam\20direkt\20loeschen
    Filter: {\0D\0A\20`2`0`****SPAM****\0D\0A1`2`0`E-Mail\20blocked\0D\0A}
    Delete
    DeleteFromServer
    IsActive
    endFilter


    Jemand eine Idee?

  • So wie du das machst, lädst du die erst runter, löscht die lokal und auf dem Server.


    Warum verwendest du als Filteraktion nicht "Sofort Löschen"?

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Hmm, bei mir sieht der Filter aber anders aus.
    Vielleicht ist das ein Bug in der 5.0.34. Mach mal ein Update auf 5.0.36.2.

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Zitat


    Hmm, bei mir sieht der Filter aber anders aus.


    Vielleicht ist das ein Bug in der 5.0.34. Mach mal ein Update auf 5.0.36.2.

    So hab jetzt ein Update gemacht.
    Seltsamerweise war nach dem Update der Selektive Übertragung-Filter nicht mehr vorhanden.


    Also hab ich ihn neu angelegt.
    So siehts jetzt aus:

    Code
    $$$$ TB! Message Filter $$$$
    beginFilter
    UID: [55787D8C.01CCFD65.53A13B3B.7E91182B]
    Name: Spam\20loeschen
    Filter: {\0D\0A\20`2`0`****SPAM****\20\0D\0A1`2`0`E-Mail\20blocked\20\0D\0A}
    IsActive
    endFilter



    Mal schauen, obs jetzt geht.
    Was ich noch geändert habe ist jeweils ein Leerzeichen nach jedem Betreff hinzugefügt.

  • Dat Dingens macht mich noch verrückt. :cursing:


    Code
    09.03.2012, 12:04:34: FETCH - Nachricht empfangen von support <donotreply@legacyconsulting.net>, Größe: 10951 Bytes, Betreff: "E-Mail blocked Tolle Spiele im SP Casino!"
    09.03.2012, 12:04:36: FETCH - Nachricht empfangen von donotreply@legacyconsulting.net an abc@xy.de, verschlüsselt: Nein, Größe: 10951, Datum: Freitag, 9. März 2012 11:55:40, Betreff: "E-Mail blocked Tolle Spiele im SP Casino!"


    Ist als HAM durchgekommen.


    Auch mit Betreff "****SPAM**** schlank werden?" oder "****SPAM**** zu dick?" sind als HAM durch. Leider aber nicht mehr im Account.log erfasst. Habe jetzt mal Log auf 50 kb gestellt und detailliert raus genommen.


    Kann es sein, dass der zweite Spam-Blocker "Bayes Filter 2.04" stört, aber eigentlich doch nicht, denn wenn ich es richtig verstanden habe, schlägt der selektive Filter vor den Spam-Plugins zu.


    GwenDragon
    Sieht mein selektiver Filter jetzt gleich aus, wie bei dir?

  • Wie? Du verwendest in TheBat die Plugins Regula und Bayes Filter?
    Deaktivier eines.
    Kann sein, dass die sich stören.
    Dann können wir weiter schauen oder warte bis gaijin was dazu sagt.


    Ich kann nicht rausbekommen, was bei dir hakt, wenn du ne ganz andere Umgebung verwendest als ich.


    Ob der Filter stimmt? Ja, ich glaub' schon.
    Du hast beim Filter auch:
    1. die Konten selektiert, auf die er wirken soll? (Reiter Anwenden auf Konten )?
    2. den Filter auf aktiv geschaltet?

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Ok, hab sicherheitshalber Bayes Filter gelöscht.


    Meine Config ist Win7 PRO x64, TB 5.0.36.2


    zu 1. ja alle Konten markiert
    zu 2. Filter ist aktiv


    Ich hab jetzt nochmals, auf Rat von Gaijin hin den Filter gelöscht, TB beendet - neu gestartet und dann zwei Filter angelegt
    jeweils mit nur einem Betreff drin, alle Konten markiert, Filter aktiv.
    Mal sehen, obs jetzt funktioniert.


    Benutzt TB für die selektive Übertragung einen anderen Port als 110?
    Mein gesamtes Netzwerk hängt inzwischen hinter einer ASG und da sind nur noch ausgewählte Ports offen.
    Ist es relevant, ob die SPAMs HMTL Mails sind?


    Gaijin
    Du hast in deinem Footer jetzt Phalanx anstatt Regula drinstehen. Wenn ich mich richtig erinnere bist du ja der Entwickler u.a. von Regula. Ist Phalanx deine Weiterentwicklung von Regula.
    Ist es sinnvoller Phalanx anstatt Regula in Zukunft zu nutzen?

  • Du hast in deinem Footer jetzt Phalanx anstatt Regula drinstehen. Wenn ich mich richtig erinnere bist du ja der Entwickler u.a. von Regula. Ist Phalanx deine Weiterentwicklung von Regula.
    Ist es sinnvoller Phalanx anstatt Regula in Zukunft zu nutzen?


    Phalanx ist ein eigenständiger Spam-Filter, der nicht an ein bestimmtes Mail-Programm gebunden ist. Dadurch ist Phalanx auch wesentlich leistungsfähiger und biete erheblich mehr Möglichkeiten als dies mit einem Plugin für TB! möglich wäre. Regula wird von mir nicht mehr weiterentwickelt und ich nutze es auch schon mehr als 4 Jahre nicht mehr selbt.


    Ich will niemanden zum Umsteigen überreden, aber ich würde auf jeden Fall Phalanx empfehlen.

  • Benutzt TB für die selektive Übertragung einen anderen Port als 110?
    Mein gesamtes Netzwerk hängt inzwischen hinter einer ASG und da sind nur noch ausgewählte Ports offen.
    Ist es relevant, ob die SPAMs HMTL Mails sind?

    Bei der "Selektiven Übertragung" werden nur die Headers (Nachrichtenkopf) einer Nachricht heruntergeladen und nicht die gesamte Nachricht. Deswegen wird auch nur anhand der Headers gefiltert. Wenn die eingestellte Filterbedingung dabei nicht erfüllt wird, dann wird die gesamte Nachricht heruntergeladen. Das passiert wohl in deinem Fall, wieso auch immer. An dem Port und/oder HTML sollte es jedenfalls nicht liegen, es sei denn, dass in einem solchen Fall nicht alle Headers übertragen werden, wiederum wieso auch immer.


    Wie ist es mit der Filteraktion "Ignorieren"? Werden die Nachrichten trotzdem heruntergeladen?

  • Hallo an alle Mitdenkende,


    Es läuft immer noch nicht.


    Ich hab jetzt schon an Dateirechte-Probleme gedacht.


    Meinem PCjetzt erst eine SSD spendiert und dadurch alles neu installiert. Gleichzeitig update von TB 3.x auf TB 5.x gemacht.
    Das Nachrichtenverzeichnis (E:\local_AllGmDat\eMail\The Bat!\) liegt und lag auf einer separaten HD und Dieses hab ich so in TB 5.x auch unverändert übernommen.


    IMHO werden die Filter in der Datei ACCOUNT.srb je Konto abgelegt und dort habe ich als Benutzer nur lesen und ausführen Rechte. Brauch ich da nicht höhere Rechte.

  • IMHO werden die Filter in der Datei ACCOUNT.srb je Konto abgelegt und dort habe ich als Benutzer nur lesen und ausführen Rechte. Brauch ich da nicht höhere Rechte.

    Sinngemäß nur dann, wenn du neue Filter erstellen möchtest. Für die bloße Ausführung braucht man normalerweise keine Schreibrechte.


    Ich hätte noch einen Vorschlag. Du hast geschrieben, dass Regula die entsprechenden Nachrichten als Junk erkennt. Danach müsste das Plug-in diese Nachrichten in den Junk-Ordner verschieben (eventuell in den Benutzereinstellungen aktivieren). Konfiguriere einfach den Junk-Ordner so, dass er bei Programmende geleert wird. Dann hast du dein gewünschtes Ergebnis, ohne dass irgendein Filer erstellt werden müsste.

  • TB ist bei mir schon so eingestellt, dass die Junks nach 10 Tagen, wenn TB geschlossen wird, gelöscht werden.


    Diese Junks will ich vorher ja noch händisch sichten, ob sich nicht doch ein HAM drunter geschmuckelt hat.
    Bei den SPAMs mit Betreff ****SPAM**** und E-Mail blocked sind aber bereits mind. 2 Anti-Junk-Waffen drüber gegangen und haben sie als Junk erkannt - deshalb wollte ich, dass die gleich ungesehen gelöscht werden.


    Aber ich versteh TB so langsam nicht mehr. Liegt es an der SSD, dass alles so schnell läuft? Vorher haben meine ganzen anderen Filter zu 100 % richtig funktioniert. Jetzt habe ich auch mit anderen Filtern so meine Probleme. Vielleicht hätte ich nicht updaten sollen. ?(


    Irgendwie will das mit der selektiven Übertragung als gemeinsamer Filter nicht funktionieren.


    Noch geb ich nicht auf. :P