"Datei erst beim Versand einfügen" funktioniert nicht

  • Hier läuft TB 5.0.3 mit Win XP


    Kontoeigenschaften, Dateien und Verzeichnisse. Das Häkchen bei
    [X] Datei(en) erst beim Versand einfügen


    ist gesetzt. TB macht das aber nicht. Heidengroße Dateien, die
    ich mal jemendem verschickt habe, blähen den Gesendet-Ordner
    auf. Was bei TB 1.6 eine 2-KB-E-Mail war, ist jetzt eine 2-MB-Mail.
    Mit derselben Vorgehensweise.


    Wie werd ich den Bug wieder los?

  • Ich konnte das jetzt mit v5.2 nicht nachvollziehen. Die Nachricht wird zusammen mit dem Anhang ganz normal abgeschickt. Diese Option bezweckt nur, dass man am Anhang noch weiter arbeiten und ihn z.B. verändern o.ä. kann, bevor man die Nachricht abschickt. So steht es auch in der Hilfedatei:

    Zitat

    Bind attachments only while sending out mail
    This setting allows you to continue working on attachments to messages before sending them. At the point of queueing the message in the outbox, the attachment is finalised and sent.

    Wenn also der Anhang nicht mehr verändert wird, dann sollte man vielleicht die Option abschalten. In den Changelogs ist dazu jedenfalls nichts enthalten, was darauf hindeutet, dass es nie ein Problem war, zumindest nicht in v5.0, v5.1 und v5.2.


    Außerdem schreibst du vom Gesendet-Ordner. Nachrichten, die erfolgreich abgeschickt wurden, landen normalerweise in diesem Ordner, der auch "Versandt" genannt wird. Also wurden die Nachrichten mit Anhängen erfolgreich versandt. Und die Ordner-Größe könnte man eventuell durch die Komprimierung verkleinern (z.B. über die rechte Maustaste oder die Ordnerwartung).

  • Es ist ja nicht so, dass der Anhang beim Senden nicht angefügrt wird. Wird er. Das Problem ist: Er bleibt dran!




    Ich bin ja vom TB 1.6 auf TB 5 gewechselt; was datwischen liegt, kenne
    ich nicht. Und mit TB 1.6 war es so: Die angefügte Datei erschein ganz
    normal als Anlage. Angenommen ein 1-MB-Bild. Dann wurde die E-Mail mit
    Einskommanochwas MB versendet. Dann lag sie im Gesendet-Ordner und war 3
    KB oder so groß. Es wurde aber ganz normal der Anhang angezeigt, man
    konnte ihn sich auch aufrufen. Nur war er keine Bestanteil der E-Mail,
    sondern wurde von dort geholt, wo er auch schon lag, als ich ihn
    angefügt habe (irgendwo auf meiner Festplatte). Ich habe jetzt noch +10
    Jahre alte archivierte verschickte Dateien, die genau dem Muster
    entsprechen. Probleme gibt es nur, wenn ich die Datei verschoben oder
    gelöscht habe. Aber dann weiß ich (dank Anhang-Makro) zumindest immer
    noch, dass die dran war.




    Wenn ich aber dieselbe 1-MB-Datei wie vor 10 Jahren mit
    [X] Datei(en) erst beim Versand einfügen
    verschicke, dann ist meine Datei im Postausgang nicht mehr 1,5 KB groß, sondern 1,6 MB.


    Da ich fast alles zum späteren Nachschlagen archiviere (Wem habe ich
    wann was geschickt?), lege ich auf eine schlanke Archivierung Wert. Ich
    versende oft große Dateien (Bilder). Zudem machen diese Datengrößen TB
    schwerfällig (vor allem beim Programm-Öffnen, -Schließen und
    Mail-Suchen).


    Warum kann TB 5 nicht, was TB 1.6 konnte? Das leuchtet mir nicht ein.
    Und auch nicht, warum ich anscheinend der einzige bin, dem diese
    nützliche Eigenschaft wichtig ist.

  • Meinst du vielleicht die Option "Dateianlagen speichern im..." in den Kotnoeigenschaften unter "Dateien & Verzeichnisse"? Wenn man dort "... Gesonderten Verzeichnis" einstellt, werden die Anhänge nicht im Nachrichtentext gespeichert und die E-Mails dadurch kleiner.

  • Meinst du vielleicht die Option "Dateianlagen speichern im..." in den Kotnoeigenschaften unter "Dateien & Verzeichnisse"? Wenn man dort "... Gesonderten Verzeichnis" einstellt, werden die Anhänge nicht im Nachrichtentext gespeichert und die E-Mails dadurch kleiner.


    Nein, das meine ich nicht. Dann hab ich jede versendete Datei zweimal auf der Platte, einmal im Quelleverzeichnis, und einmal im TB zugewiesenen Zielverzeichnis. Das ist doch genauso Unsinn. Und das zweitgenannte Verzeichnis regelmäßig zu leeren, führt dazu, dass die Verknüpfungen in den gesendeten E-Mails kaputt sind (bisher waren sie das nicht, sofern die verschickte Datei an ihrem Platz bleibt).


    Nimm mal ein praktisches beispiel. Ich habe im Postausgangsordner eine E-Mail vom 24. Januar 2003. Im Body steht nichts weiter als
    | Anlage(n):
    | tauch4a.JPG; tauch2a.JPG; tauch3a.JPG; tauch1a.JPG


    Die vier Fotos sind zusammen 243 KB groß (37+32+109+65 B). Ich kann sie auch sehen (Anklicken der Dateireiter) oder einzeln aufrufen, weil sie noch im gleichen Verzeichnis liegen, aus dem ich sie vor fast 10 Jahren angefügt habe (es war ein anderer Rechner, aber ich habe den neuen wieder ähnlich aufgesetzt). Die Dateigröße im Versandt-Ordner beträgt ganze 1608 Byte. Weil nämlich TB 1.6 "Dateien erst beim Versand einfügen" nicht nur versprochen, sondern auch gehalten hat (statt "erst" könnte es präziser "nur" heißen). Eine sehr schöne Funktion, denn so hat man ein schlankes TB-Archiv, ohne dass irgendwas fehlt. Und wenn ich die versandten Dateien doch gelöscht oder verschoben habe, sehe ich zumindest, welche es waren, die ich damals verschickt habe (Name und Typ).


    Nun nehme ich die E-Mail her, von der ich eben geschrieben habe, diese 1608-Byte-Mail mit den vier Bildern (genauer: den Verknüpfungen zu den vier Bildern, denn real sind sie ja nicht in TB drin, und sollen sie auch nicht). Ich führe die Funktion "Kopieren in Ausgang" aus. Dann verschicke ich genau diese E-Mail von damals mit TB 5 nochmal (nur an eine andere Adresse, eine von mir, um den damaligen Empfänger nicht mit dem Experiment zu belästigen). Jetzt finde ich diese Kope auch wieder im Versandt-Ordner, die Ansicht ist identisch, bloß mit dem kleinen großen Makel, dass der Spaß jetzt 343'725 Byte groß ist. Locker mal mehr als das 200fache als in TB 1.6 für nullkommanull Mehrwert.


    Das angebrachte Beispiel ist noch harmlos. Ich verschicke auch Dateien, die viele MB groß sind, und das häufig. Meinen Versandt-Ordner zu leeren, ist keine gute Idee. Denn, wie gesagt, ich will manchmal auch noch viel später wissen, wann ich wem was geschickt habe. Das habe ich ja am alten TB so geschätzt, man konnte zehntausende E-Mails im Versandt-Ordner (oder seinen Unterordnern) auf minimalem Speicherplatz haben. Aber damit es es nun anscheinend vorbei.


  • Nein, das meine ich nicht. Dann hab ich jede versendete Datei zweimal auf der Platte, einmal im Quelleverzeichnis, und einmal im TB zugewiesenen Zielverzeichnis. Das ist doch genauso Unsinn. Und das zweitgenannte Verzeichnis regelmäßig zu leeren, führt dazu, dass die Verknüpfungen in den gesendeten E-Mails kaputt sind (bisher waren sie das nicht, sofern die verschickte Datei an ihrem Platz bleibt).

    Kommoando zurück, Sanyok ist auf der richtigen Spur. Wenn ich also auswähle "Dateieinlagen speichern im gesonderten Verzeichnis", dann aber kein Verzeichnis zuweise ("<voreingestellt>"), dann ist dieses Verzeichnis das Quellverzeichnis der angehangenen Datein. Habe es eben mit dem nochmaligen Neuversand der 2003er Datei erfolgreich getestet, und auch mit einer neu angelegten E-Mail. Mein Problem ist damit gelöst, danke!

  • Wenn's läuft, dann ist das Thema erledigt. Ich habe nur geschrieben, dass wenn man die Anhänge in einem separaten Verzeichnis ablegen möchte, man anstelle von "<voreingestellt>" ein spezielles Verzeichnis dafür bestimmen sollte. "<Voreingestellt>" müsste das Stammverzeichnis sein.