Problem mit Zertifikaten / Fehlermeldung

  • Hallo zusammen,


    ich habe ein Problem beim Mailversand bzw. beim Abholen von Mails über eine sichere Verbindung.


    Die Einstellungen sehen wie folgt aus:


    POP 3: TLS Port 995 Auth: Standard


    SMTP: TLS Port 587 Auth: SMTP-Auth nach RFC 2554


    Nun erscheint beim Abholen von Mails folgende Meldung:


    [Blockierte Grafik: http://img845.imageshack.us/img845/1982/zox0.jpg]


    Klicke ich auf Fortfahren "OK" bekomme ich die Mails angezeigt bzw. sie werden abgeholt.


    Was könnte diese Meldung verursacht haben? Existieren möglicherweise keine gültigen Zertifikate mehr in meiner TB-Version. Ich muss gestehen, dass ich noch die Version 4.0.38 unter XP verwende (BTW: Sollte ich besser updaten? Welche Version ist empfehlenswert?). Was ist das in der Meldung erwähnte "Wurzekzertifikat"?


    Achso, mit Voyager klappt es hingegen mit den selben Einstellungen. Das ist doch merkwürdig...


    Ich bin für jeden Tipp dankbar :)


    Viele Grüße
    Mammal

  • Noch eine Ergänzung aus dem Protokoll:


    >27.10.2013, 14:20:43: FETCH - Zertifikat S/N: <<Nummer>>, Algorithmus: RSA (2048 Bits), ausgestellt von 21.01.2013 bis 22.03.2015 23:59:59, für 1 Host(s): <<domain>>.
    >27.10.2013, 14:20:43: FETCH - Besitzer: Go to https://www.thawte.com/repository/index.html, Thawte SSL123 certificate, Domain Validated, <<domain>>.
    >27.10.2013, 14:20:43: FETCH - Aussteller: US, Thawte, Inc., Domain Validated SSL, Thawte DV SSL CA.
    >27.10.2013, 14:20:43: FETCH - Aussteller: US, thawte, Inc., Certification Services Division, (c) 2006 thawte, Inc. - For authorized use only, thawte Primary Root CA.
    !27.10.2013, 14:20:43: FETCH - TLS-Handshakefehler. Ungültiges Serverzertifikat (Der Aussteller dieser Zertifikatskette wurde nicht gefunden)

  • Das habe ich noch nicht gesehen. Ich danke dir, de-bugger!!


    Die von Gwen beschriebene Lösung wird mir bestimmt weiterhelfen.
    Wenn ich es richtig verstehe, sind von dem Zertifikat-Problem aber nur alte TB-Versionen (4.x) betroffen!??

  • Ich muss gestehen, dass ich noch die Version 4.0.38 unter XP verwende

    Dann verschiebe ich mal in Therapieplatz v4.x.



    Wenn ich es richtig verstehe, sind von dem Zertifikat-Problem aber nur alte TB-Versionen (4.x) betroffen!??

    In dem anderen Thread war v5.3.4 und der Server Hotmail/Live/Outlook.com betroffen. Geht es bei dir auch um diesen Server? Wenn nicht, dann wird dir wahrscheinlich das Zertifikat aus dem anderen Thread nicht viel helfen. Du brauchst das Zertifikat für deinen Server. Thawte Root-/Wurzel-Zertifikate bekommen man unter https://www.thawte.com/roots/index.html. Am besten das Thawte Root Package mit allen Zertifikaten herunterladen. Ansonsten so vorgehen, wie von Gwen in dem anderen Thread beschrieben.

  • Wenn ich es richtig verstehe, sind von dem Zertifikat-Problem aber nur alte TB-Versionen (4.x) betroffen!??

    Die aktuellen TheBat 5.8.x haben aktualisierte Zertifikate, da sollte es zu wenig Problemen kommen.

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Stimmt, ich benötige das Zertifikat nicht für die Server
    Hotmail/Live/Outlook.com. Dann probiere ich es gleich mit dem
    thawte-Package aus, das ich nun heruntergeladen habe.


    Hinsichtlich der Vorgehensweise bin ich mir allerdings noch
    unsicher:


    Soll ich im Adressbuch zunächste ALLE existierenden (alten)
    thawte-Zertifikate löschen?


    Hinsichtlich des Imports:


    Nach Strg+T erfolgt der Eintrag des Zertifikatnamens (= jeweiliger
    Ordnername im thawte-Package) unter "Nachname"?


    Und welche Datei soll ich beim Import auswählen? In den einzelnen
    Verzeichnissen des thawte-Packages finden sich drei bis vier
    Dateien (.cer, .pem, .txt). Ist für den Import dann immer nur die
    .cer-Datei auszuwählen?


    Vielen Dank nochmals!

  • Nach Strg+T erfolgt der Eintrag des Zertifikatnamens (= jeweiliger
    Ordnername im thawte-Package) unter "Nachname"?

    Ja so mache ich es.


    Soll ich im Adressbuch zunächste ALLE existierenden (alten)
    thawte-Zertifikate löschen?

    musst du nicht. TheBat sucht sich immer die richtigen.



    Und welche Datei soll ich beim Import auswählen? In den einzelnen
    Verzeichnissen des thawte-Packages finden sich drei bis vier
    Dateien (.cer, .pem, .txt). Ist für den Import dann immer nur die
    .cer-Datei auszuwählen?

    cer. oder .pem, geht beides.

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • So, ich habe jetzt alles aus dem thawte-Package importiert. Jedenfalls soweit möglich. Die "alten" Einträge habe ich ertmal im Adressbuch gelassen.


    Was sich nicht zu installieren ging war "thawte Primary Root CA - G2 (ECC)". Außerdem war im Package das Verzeichnis "thawte Primary Root CA - G3 (SHA256)" leer.


    Bei einem thawte-Zertifikate ist mir aufgefallen, dass dort irgenwas von VeriSign stand. Fand ich etwas komisch, da VeriSign doch eigene Zertifikate hat. Hmm. Wird aber schon stimmen, nehme ich an.


    Der Übersichtlichkeit halber würde ich nun doch gerne alte thawte-Einträge llöschen. Was sind denn die wichtigsten Root-Zertifikate?


    Diese werden im Package geliefert. Ich habe alle importiert, was vielleicht gar nicht nötig war?!?


    - Thawte Personal Basic CA
    - Thawte Personal Freemail CA
    - Thawte Personal Premium CA
    - thawte Premium Server CA
    - thawte Primary Root CA - G1 (EV)
    - thawte Primary Root CA - G2 (ECC) -- Lässt sich nicht installieren
    - thawte Primary Root CA - G3 (SHA256) -- Keine Zertifikate
    - thawte Server CA
    - thawte SGC Root CA
    - Thawte Timestamping CA


    Oder lässt sich das so gar nicht beantworten?


    Viele Grüße!
    Mammal

  • Die "alten" Einträge habe ich ertmal im Adressbuch gelassen.

    Zertifikate, die abgelaufen sind, kannst du entfernen.



    Was sind denn die wichtigsten Root-Zertifikate? Diese werden im Package geliefert.

    Die Frage hast du bereits selbst beantwortet. Die aus dem Package sind die wichtigsten.



    Ich habe alle importiert, was vielleicht gar nicht nötig war?!?

    Du musst herausfinden, welches Wurzelzertifikat du brauchst. Falls du es nicht weißt, musst du so vorgehen, wie in der Fehlermeldung beschrieben ist, sich also mit dem Admin des Servers in Verbindung setzen.



    - thawte Primary Root CA - G2 (ECC) -- Lässt sich nicht installieren

    Ich konnte es installieren. Was in den runden Klammern steht, braucht man nicht einzutragen. Bei mir ist dieses Zertifikat einfach unter "thawte Primary Root CA - G2" eingetragen.



    - thawte Primary Root CA - G3 (SHA256) -- Keine Zertifikate

    Lade es von der o,g. Webseite separat herunter. Sie haben es wohl bei dem Package vergessen.

  • Das Zertifikat "thawte Primary Root CA - G3 (SHA256)" konnte ich nachträglich herunterladen und installieren.


    Was aber gar nicht klappt ist das "thawte Primary Root CA - G2" Zertifikat. Weder aus dem Package noch einzeln heruntergeladen.
    Beim Import kommt immer die Meldung "Die Datei....pem ist entweder beschädigt oder keine gültige Zertifikatsdatei".
    Mit der .cer-Datei klappt es aber auch nicht. Hier erscheint die selbe Meldung.

  • Das thawte Primary Root CA - G2 ist defekt.


    Auf der Seite steht aber auch, dass es derzeit nicht verwendet wird, du brauchst es nicht.

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Zitat

    Ich habe meins hier angehängt.


    Vielen Dank, funktioniert aber mit Version 4.0.38 leider auch nicht.


    Es erscheint auch hier die Fehlermeldung "Datei beschädigt oder kein Zertifikat".


    Mammal