Antwort auf HTML-Mail zeigt Leerzeilen

  • //MODEDIT: Abgeteilt von Text-Antwort auf HTML-Mail zeigt zusätzliche Leerzeilen


    Ich grab mal diesen Thread aus... gibts hierfür inzwischen ein Workaround?


    Beim Update von 3.99 auf die aktuelle Version ist mir aufgefallen, dass der Editor der alten Version
    beim Beantworten von solchen HTML Mails als reine Textmails weitaus seltener leere Zeilen eingefügt bzw. das "</p>"
    anders interpretiert hat als das jetzt die aktuellere Version macht.


    Wobei es die neue Version natürlich "richtiger" macht, aber es nervt trotzdem - gibt ja einige Outlook Jünger da draußen.


    Kann man das irgendwie in den Griff bekommen, dass Absätze (Enter im OL = </p>) als Zeilenumbrüche (Shift+Enter im OL = <br>) interpretiert werden?


    Danke und Grüße,
    Martin

  • Beim Update von 3.99 auf die aktuelle Version ist mir aufgefallen, dass der Editor der alten Version
    beim Beantworten von solchen HTML Mails als reine Textmails weitaus seltener leere Zeilen eingefügt bzw. das "</p>"
    anders interpretiert hat als das jetzt die aktuellere Version macht.

    Und die aktuellere ist wohl v7.x? Ich weiß nicht mehr, wie das mit v3.99 war, aber in v7.x sieht es in dieser Hinsicht besser als noch in v6.x aus. Es hängt dabei auch z.B. davon ab, mit welchem genauen Text-Editor man antwortet: MicroEd oder Windows Editor. Windows Editor hat z.B. bis vor kurzem zusätzliche Leerzeilen eingefügt, was in der Zwischenzeit behoben sein müsste. Außerdem ist es wichtig, mit welchem MUA die HTML-Mail verfasst wurde. Mit OL-Mails tritt das Problem am meisten auf. Aber auch dabei kommt's darauf an, wie die HTML-Mail verfasst wurde. Ich habe schon mehrere gesehen, bei denen bereits im Original zwischen jeder Textzeile eine Leerzeile vorhanden war bzw. der Zeilenabstand zu groß war, als ob jede Zeile ein neuer Absatz war, wie z.B. bei der oben angehängten Test-Mail. Ist der Text hingegen lückenlos geschrieben, gibt's beim Antworten entweder gar keinen oder nur unbedeutenden Abstand.

  • Upps sorry, hatte ganz übersehen dass der Thread unter "Therapieplatz Version 6.x" ist.


    Jap hatte das Ganze mit der v7.4.16 und MicroEd als Editor probiert.

    Ist der Text hingegen lückenlos geschrieben, gibt´s beim Antworten entweder gar keinen oder nur unbedeutenden Abstand.

    Genau das ist aber eben das Problem, viele schreiben (verständlicherweise) eben nicht lückenlos, sondern machen den Zeilenumbruch selber.
    Nur eben nicht "richtig" mittels Shift+Enter (was zu einem <br> führt), sondern nur mit einem Enter (was zu einem </p> führt).


    Und da war die alte Version wie es scheint um einiges nachlässiger (im positiven Sinn), mal davon abgesehen dass diese allgemein,
    aber vor allem beim Antworten oder Erstellen einer neuen Mail um einiges zackiger war. War mir auch schon mal früher
    beim Test einer 6.x aufgefallen. Es dauert einfach einen Augenblick länger.


    Aber damit könnte man leben, mit dem Verhalten des Editors leider nur schlecht, vor allem wenn man viele Kontakte hat die mit Outlook arbeiten.


    Grüße
    Martin

  • Ich habe es angeteilt.


    Es gibt wohl dazu keien Bugmeldung bei Ritlabs so wie ich das sehen kann.


    Kann bitte jemand das als Bug melden?

    The Bat! Pro 10.x BETA (32bit, keine nau) | Win 11 Pro x64 | GnuPG 2.4.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Ich habe es angeteilt.

    Danke!


    Zitat von GwenDragon

    Es gibt wohl dazu keien Bugmeldung bei Ritlabs so wie ich das sehen kann.
    Kann bitte jemand das als Bug melden?

    Najo, ich würde nicht soweit gehen und es als Bug bezeichnen.
    Immerhin interpretiert die Fledermaus den HTML Code richtig, das Problem liegt IMHO bei den anderen Mailclients.


    Aber eine Option dass der Code so konvertiert wird wie er vom internen HTML Editor angezeigt wird (dort sieht man nämlich auch keine
    Leerzeichen...) wäre sehr praktisch.


    Anbei ein paar Screenshot welches das Problem zeigt sowie die HTML der Outlook Mail.


    Grüße
    Martin

  • Najo, ich würde nicht soweit gehen und es als Bug bezeichnen.


    Das müsste ein Bug sein, wenn man auf die im v6.x Thread angehängte Test-Mail zum Vergleich in TB! und anderen MUAs antwortet. Im Original gibt's zwischen jeder Textzeile nur eine Leerzeile:

    Code
    Zeile 1
    
    
    Zeile 2
    
    
    Zeile 3
    
    
    MfG TEst

    Beim Antworten in TB! wird noch eine Leerzeile eingefügt:

    In Thunderbird sieht's hingegen mit nur einer Leerzeile dazwischen richtig aus:

    Code
    > Zeile 1
    >
    > Zeile 2
    >
    > Zeile 3
    >
    > MfG TEst

    Ebenso in WLM:

    Code
    Zeile 1 
    
    
    Zeile 2
    
    
    Zeile 3
    
    
    MfG TEst

    Wahrscheinlich ist es auch in anderen MUAs so. Demnach ist das Verhalten nur in TB! anders, aber auch nur im MicroEd oder Windows Editor. Antwortet man auf die Test-Mail im HTML-Editor, gibt's nur eine Leerzeile dazwischen. Das deutet ebenfalls darauf hin, dass es ein Bug in den Text-Editoren sein muss.

  • Zitat von sanyok

    Das müsste ein Bug sein, wenn man auf die im v6.x Thread angehängte Test-Mail zum Vergleich in TB! und anderen MUAs antwortet.

    Die "Test.eml" hat aber eine andere Problemursache.
    Hier stört sich die Fledermaus (übrigens auch die alte 3.99.29) scheinbar an der <div>/</div>Verschachtelung.
    Mir gehts aber um die <p>/</p> Interpretation... siehe Screenshots und Textfile (Html Horror by Outlook).


    Grüße
    Martin

  • Die "Test.eml" hat aber eine andere Problemursache.

    Nun, es ging ja ursprünglich auch um dieses Problem. Du hast ja auch zuerst dort gepostet. Gwen hat's lediglich getrennt, weil's hier um v7 und nicht um ein anderes Problem geht. Ich habe in dem v6 Thread gefragt, ob das Problem bereits im BT gemeldet wurde, da es in v7 immer noch vorhanden ist. Worauf du geschrieben hast, dass es fraglich sei, ob das ein Bug ist. Das mit "Test.eml" muss jedenfalls ein Bug sein.



    Mir gehts aber um die <p>/</p> Interpretation... siehe Screenshots und Textfile (Html Horror by Outlook).

    Und wie sieht's in deinem Fall mit anderen MUAs aus? Wie ich auf deinem Screenshot sehe, hast du es nur mit TB! v3 und v7 getestet. Wenn der zitierte Text in anderen MUAs ohne zusätzliche Leerzeilen dargestellt wird, dann muss auch dein Beispiel ein Bug sein. Kannst du übrigens eine Test-Mail in EML- oder MSG-Form hier anhängen? Persönliche Daten kannst du vorher entfernen.

  • Au weh. Das ist aber kaputtes Microsoft-HTML im Mail!


    Aber schick doch mal die Mail als Bugreport an Ritlabs Support oder Bugtracker.
    BugTracker-Verwendung


    Die Entwickler schauen dann was da machbar ist.

    The Bat! Pro 10.x BETA (32bit, keine nau) | Win 11 Pro x64 | GnuPG 2.4.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Wie auch immer - Bug oder nicht - anbei eine anonymisierte EML.

    Die angehängte Nachricht ist keine reine HTML, sondern eine sog. HTML + Nur-Text Nachricht (auch Multipart-Nachricht genannt). TB! kann ebenfalls solche erstellen. Wenn man sich den Text-Teil anschaut, dann sieht man Folgendes:

    Code
    Zeile1 - es folgt Enter
    
    
    Zeile2 - es folgt Enter
    
    
    Zeile3 - es folgt Shift+Enter
    Zeile4 - es folgt Shift+Enter
    Ende


    Es ist also bereits im Original zwischen den ersten drei Zeilen je eine Leerzeile vorhanden (Gesamt: 7 Zeilen). Beim Antworten in TB! bekommt man auch 7 Zeilen:

    Code
    > Zeile1 - es folgt Enter
    
    
    > Zeile2 - es folgt Enter
    
    
    > Zeile3 - es folgt Shift+Enter
    > Zeile4 - es folgt Shift+Enter
    > Ende


    Genauso ist es in Thunderbird und WLM. Keine zusätzliche Leerzeile wird eingefügt, wenn man im Text-Modus antwortet, weil für die Antwort der Text-Part zitiert wird.


    Antwortet man hingegen auf diese Multipart-Nachricht im HTML-Modus, wird der HTML-Part zitiert, der im Original keine Leerzeilen beinhaltet. Dann ist auch beim Antworten der zitierte Text in allen MUAs komplett ohne Leerzeilen.


    Alles wie es sein soll.

  • Au weh. Das ist aber kaputtes Microsoft-HTML im Mail!

    Jap, Outlook mit Word als HTML Editor - das Beste was Microsoft zu bieten hat. :whistling:;)


    Zitat von sanyok

    Antwortet man hingegen auf diese Multipart-Nachricht im HTML-Modus, wird der HTML-Part zitiert, der im Original keine Leerzeilen beinhaltet. Dann ist auch beim Antworten der zitierte Text in allen MUAs komplett ohne Leerzeilen.

    Meinst du ohne zusätzliche Leerzeichen oder wie in der Leseansicht komplett ohne - sprich in Summe 5 Zeilen?
    Letzteres bekomme ich nämlich eben mit der 7.4.16 nicht hin, oder mache ich was falsch?


    Wobei die Darstellung von 7 Zeilen ja lt. Text- sowie HTML Datei IMHO die richtigere wäre,
    würde da nicht der HTML Viewer der Fledermaus, Outlook und auch ua. Firefox und Chrome nicht eben nur 5 anzeigen.
    Der Grund hierfür scheinen wohl die Style Definitionen im Header der HTML Datei zu sein - genau genommen die margin:0cm Angabe.


    Grüße
    Martin

  • Meinst du ohne zusätzliche Leerzeichen oder wie in der Leseansicht komplett ohne - sprich in Summe 5 Zeilen?

    Beim Antworten im HTML-Editor (Nur HTML oder HTML + Nur-Text) bekomme ich 5 Zeilen ohne jegliche Leerzeilen dazwischen. Es ist also so, wie im Original-HTML-Part beim Betrachten. Getestet ebenfalls mit v7.4.16.



    Wobei die Darstellung von 7 Zeilen ja lt. Text- sowie HTML Datei IMHO die richtigere wäre,

    Wie ich bereits geschrieben habe, sieht man im Original 7 Zeilen nur im Text-Part, im HTML-Part hingegen 5 Zeilen. Es ist also bereits im Original unterschiedlich.



    würde da nicht der HTML Viewer der Fledermaus, Outlook und auch ua. Firefox und Chrome nicht eben nur 5 anzeigen.

    Für den Test sollte man keine Browser, sondern MUAs nehmen, da die Browser nur den HTML-Part und deswegen nur 5 Zeilen anzeigen. Über die Option "Nur-Text und HTML-Nachrichten anzeigen als:" in den Benutzereinstellungen kann man in TB! bestimmen, wie eine Multipart-Nachricht angezeigt werden soll. Hat man dort "HTML und Nur-Text-Version" gewählt, erhält man bei einer Multipart-Nachricht zwei Reiter "HTML" und "Text", über die man sehen kann, wie der HTML-Part und wie der Text-Part dieser Multipart-Nachricht im Original aussehen.


    Im Thunderbird kann man das über das Menü "Ansicht | Nachrichteninhalt" ändern. Ist dort "Original HTML" gewählt, sieht man 5 Zeilen. Wählt man hingegen "Reiner Text", bekommt man 7 Zeilen. Ob man im HTML- oder Text-Modus antworten möchte, kann man in Thunderbird ebenfalls einstellen. Das Verhalten ist dann genauso wie in TB!: beim Antworten im HTML-Modus bekommt man 5 und beim Antworten im Text-Modus 7 Zeilen.


    In WLM wird eine Multipart-Nachricht standardmäßig auch nur im HTML-Modus angezeigt. In den Einstellungen kann man aber die Option "Alle Nachrichten als Nur-Text lesen" aktivieren. Danach wird der Text-Part mit 7 Zeilen angezeigt. Auch den Editor-Modus kann man in den Einstellungen wählen. Stellt man HTML ein, werden beim Antworten 5 Zeilen angezeigt, im Text-Editor hingegen 7 Zeilen. Auch hier ist das Verhalten wie in TB!


    Ich gehe davon aus, dass sich OL und andere MUAs insoweit auch gleich verhalten. Ein Fehler/Bug in TB! ist daher nicht ersichtlich.

  • @sanyok
    Danke für Deine Ausführungen!


    Beim Antworten im HTML-Editor (Nur HTML oder HTML + Nur-Text) bekomme ich 5 Zeilen ohne jegliche Leerzeilen dazwischen. Es ist also so, wie im Original-HTML-Part beim Betrachten. Getestet ebenfalls mit v7.4.16.


    Nicht aber wenn die HTML eMail als Textmail beantwortet wird.
    Ich fürchte da haben wir aneinander "vorbeigeschrieben" obwohl ich es in meinem ersten Post erwähnt hatte.


    Während die alte Version den HTML Teil so zitiert wie er angezeigt wird (5 Zeilen), wird in der neuen Version (bzw. schon länger) der "Multipart-Text" eingefügt,
    was in diesem Beispiel 7 Zeilen zufolge hat.


    Man kann nun darüber streiten welches Verhalten das "richtigere" ist, ich würde sogar meinen das jetzige ist es,
    aber gerade ua. wegen solcher "tollen" OL Mails wäre eine Option welche den Code so zitiert wie er vom internen HTML Editor angezeigt wird (wie es eben früher gemacht wurde) sehr praktisch.


    Grüße
    Martin

  • Bei mir nicht - auf drei verschiedenen Systemen

    Verwendest du vielleicht eine spezielle Antwort-Vorlage? Klicke mal für den Test auf die Schaltfläche "Standardvorlage wiederherstellen". Mit der Standardvorlage bekomme Ich beim Antworten Folgendes angezeigt:



    5 Zeilen ohne etwas dazwischen. Die blaue Linie ist bereits berüchtigt. In den Benutzereinstellungen ist als Standard-Text-Editor "Nur HTML" eingestellt. Die o.g. Option ist aktiviert. Habe das mit verschiedenen Konten getestet. Habe sogar in den Benutzereinstellungen "Nur-Text-Version" bei "Nur-Text und HTML-Nachrichten anzeigen als:" eingestellt. Angezeigt wird dann nur der Text-Part mit 7 Zeilen, beim Antworten werden jedoch weiterhin keine Leerzeilen zitiert.


    Weiß nicht, wo der Unterschied zwischen unseren Systemen noch liegen könnte. Vielleicht testet das jemand noch und schreibt, wie es bei ihm/ihr aussieht.


  • In den Benutzereinstellungen ist als Standard-Text-Editor "Nur HTML" eingestellt.

    Das Ergebnis ist eine Antwortmail im HTML Format.
    Auch wenn die Option HTML-Nachrichten im "Nur-Text-Format" beantworten aktiviert ist.
    Ändert man das Nachrichtenformat während des Antwortens auf Nur-Text hat man wieder 7 Zeilen.


    Grüße
    Martin

  • Ändert man das Nachrichtenformat während des Antwortens auf Nur-Text hat man wieder 7 Zeilen.

    Ja, weil der Original-Text-Part aus 7 Zeilen besteht. Ich habe dich so verstanden, dass bei dir der zitierte Text jedoch immer aus 7 Zeilen unabhängig davon besteht, ob du im HTML- oder Text-Modus antwortest.


    Das Verhalten in TB! ist jedenfalls wie in anderen MUAs. Du kannst einen BT-Eintrag erstellen, jedoch wird es bestimmt schwierig sein, die Entwickler davon zu überzeugen, dass TB! einen Fehler macht, wo doch die anderen MUAs genauso regieren.