Schnellvorlage Datei anfügen funktioniert nicht

  • Habe nach Vorgabe eine Schnellvorlage erstellt, die früher mal das Verzeichnis zum Auswählen von Nachrichten öffnete.
    Nun passiert jedoch gar nichts. Was ist falsch?

    //modedit: Code korrekt eingesetzt, Post verschoben.

  • Geht bei mir mit 7.4.16 32bit auf Win 10.


    Ich habe die Schnellvorlage als Gemeinsame Vorlage mit dem Kürzel datei angelegt im Format Text.
    Wenn ich datei in den Mailbody eingebe und Ctrl+Leertaste eingebe, öffnet bei mir die Dateiauswahl, nach Auswahl einer Datei wird die auch als Anhang samt Text für Größe und Art eingefügt.


    XMP geht nur mit The Bat! 32bit. Außerdem braucht es im Programmordner von The Bat! die Datei pcre.dll.
    Und hast du XMP auch in The Bat! als Plugin angemeldet?




    Ach so, ja:
    Schnellvorlage in HTML geht nicht. Ist ein Bug mit MAkros und HTML :(
    Siehe BUG: https://bt.ritlabs.com/view.php?id=521

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    2 Mal editiert, zuletzt von GwenDragon ()

  • XMP geht nur mit The Bat! 32bit. Außerdem braucht es im Programmordner von The Bat! die Datei pcre.dll.Und hast du XMP auch in The Bat! als Plugin angemeldet?


    Ach so, ja:
    Schnellvorlage in HTML geht nicht. Ist ein Bug mit MAkros und HTML :(
    Siehe BUG: https://bt.ritlabs.com/view.php?id=521

    Hm... habe 64bit... Dann wirds so wohl leider nix mehr? Schade, in der alten Version ging es ja bei 64bit...
    Mail wäre "nurText", als Plugin angemeldet? ka, denke nicht aber wie egesagt, wenns unter 64bit eh nicht geht... :( :(

  • Hm... habe 64bit... Dann wirds so wohl leider nix mehr? Schade, in der alten Version ging es ja bei 64bit...

    64-Bit Windows oder 64-Bit TB!? Unter 64-Bit TB! kann man das XMP Plug-in nicht einbinden. Es klappt daher mit keiner 64-Bit TB! Version und hat auch nie. Mehr zum XMP 64-Bit im Thread "XMP 64-Bit". Es wird also keine geben.


    Benutzt du hingegen zwar eine 64-Bit Windows-, jedoch eine 32-Bit TB!-Version, dann kannst du das Plug-in einbinden. Dass es dennoch nicht klappt, könnte aber an dem o.g. Bug liegen.

  • @Wichtelmann Ich benutze selbst XMP + The Bat! 7.4.16 (32bit) + Win 10x64.
    Ich hätte es nicht so gesagt, wenn es nicht funktionieren würde.


    Wozu brauchst du The Bat! 64bit?

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • 64-Bit Windows oder 64-Bit TB!? Unter 64-Bit TB! kann man das XMP Plug-in nicht einbinden. Es klappt daher mit keiner 64-Bit TB! Version und hat auch nie. Mehr zum XMP 64-Bit im Thread "XMP 64-Bit". Es wird also keine geben.
    Benutzt du hingegen zwar eine 64-Bit Windows-, jedoch eine 32-Bit TB!-Version, dann kannst du das Plug-in einbinden. Dass es dennoch nicht klappt, könnte aber an dem o.g. Bug liegen.


    The Bat! Professional Edition
    Version 7.4.16 (64-bit)
    Copyright © 1998-2017 Ritlabs, SRL
    Alle Rechte vorbehalten.

  • The Bat! Professional Edition
    Version 7.4.16 (64-bit)

    Und du konntest XMP über "Benutzereinstellungen | Plugins" erfolgreich einbinden? Ich habe jedenfalls mit der allersten 64-Bit-Version 6.7 eine Fehlermeldung erhalten, als ich es versuchte. Vielleicht kann man das mittlerweile. Funktionieren wird aber ein 32-Bit Plug-in mit einer 64-Bit-Version nicht.

  • Die 32bit-Plugins (egal welche) haben noch nie mit 64bit-The Bat! funktioniert.


    Muss @Wichtelmann wissen, was er jetzt nutzen will – 64bit ohne XMP oder 32bit mit.

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Gibts denn irgendwelche anderen Nachteile mit TB32bit?

    Wieso Nachteile? XMP funktioniert ja mit TB! 32-Bit. Und vom o.g. Bug #0000521 sind sowohl 32- als auch 64-Bit TB!-Versionen betroffen. Schließlich kann man Makros ja auch ohne XMP verwenden.



    Kann ich das ggf noch korrigieren?

    Du könntest den o.g. Eintrag im BT bestätigen. Wie es geht, steht im Thread "BugTracker-Verwendung".



    Hatte glaube ich in der 5er Vorgängerversion auch Anti Virus und Junk Plugins aktiviert...

    TB! 64-Bit kam erst mit v6.7. v5.x war nur als 32-Bit verfügbar. Da konntest du natürlich XMP problemlos einbinden und verwenden.

  • Schließlich kann man Makros ja auch ohne XMP verwenden.

    Sorry ich bin ja nicht so tief in der Materie drin. Von XMP, der Verwendung oder den Möglichkeiten weiß ich nichts. Ich sehe derzeit, dass das Makro so nicht funktioniert. Bekomme ich es also mit der 64bit so (weil ohne XMP?) nicht hin?
    Du sagtest ja Makros funktionieren auch ohne...

  • Das was du da machen willst, geht nur mit XMP-Plugin. Die Vorlage oben hat ja %XMP_… Makros drin, also brauchst du es dazu.
    Das geht nur mit The Bat! 32bit. Deinstalliere die 64bit und Installiere die 32bit.

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Du sagtest ja Makros funktionieren auch ohne...

    Es gibt Makros, die von TB! bereits standardmäßig ohne jegliche Plug-Ins funktionieren. Die offizielle Makros-Liste mit Erklärungen findet man in der Online-Hilfe. Deine Vorlage besteht aber aus XMP-Makros und wird daher ohne XMP nicht funktionieren.


    Du hast daher zwei Möglichkeiten. Entweder, wie von Gwen vorgeschlagen, steigst du von TB! 64- auf TB! 32-Bit um und verwendest deine Vorlage mit dem XMP Plug-in. Oder du bleibst bei TB! 64-Bit, musst aber deine Vorlage anpassen, also nur die von TB! unterstützten Makros verwenden. Ob das überhaupt geht, weiß ich allerdings nicht. Schließlich wurde XMP ja entwickelt, weil TB! selbst nicht alles kann.

  • Das oben gezeigte XMP-Makro (Datei öffnen, Dateiliste einlesen, etc) ist nicht mit den internen The Bat!-Makros zu erreichen.

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.