Mails exportieren mit Betreff

  • Interessant ist, fand ich eben erst raus, das jene 4 Mails, welche sich nicht exportieren lassen, jedoch von Hand, vollkommen problemlos, in den letzten Ordner des automatisch erstellten Pfades (der durch vorheriges Exportieren anderer Mails dorthin zuvor erstelt worden war), gespeichert werden können.

  • @Trevor Eben ein Bug im Filtermanager.


    Gibt es im Mailverzeichnis ein thebatXX_Exceptions log oder ex_log?
    Wenn ja auch beim Ritlabs-Support mit hochladen senden.
    Schließlich sollen andere nicht auch noch dasselbe Ärgernis haben wie du beim Export.

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Gerade rausgekriegt: Wenn eine Mail über den Filtermanager nicht exportiert werden kann, wie oben beschrieben, landet tatsächlich ein Fehlereintrag in der Datei thebat32_Exceptions.log (in meinem Fall.)


    Könnte das Problem darin bestehen, dass im Pfad ein zusätzliches Leerzeichen auftaucht vor dem schließenden Backslash? \Xxxxx X. Xxxxx \
    Die Xe entsprechen dem anonymisierten Namen des Absenders. Der Absendername wird über das Makro %FROMNAME ausgelesen. Das entsprechende Kopfdatenfeld enthält dieses Leerzeichen auch.


    Von: "Xxxxx X. Xxxxx " <mail@domain.com> (Company)

  • Ich konnte es wohl reproduzieren: Der Export über den Filter scheitert, wenn

    • das ausgewertete Feld (im Beispiel der Absender) Teil des Dateipfades wird UND
    • das ausgewertete Feld Anführungszeichen enthält UND
    • vor dem zweiten Anführungszeichen ein Leerzeichen steht.

    Von: Test <test@domain.com> funktioniert
    Von: "Test" <test@domain.com> funktioniert
    Von: " Test" <test@domain.com> funktioniert
    Von: "Test " <test@domain.com> funktioniert nicht


    Der Testpfad war in meinem Fall dann D:\export\2015\Test \...
    Der Grund, dass es nicht funktioniert ist, dass Windows (in meinem Fall 10) ein Leerzeichen, das bei der Erstellung eines neuen Ordners am Ende eingetippt wird ("Test ") beim tatsächlichen Anlegen des Ordners wieder weglässt. Der Erstellvorgang über den Filtermanager funktioniert ja noch. Der anschließende Exportvorgang will dann aber die Mail in den Ordner ...\Test \... exportieren, den es aber dann nicht mehr gibt. Daher scheitert der Export.


    Beim Speichern der Mail über das Menü oder über Drag and Drop in den Windows Explorer wird die Mail in einen existierenden Ordner exportiert und zudem das Feld Absender (in diesem Fall) nicht ausgewertet. Deswegen gelingt das Speichern von Hand auch bei solchen Mails.

  • @mse Dann melde das doch mal as Bug.
    Kann ja nicht sein, dass es so nicht zu exportieren ist.

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Kann ich schon machen, aber ich bin nicht sicher, ob das überhaupt ein The Bat Fehler ist.


    Ich habe das Exportieren mit dem TBBETA-Ordner getestet. Darin sind 23.656 Mails, bei 17 davon hat es nicht funktioniert und alle kamen vom selben Absender. Ich sehe das eher als Fehlkonfiguration des Absenders an, welche aber nur deshalb relevant wird, weil Windows Leerzeichen am Ende von Ordnernamen nicht verweigert, sondern statt dessen einfach weglässt. The Bat hingegen verwendet zum Export exakt das, was ihm zwischen zwei Anführungszeichen hingeworfen wird.


    Im Unterschied dazu: Wenn ein zu exportierendes Feld, das später Teil des Dateinamens werden soll, unerlaubte Zeichen enthält (z.B. /\ * : ?) wird es korrekt durch einen Unterstrich ersetzt.