The Bat! 9.0.8 MSI

  • Please try The Bat! 9.0.8 MSI files:
    32-bit https://www.ritlabs.com/downlo…e_bat/thebat_32_9-0-8.msi
    64-bit https://www.ritlabs.com/downlo…e_bat/thebat_64_9-0-8.msi


    [-] (#0001888) "Cannot focus a disabled or invisible window" error on closing folder view window
    [-] Access Violation at start on some existing installations, related to tbuser.def handling


    https://www.mail-archive.com/t…utaint.com/msg112184.html

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Wie gut funktioniert die neue GPG-Integration eigentlich? Immerhin haben sie sie ja als runderneuert angepriesen.

    Wo wurde das angepriesen? Es wurde damals lediglich mitgeteilt, dass die veraltete integrierte PGP-Unterstützung nach RFC-1991 entfernt wird, was auch geschehen ist. Der Punkt ist zwar im PGP-Menü weiterhin sichtbar. Die entsprechende Option ist aber ausgegraut und kann daher nicht mehr gewählt werden. Der Rest ist wie früher geblieben.

  • Es ist, wie du selbst festgestellt hast, regelmäßig abgestürzt oder - zum Schluss - beim Verschlüsseln einfach ausgegangen. Auf der Betaliste sah ich gestern eine Version, die das korrigieren sollte, aber das habe ich noch nicht ausprobiert (meine Geduld ist endlich - und ich war noch nicht wieder am Desktoprechner)...

  • Es ist, wie du selbst festgestellt hast, regelmäßig abgestürzt oder - zum Schluss - beim Verschlüsseln einfach ausgegangen.

    Sowas kann ich nicht mehr nachvollziehen, ich benutze seit langem GnuPG auf meiner 32bit The Bat!.
    Aber jetzt wo du es sagst, kann The Bat! mal wieder bestimmte HTML-Mails nicht entschlüsseln.
    The Bat! ist sowas von kaputt bei GnuPG.

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    2 Mal editiert, zuletzt von GwenDragon ()

  • Breite Spalte Anhange in Editor
    wird nicht gemerkt.
    Könnt ihr das bestätigen?

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Siehste ...

    Na ja, es fällt halt nicht immer auf. Zudem ist Text-Mails nutze.


    Macken mit OpenPGP mir nur ca. 1× im Monat oder noch seltener, dass Mails nicht geprüft/entschlüsselt werden. Meistens ist daran der sendende Mailclient schuld.


    Aber Thunderbird + Enigmail läuft da robuster als The Bat!. :(

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Was eigentlich witzig ist, weil die Unzuverlässigkeit von Enigmail mich damals zu The Bat! getrieben hatte. (Wirklich performant ist Enigmail aber immer noch nicht - und wirklich mögen tu' ich Thunderbird auch immer noch nicht.) Deswegen hatte ich mir ja viel versprochen, als es ursprünglich hieß, "der Kern" von The Bat! solle neu entwickelt werden. Aber sie meinten anscheinend bloß die blöden Oberflächenelemente. Tja nun...

  • als es ursprünglich hieß, "der Kern" von The Bat! solle neu entwickelt werden. Aber sie meinten anscheinend bloß die blöden Oberflächenelemente. Tja nun...


    Hoffen wir mal, dass es nicht "Des Kaisers neue Kleider sind" und That Bat! dann nur nackert mit einer neuen Versionsnummer da steht.

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • @sanyok Probleme die ich bei GnuPG habe sind in beiden Versionen gleich.
    Und wo sind ist die Einbindung für GnuPG neu geschrieben worden? Quelle?


    Muss ich etwa alle Bugs wieder neu melden nur weil die 9er ein neues GUI hat? Sehe ich nicht ein.

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Muss ich etwa alle Bugs wieder neu melden

    Soweit ich Max verstanden habe, sollte man im BT für v9 immer die Kategorie New Release Specific nehmen. Wahrscheinlich sortieren sie die BT-Einträge danach und die Einträge mit anderen Kategorien werden als Bugs für v8 interpretiert und zweitrangig behandelt, wenn überhaupt, da es wohl keine weitere v8 mehr geben wird. Jetzt entsteht natürlich die Frage, ob man alte Einträge weiterhin ergänzt oder neue erstellen muss.


    Mein alter #0001680 für v8 wurde z.B. geschlossen, da angeblich gefixt, und der neue #0001894 unter der o.g. Kategorie wurde für v9 erstellt.


    Du musstest ebenfalls für irgendein Problem einen neuen erstellen, war vielleicht sogar etwas mit GPG.



    Der Punkt ist zwar im PGP-Menü weiterhin sichtbar

    Wen's übrigens stört, sollte den von mse erstellten Eintrag #0001832 bestätigen.

  • Was für ein Trauerspiel, dann muss ich die alten Bugs für die 9er klonen/neu erstellen :(

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Ich find's auch unsinnig. Wozu hat man über 40 Kategorien, wenn man jetzt für alles nur eine einzige benutzen soll? Max fängt jetzt auch schon an, bei den neuen Einträgen die Kategorie zu ändern. Also ist sie doch relevant. Solange das aber den Entwicklern irgendwie hilft. Hauptsache, dass die Bugs behoben werden.