The Bat! 9.2.0.3 (BETA)

  • Ok, gleich Nachfrage auf Deine Antwort zur älteren Version: Ins Installationsverzeichnis entpacken? Nicht ins Programmverzeichnis von TB!?

    Nur mal zum Verständnis: Das Installationsverzeichnis ist bei mir das Verzeichnis, in das ich die Installationsdatei speichere und aufhebe und von dem aus ich dann den Installationsprozess starte.

  • Genau.
    Gute Nachricht: Mein Rechner ist nicht explodiert und die ganzen Programmfenster (also Nachrichtenliste und so weiter) sehen noch aus wie vorher. Auch die Shortcuts scheinen noch zu funktionieren.

    Ich muss Sanyok Recht geben, die eingetroffenen HTML-Mails sehen deutlich besser aus, ich würde sogar sagen: Wie im Original. Also so, wie sie gemeint waren.

    Aber: Das Weiterleiten ist ein Graus. Bei dem normalen Weiterleiten eines einfachen IKEA-Newsletter sind erstmal alle Bilder verlorengegangen. Beim Weiterleiten als EML-Anhang waren die zwar da, aber der gesamte Inhalt wurde genauso schlecht dargestellt wie beim alten TB! mit dem eingebauten HTML-Betrachter. Nämlich immer alle Bilder doppelt nebeneinander. Es gibt auch keinen Button zum Umschalten des Betrachters. Ist wohl nicht mehr vorgesehen. Da muss Ritlabs unbedingt noch nachbessern.

  • Etwas ist mir noch aufgefallen, was ich schon einmal in einer älteren Version angemerkt hatte:
    Wenn ich das Adressbuch aufrufe und dort mit TAB in das Kontaktefenster wechsle (wo unverständlicherweise der Bereich ab "Favorit" blau markiert ist, nicht der Name), dann kann ich nicht mehr mit STRG-A alle Kontakte markieren und auch nicht mit ALT-ENTER die Eigenschaften der markierten Kontakte anzeigen lassen. Kann das vielleicht nochmal jemand weitergeben?

  • Noch etwas ist mir aufgefallen:
    Wenn ich das in die Taskleiste minimierte TB! wieder "erwecke" und maximiere, dann befindet sich oberhalb der drei nebeneinander liegenden Fenster und unterhalb des Menüs ein großer, grauer Streifen. Wahrscheinlich da, wo sich sonst allerlei große, bunte Bildchen tummeln. Ich muss dann immer erstmal die Markierung in der Ordner- oder Mailliste ein Element nach oben oder unten bewegen, dann verschwindet dieser graue "Platzhalter" wieder und die Fenster befinden sich unmittelbar unter dem Menü.

    Ist das bei Euch auch so?

  • Noch etwas ist mir aufgefallen:
    Wenn ich das in die Taskleiste minimierte TB! wieder "erwecke" und maximiere, dann befindet sich oberhalb der drei nebeneinander liegenden Fenster und unterhalb des Menüs ein großer, grauer Streifen. Wahrscheinlich da, wo sich sonst allerlei große, bunte Bildchen tummeln. Ich muss dann immer erstmal die Markierung in der Ordner- oder Mailliste ein Element nach oben oder unten bewegen, dann verschwindet dieser graue "Platzhalter" wieder und die Fenster befinden sich unmittelbar unter dem Menü.

    Ist das bei Euch auch so?


    Ja, das ist bekannt. Ich habs Ritlabs schon kommuniziert und auf der Beta-Mailingliste gibts auch Bestätigungen. Du kannst im Bugtracker ebenfalls einen Kommentar dazupacken: https://bt.ritlabs.com/view.php?id=2030

  • Das Installationsverzeichnis ist bei mir das Verzeichnis, in das ich die Installationsdatei speichere

    Dann verwendest du diesen Begriff falsch, denn das Installationsverzeichnis ist das Verzeichnis, in das etwas installiert wird, und nicht in dem die Installationsdateien liegen. Daher sind das Installationsverzeichnis und das Programmverzechnis Synonyme. Das andere kann man hingegen z.B. als Download-Verzeichnis bezeichnen.


    Bei dem normalen Weiterleiten eines einfachen IKEA-Newsletter sind erstmal alle Bilder verlorengegangen.

    Das liegt wohl daran, dass der HTML-Editor immer noch die alte HTML-Engine verwendet. Außerdem ist immer noch unklar, wo die nachgeladenen Dateien gespeichert werden. Vielleicht werden sie deswegen bei einer Weiterleitung nicht eingebettet.


    Beim Weiterleiten als EML-Anhang waren die zwar da, aber der gesamte Inhalt wurde genauso schlecht dargestellt wie beim alten TB! mit dem eingebauten HTML-Betrachter.

    Das wiederum kann ich nicht bestätigen. In der angehängten EML-Datei ist alles enthalten und beim Öffnen wird sie im neuen HTML-Betrachter richtig angezeigt.


    Es gibt auch keinen Button zum Umschalten des Betrachters. Ist wohl nicht mehr vorgesehen.

    Ja, laut Roadmap unter TheBat! Roadmap wurde anvisiert, sowohl den internen als auch den IE-Renderer zu entfernen und durch CEF zu ersetzen. Es wird jetzt also wohl nur noch eine HTML-Engine geben, was auch Sinn macht, denn IE ist unsicher und der eingebaute war schlecht.


    Wenn ich das Adressbuch aufrufe und dort mit TAB in das Kontaktefenster wechsle (wo unverständlicherweise der Bereich ab "Favorit" blau markiert ist, nicht der Name), dann kann ich nicht mehr mit STRG-A alle Kontakte markieren und auch nicht mit ALT-ENTER die Eigenschaften der markierten Kontakte anzeigen lassen. Kann das vielleicht nochmal jemand weitergeben?

    Das kann ich bestätigen. Es liegt wohl daran, dass DevExpress entfernt und die alte Toolbar mit dem alten Anpassungsmenü wiederhergestellt wurden. Dadurch sind wohl einige Shortcuts verlorengegangen. Man kann sie aber über das Anpassungsmenü selbst vergeben, so dass es keine große Sache ist.


    Also, das Adressbuch aufrufen, auf die Toolbar rechtsklicken, "Anpassen..." wählen und dann den Reiter "Tastenkombinationen". In der Baumansicht "Bearbeiten" öffnen und dort zuerst auf "Alles auswählen" doppelklicken und STRG+A vergeben und anschließend gleich darunter auf "Eigenschaften..." doppelklicken und ALT+ENTER vergeben. Das war's!

  • Ich muss das mit der EML-Mail nochmal überprüfen. Dummerweise habe ich die Mails schon wieder gelöscht, aber morgen kommen sicher neue. Ich hatte extra eine ausgewählt, bei der mit dem alten, internen HTML-Betrachter alle Bilder doppelt angezeigt wurden. Die habe ich dann testweise an mich selbst geschickt. Ich habe dann die Nachricht einfach so im Vorschaufenster angesehen, also den HTML-Teil. Da waren wieder alle Bilder doppelt. Ich hätte vermutlich unten auf den Reiter EML-Nachricht gehen sollen oder sonstwie allein die EML-Mail öffnen sollen, dann wäre sie richtig angezeigt worden.


    Deine Beschreibung des Hinzufügens von Shortcuts ist schön ausführlich und hat natürlich funktioniert. Übrigens windowseinheitlich ALT-ENTER für die Eigenschaften, nicht STRG-ENTER. Hast Du nun auch noch eine Lösung dafür, wie man den blauen Markierungsbalken auf die ganze Zeile ausdehnt, also auch den Namen? Das irritiert mich immer so, wenn nur die rechte Hälfte markiert ist.

  • Ich habe dann die Nachricht einfach so im Vorschaufenster angesehen, also den HTML-Teil.

    Ich habe auf den EML-Anhang gedoppelklickt (so steht's übrigens im Duden; ich persönlich hätte "doppelgeklickt" gewählt), worauf er in einem separaten Fenster angezeigt wurde. Dort wird die neue Engine eingesetzt, daher war die Anzeige korrekt. In der Tab-Vorschau wird vielleicht noch die alte verwendet.


    Übrigens windowseinheitlich ALT-ENTER für die Eigenschaften, nicht STRG-ENTER.

    Hab's im Post geändert. Weiß nicht, wieso da CTRL stand, wahrscheinlich wegen dem vorherigen Shortcut. Im Anpassungsmenü habe ich jedenfalls die richtigen Shortcuts eingestellt. Wer will, kann aber natürlich auch STRG+ENTER wählen. Das ist der Vorteil des Anpassungsmenüs.


    Hast Du nun auch noch eine Lösung dafür, wie man den blauen Markierungsbalken auf die ganze Zeile ausdehnt, also auch den Namen?

    Meinst du das, was im nächsten Zitat unten steht?


    wo unverständlicherweise der Bereich ab "Favorit" blau markiert ist, nicht der Name

    Ich kann hier keinen Unterschied zu früheren Versionen feststellen. Poste mal einen Sctreenshot, wie's bei dir aussieht. Adressen solltest du vorher unkenntlich machen.

  • Das war aber auch in früheren Versionen so. In Windows, egal welche Version, ist es grundsätzlich eingestellt, dass eine markierte Zeile blau hervorgehoben wird. Daher müsste eigentlich die gesamte Zeile im Adressbuch blau sein. Jedoch ist es in TB! (wohl unveränderbar) eingestellt, dass eine gerade markierte Spalte grau bzw. silver hervorgehoben wird, vielleicht damit man weiß, in welcher Spalte man sich gerade befindet. Wenn man z.B. die Spalte "E-Mail" oder "Ort" anklickt, wird's dort grau usw. Da die Einstellungen eines Programm Priorität gegenüber Windows-Standardeinstellungen haben, sieht's etwas komisch aus. War aber, wie gesagt, schon immer so.


    Kann übrigens auch sein, dass diese Farbeinstellung ebenfalls von Windows kommt. Da muss man unter "Fensterfarbe" irgendwo in der Systemsteuerung nachschauen und ggfs. anpassen.

  • Nein. Bei mir ist es völlig egal, welche Spalte ich anklicke (für die Sortierung nach dieser Spalte), die blaue Markierung beginnt immer erst an der zweiten Spalte, nicht vorne beim Namen. Auch wenn das früher auch schon so war, mich nervt und irritiert es jedesmal.

  • Wenn ich viele HTML-Mails bekomme, ist das Arbeiten ein Grauen. Der HTML-Viewer hängt jedesmal 2-3 Sekunden und nichts geht mehr, in der Zeit kann ich The Bat! nicht mehr bedienen.

    Ist in der 32bit.


    Habt ihr das auch? Oder ist das irgendein Murks mit Windows 10 Defender oder gar Intel CPU-abhängig?

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Ich habe dieses Problem nicht, allerdings mit der 64-Bit-Version und ausreichend Ram (64 GB). Mit der alten Version gab es zeitweise ja auch schon mal Unterschiede zwischen 32- und 64-Bit-Version. Mir ist dafür etwas anderes aufgefallen, worauf ich im nächsten Posting eingehen möchte.