The Bat! 9.3.4.12 (ALPHA)

  • https://www.ritlabs.com/downlo…ta/tb9.3.4.12-x32-full.7z

    https://www.ritlabs.com/downlo…ta/tb9.3.4.12-x64-full.7z


    https://www.ritlabs.com/downlo…at/beta/tb9.3.4.12-x32.7z

    https://www.ritlabs.com/downlo…at/beta/tb9.3.4.12-x64.7z


    Here is a short list of changes:

    Code
    [*] Better quotation when switching from HTML to plain (Alpha issue)
    [*] Treat files with .MSG and .EML extesions as message/rfc822 ignoring declared MIME type
    [*] Option for automatic switching to HTML format in the message editor is now active
    [-] The "Insert table" dialog was not scalable (Alpha issue)
    [-] (#002118) AV Errors when a message was printed by a filter action

    https://www.mail-archive.com/t…utaint.com/msg114670.html

  • Code
    [*] Option for automatic switching to HTML format in the message editor is now active

    Jetzt funktioniert sie. Man bekommt einen Warnhinweis, wenn man im Nur-Text-Editor eine HTML-Formatierung verwenden möchte.

  • Werden Links beim Einfügen in den Mailtext nicht mehr als solche erkannt?

    Die Linkerkennung geht nur noch im Plain Text, aber nicht im HTML-Modus des Editors.


    Hab ich da was verpasst oder falsch eingestellt? Oder ist das im neuen Editor defekt?

    Den Link-Button der Werkzeuleiste dafür nehmen zu müssen ist doch unnötig. Ich bin zu verwöhnt von Webmailern und Thunderbird.

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Einmal editiert, zuletzt von GwenDragon ()

  • Stimmt, is nix mit Link. Gerade mit der x64 getestet.


    Aber da sind noch mehr Sache kaputt, zumindest im HTML-Teil. Wenn ich da oben nach dem eingefügten Link (oder sonstigem Text) eine Leerzeile einfüge, wird unten zwischen Gruß und meinem Namen eine gelöscht. Dann werden der Gruß und der Name ein Zeichen eingerückt. Wird das gelöscht, so wird der erste Buchstabe mitgelöscht. Alles noch etwas unausgegoren.


    Ich habe bisher nur keine Fehlermeldung gemacht, weil es ja noch eine Alpha ist. Ich denke mir und hoffe, dass das in der Betaliste angesprochen wird, auf die ich leider keinen Zugriff mehr habe.

  • Wie unterscheidet sich eigentlich Alpha von Beta und definitives Programm? Respektive ab welcher Version ist es empfehlenswert von einer definitiven Version auf eine nächste zu wechseln?

    Und:

    Eigentlich würde ich erwarten, dass Makros, die Mails verschieben und dann ausdrucken beim Start von The Bat! automatisch ablaufen. Das ist aber nicht so. Das Programm ist, wenn ich es starte, auf dem Ordner "alle neuen virtuell" (wie gewünscht), dann muss ich auf eine Konto wechseln und dann Enter drücken bis, nach der Error Meldung (bei der aktuellen Version 9.3.4 bekannt) das Makro abläuft. Muss das so sein oder hat das mit dem aktuellen Fehler zu tun?

  • Werden Links beim Einfügen in den Mailtext nicht mehr als solche erkannt?

    Die Nachricht kommt auch mit einem nicht anklickbaren Link an. Das wurde auch schon in TBBETA angesprochen.



    Wie unterscheidet sich eigentlich Alpha von Beta und definitives Programm?

    Das wird ausführlich in diesem Artikel erklärt - https://de.wikipedia.org/wiki/Entwicklungsstadium_(Software)



    Respektive ab welcher Version ist es empfehlenswert von einer definitiven Version auf eine nächste zu wechseln?

    Alle Test-Versionen sind mit Vorsicht zu genießen. Ständige Sicherungen sind unentbehrlich. Am besten wechselt man daher erst, wenn es eine finale Version gibt, die unter https://www.ritlabs.com/de/products/thebat/download.php veröffentlicht wurde.


    Eigentlich würde ich erwarten, dass Makros, die Mails verschieben und dann ausdrucken beim Start von The Bat! automatisch ablaufen.

    Nicht Makros, sondern Filter verschieben Mails. Makros werden in Vorlagen verwendet und greifen erst ein, wenn man z.B. eine neue Nachricht startet oder eine empfangene beantwortet.


    Filteraktionen aus dem Filtermanager hingegen werden ausgeführt, wenn die korrespondierende Filterbedingung bzw. Filterbedingungen erfüllt wurde(n). Das ist normalerweise der Fall, wenn eine Nachricht empfangen oder versandt wurde, jedoch definitiv nicht beim Programmstart.

  • Eigentlich würde ich erwarten, dass Makros, die Mails verschieben und dann ausdrucken beim Start von The Bat! automatisch ablaufen. Das ist aber nicht so. Das Programm ist, wenn ich es starte, auf dem Ordner "alle neuen virtuell" (wie gewünscht), dann muss ich auf eine Konto wechseln und dann Enter drücken bis, nach der Error Meldung (bei der aktuellen Version 9.3.4 bekannt) das Makro abläuft.

    Was ist damit gemeint? Ich versteh den obigen Text nicht.

  • Was hast du gegen Wikipedia - meiner Meinung nach die beste Informationsquelle, die es gibt.

    Das ist sehr sehr gemischt. Inbezug auf einfach physikalische oder chemische Tatsachen, kann man die weitgehend ohne Vorbehalte lesen.


    Aber überall, wo Herrschaft von Menschen über Menschen eine Rolle spielt, setzen sich die reaktionären Vertreter der Herrscher durch, wo Fanwesen im Spiele ist wie z.B. bei der Eisenbahn oder Automobilen, die Fans, auch in technischen Dingen wie in diesem Falle die Leute, die etwas aus dem Englischen übersetzen, ohne wirklich Kenntnis der Ausgangssprache English noch der Zielsprache Deutsch, und von dem betroffenen Fach kaum etwas.


    Siehe bspw im deutschen Interface von TheBat!, wo Textbausteine hinter dem völlig unverständliche "Schnellvorlage" versteckt werden, oder gerade im Wikipedia-Standard, wo Kurzinfos zu "Schnellen Fakten" werden, ohne daß aber deren Geschwindigkeit angegeben wird: 100 km/h? Lichtgeschwindigkeit? Oder was.


    Einfach nur sprachlicher Blödsinn.


    Was Makros angeht: ich hab mehrere Jahrzehnte Erfahrung in der Computerindustrie hinter mir, und ich weiß, was ein Makro ist. Ich hab selber welche programmiert.

  • Das ist alles Ansichtssache. Ich vertraue den Beiträgen der Wikipedia auf alle Fälle mehr, als dem, was ich in den Printmedien zu lesen bekomme und sogar den meisten Beiträgen im Fernsehen. Du siehst es halt anders als viele von uns. Belassen wir es doch einfach dabei.

    Die meisten Menschen sind bereit zu lernen, aber nur die wenigsten, sich belehren zu lassen.
    Winston Churchill

  • Siehe bspw im deutschen Interface von TheBat!, wo Textbausteine hinter dem völlig unverständliche "Schnellvorlage" versteckt werden,

    Diese Diskussion hatten wir bereits und es wurde u.a. auch MS Word genannt, in dem es ebenfalls anders heißt. Wie dem auch sei, innerhalb von TB! sind Makros und Filter unterschiedliche Sachen und Makros verschieben hier keine Nachrichten. Entweder benutzt man das Programm mit den darin enthaltenen Bezeichnungen oder man lässt es. Darüber in einem nicht offiziellen Forum und dazu auch noch überhaupt nicht passenden Thema zu meckern, ist völlig nutzlos und offtopic.

  • Was ist damit gemeint? Ich versteh den obigen Text nicht.

    Also: Ich habe, einen kürzlichen Tip betreffend virtuelle Ordner aufgreifend, einen virtuellen Ordner angelegt mit zig nichtvirtuellen Subordnern, in die ich teils händisch, teils mit Makros, also Filtern, die Mails ablege, die ich behalten will. Und dieses Konstrukt habe ich oberhalb der Kontoordner plaziert, weil mich das übersichtlicher dünkt als die bäume meiner sieben Konti. Wenn ich The Bat! starte, befinde ich mich im obersten Ordner, der mir alle neuen Mails anzeigt. Von früher her war ich mich gewohnt, dass, wenn ich das Programm gestartet habe, alle Filter und Makros - dort hiessen sie Script - abzulaufen beginnen, also drucken, verschieben, löschen, usw. Jetzt, mit The Bat!, muss ich mich mit der Maus aus dem virtuellen Ordner hinab zum Eingangs-Ordner meines Hauptkontos bewegen, wenn ich die Filter und Makros abgearbeitet haben will. Damit das geschieht, muss ich aber, weil ich die aktuelle The Bat!-Version 9.3.4 benütze, nach dem Enter für die Filter und Makros, noch ein zweites Mal Enter drücken, um eine Fehlermeldung, die ein offenbar bekannter Bug ist, zu schliessen.

  • Ich habe immer noch das Problem, dass mir HTML-Newsletter von Samsung mit falschen Zeichen angezeigt werden. Deklariert sind sie als Windows-irgendwas, tatsächlich handelt es sich aber um Unicode (UTF-8).
    Wie kann ich denn in den Settings fest einstellen, dass IMMER die automatische Erkennung benutzt werden soll? Wenn ich die nämlich manuell auswähle, dann wird die Anzeige richtig korrigiert. Aber das bleibt nicht erhalten.

  • Deklariert sind sie als Windows-irgendwas, tatsächlich handelt es sich aber um Unicode (UTF-8).

    Das Problem trat auch in alten Versionen auf, da TB! den Zeichensatz immer aus dem Header der Mail übernimmt. Entscheidend ist also, was unter Content-Type: text/html; charset="<Zeichensatz>" steht. Und das ist eben die automatische Erkennung. Eventuell hilft's aber, wenn du Unicode (UTF-8) manuell wählst und dann die Option Als Voreinstellung festlegen anklickst. Danach müsste die Ansicht mit diesem Zeichensatz dauerhaft gespeichert sein.

  • Das habe ich gemacht. Funktioniert aber bei diesen Newslettern nicht. Sie werden immer mit Windows-Dingenskirchen geöffnet. Wenn ich dann die automatische Erkennung auswähle, dann wechselt die Anzeige auf UTF-8 und es wird richtig dargestellt.