The Bat! 9.3.4.14 (ALPHA)

  • Version 9.3.4.14 (still Alpha, but hopefully the last one in this series) is available


    https://www.ritlabs.com/downlo…ta/tb9.3.4.14-x32-full.7z

    https://www.ritlabs.com/downlo…ta/tb9.3.4.14-x64-full.7z


    https://www.ritlabs.com/downlo…at/beta/tb9.3.4.14-x32.7z

    https://www.ritlabs.com/downlo…at/beta/tb9.3.4.14-x64.7z


    Here is a short list of changes:

    Code
    [+] The "Display HTML-related message parts as attachments" viewer option
    [*] Insert Smiley is replaced by Insert Emoji
    [*] Table-related menu/toolbar commands are now working in HTML editor (Alpha issue)
    [-] Optimize loading of HTML to prevent eventual viewer crashes

    https://www.mail-archive.com/t…utaint.com/msg114685.html

  • Hm, ich sehe leider beim HTML-Editor noch keine Unterschiede.


    Wenn ich eine neue Nachricht erstelle (STRG-N) und oben den Empfänger eingetragen habe, wird unten im Text immer noch nicht der Name eingefügt.

    Wenn ich dann nach dem ersten Text ein RETURN drücke, um eine Leerzeile einzufügen, wird dafür weiter unten zwischen Gruß und meinem Namen eine Leerzeile gelöscht. Außerdem entstehen vor dem "Viele Grüße" und "Ralf" jeweils ein Leerzeichen. Will ich das weglöschen, wird der erste Buchstabe mitgelöscht.

    In dem Text, den der Empfänger erhält, ist dann plötzlich oben, wo eine Leerzeile eingefügt wurde, eine Leerzeile mehr als beim Schreiben zu sehen.


    Ich gehe davon aus, dass diese Dinge noch in der TBBETA-Gruppe angesprochen und diskutiert werden und man jetzt noch keinen BUG-Eintrag machen sollte, weil es sich ja um eine Alpha handelt und da noch weitere Fehler auftreten werden. Oder?

  • Gerade nochmal getestet:


    Wenn ich im Editor (also beim Schreiben) einer HTML-Mail NICHTS ändere, also keine Leerzeile einfüge und keine Leerzeichen lösche, nur den Namen oben von Hand einfüge und meinen Text schreibe, dann sieht die Nachricht zwar falsch aus, sie kommt aber beim Empfänger richtig an.

  • Wenn ich eine neue Nachricht erstelle (STRG-N) und oben den Empfänger eingetragen habe, wird unten im Text immer noch nicht der Name eingefügt.

    Das Problem habe ich dir gegenüber bereits bestätigt. Wenn du dich dafür entschließt, es im BT zu melden, kann ich's auch dort bestätigen. In einem Nur-Text-Editor ist alles OK. Also muss es ein Bug im (Alpha-)HTML-Editor sein. Eventuell könnte man wenigstens bis zur ersten Beta abwarten.


    Wenn ich dann nach dem ersten Text ein RETURN drücke, um eine Leerzeile einzufügen, wird dafür weiter unten zwischen Gruß und meinem Namen eine Leerzeile gelöscht.

    Das hängt wohl mit diesen neuen Blöcken im neuen HTML-Editor zusammen. Ich habe ja schon mal die Option Highlight the active paragraph/block angesprochen. Aktiviert man sie, sieht man die jeweiligen Blöcke in grau. Offensichtlich werden innerhalb eines Blocks keine Leerzeilen eingefügt. Mit Enter kann man lediglich zur nächsten Zeile springen, es sei denn, dass man am Ende einer Textzeile steht. Dann wird wohl ein neuer Block mit einer neuen Leerzeile eingefügt. Ist wohl eine Eigenheit des neuen HTML-Editors.

  • 32bit: Beim Antworten auf ein HTML-Mail und dem Spichern als Entwirf verliert das Mail die Textfarbe bei der Signatur (bei mir ist das in der Text-Vorlage hellgrau)? Bei euch auch?


    //EDITH: Oh, im HTML ist das dann das HTML-Element address mit der CSS-Klasse Adr.


    Das ist ja wohl vollig sinnfrei, denn eine Signatur im Mail ist niemals semantisch eine Adresse!

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Einmal editiert, zuletzt von GwenDragon ()

  • sanyok

    Hat das Thema geschlossen