[Bug] HTML-Formatierung entfernt Umbrüche in Text

  • 1. Erstelle eine mehrzeilige Mail im Format "Plain Text"
    Sowas z.B.:
    ++++++++++

    Da ist ein Test.


    1

    2

    3


    ASDF
    ++++++++++

    2. Markiere alles

    3. Drücke im Editor den Button B (Fett), damit schaltet alles in Format HTML um

    4. Text ist fett, aber ohne Umbrüche:

    ++++++++++ Da ist ein Test. 1 2 3 ASDF ++++++++++



    The Bat! 9.5 CE 32bit Win 11 21H2


    Bei euch auch? Bekannter Bug?


    Sieht so aus als würde da im HTML-Code kein Umbruch <br> hinzugefügt, wenn im normalen Text ein Umbruch war.

    The Bat! Pro 10.x BETA (32bit, keine nau) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    5 Mal editiert, zuletzt von GwenDragon ()

  • Ich kann's auch bestätigen, aber für den Test muss die Option "Von Nur-Text auf HTML wechseln, wenn HTML-Formatierung angewendet wird" aktiviert sein, sondern erhält man einen Hinweis, dass man im Nur-Text-Modus nicht formatieren kann.

  • aber für den Test muss die Option "Von Nur-Text auf HTML wechseln, wenn HTML-Formatierung angewendet wird" aktiviert sein

    Oh, die ist nicht automatisch aktiviert? Hab ich dann wohl irgendwann bei den Betas gemacht.


    Danke an euch für die Bestätigung der Bugmeldung im Tracker.

    The Bat! Pro 10.x BETA (32bit, keine nau) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Oh, die ist nicht automatisch aktiviert?

    Es kann sein, dass diese Option standardmäßig aktiviert ist, aber der Test ist ja nicht nur für diejenigen, die TB! gerade frisch installiert haben. Bei mir war sie jedenfalls deaktiviert, weil ich sie vielleicht irgendwann mal selbst deaktiviert habe, und ich konnte dadurch Schritt #3 nicht nachmachen, weil ich einen Fehler bekam. Wer also das gleiche Problem hat, sollte diese Option für den Test aktivieren.