BYE out-of-sync data before server greeting

  • Aus dem logfile:



    hat jemand ne Ahnung was das meint: "BYE out-of-sync data before server greeting"

  • ich weiß nicht was der Server da hat. Ist das IMAP oder Exchange?


    Irgendwelche Spam-Filtersoftware oder Sicherheitsprogramem auf deinem Windows?

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Ich kann bei meinem eigenen Mailserver das kombinierte Senden und Empfangen trotzdem verwenden.


    Dann haben die bei 1&1 was bei ihrem Mailserver geändert, dass es nicht mehr geht.

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Hi,


    Die Einstellung hat keine Auswirkung auf den erfolgreichen Abruf der Email.


    Es kann sein dass man auf einen Mail-Server bei 1&1/GMX landet welcher z.B. ein Problem mit der AUTH hat.

    Ein Update bei mir von 9.4.5 auf die 9.5 hat keine Änderung bewirkt.


    Habe keine IP um zu sehen welcher Server hinter dem HLB angesprochen wurde.Ist aber ein temporäres Problem.


    Nach xx mal eines Reconnects konnte ich mit aktiviertem Kombiversand wieder Email abrufen.


    CU

  • "out-of-sync data before server greeting" ist mir als Serveradministratorin unbekannt. Aber manche Mailanbieter haben auch eigene Ansichten wie was an Mailclients zu melden ist.

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Ist bestimmt während des rollouts einer neuen Konfig aufgefallen.


    RFC3501 beschreibt wann greeting und data zu senden sind.

    Und da es ja anscheinend bei allen großen Anbietern zum guten Ton gehört RFCs selbst großzügig zu interpretieren kann es schon mal zu Problemen kommen.


    Code
     State and Flow Diagram
       Once the connection between client and server is established, an   IMAP4rev1 connection is in one of four states.  The initial   state is identified in the server greeting.  Most commands are   only valid in certain states.  It is a protocol error for the   client to attempt a command while the connection is in an   inappropriate state, and the server will respond with a BAD or   NO (depending upon server implementation) command completion   result.
  • Ja und leider hat das setzen der Checkbox in der tat nichts damit zu tun. Weil es geht weiterhin nicht. Obwohl vorhin alle Mails von heute abgerufen wurden. Seitdem heisst es wieder:


  • Wenn du das erweitere IMAP/SMTP-Log unter Transport > verbindungsprotokoll einschaltest und mal nachsiehst, ob da noch mehr drin steht.

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • In The Bat! Konto → Eigenschaften → Transport → Verbindungsprotokoll
    Dort dann das für IMAP und SMTP aktivieren, wahlweise den Speicherort wählen, im Allgemeinen ist das Kontenlog dann im Ordner des Kontos.
    Abrufe werde nun genauer protokolliert.

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Die Option gibts nicht, habe ja auch, wie ich gerade sehe, die Version 8.3


    Upgraden kann ich nicht, weil da keine Sau durch sieht. Woher bitte um alles in der Welt soll ich wissen, wann ich meine Lizenz gekauft habe?


    Egal


    Individual-Lizenz

    Gültig für Version 8

  • Eine Bekannte von mir hat seit heute denselben Fehler BYE out-of-sync data before server greeting mit GMX und IMAP. POP3 klappt und IMAP geht auch ohne Probleme mit anderen MUAs.


    Wie es scheint, könnten eventuell alle Firmen vom United Internet betroffen sein.

  • habe ja auch, wie ich gerade sehe, die Version 8.3

    Hast du es bereits mit v8.8.9 getestet?


    Ich kann mir nämlich vorstellen, dass die alle IMAP auf TLS 1.2 umgestellt haben. TB! unterstützt es aber erst seit v8.5. Daher es am besten mit der letzten v8 probieren.


    Mit TB! v9 müsste es jedenfalls keine Probleme geben.

  • Moinsen!


    Ich habe seit heute (25.1.2022) Probleme, E-Mails über meine diversen Mailboxen bei 1&1/ionos und GMX zu empfangen (IMAP) oder zu versenden. Beim Zugriff auf eine der 1&1-Boxen per TB sieht das Log typischer Weise wie folgt aus:


    25.01.2022, 16:40:56: IMAP - Connecting to IMAP server imap.ionos.de on port 993

    25.01.2022, 16:40:56: IMAP - Initiating TLS handshake

    >25.01.2022, 16:40:56: IMAP - Certificate S/N: 1B579B904296C437C368DD1A11AFF1AA, algorithm: RSA (2048 bits), issued from 8/4/2021 8:37:14 AM to 8/8/2022 11:59:59 PM, for 9 host(s): smtp.ionos.de, pop.ionos.de, imap.ionos.de, smtp.1und1.de, pop.1und1.de, imap.1und1.de, smtp.1und1.com, pop.1und1.com, imap.1und1.com.

    >25.01.2022, 16:40:56: IMAP - Owner: DE, IONOS SE, Rheinland-Pfalz, Montabaur, smtp.ionos.de.

    >25.01.2022, 16:40:56: IMAP - Issuer: DE, T-Systems International GmbH, T-Systems Trust Center, Nordrhein Westfalen, 57250, Netphen, Untere Industriestr. 20, TeleSec ServerPass Class 2 CA.

    25.01.2022, 16:40:56: IMAP - TLS handshake complete

    25.01.2022, 16:40:56: IMAP - Connected to IMAP server (imap.ionos.de)

    !25.01.2022, 16:40:56: IMAP - Server reports error. The response is: BYE out-of-sync data before server greeting

    !25.01.2022, 16:40:56: IMAP - BYE out-of-sync data before server greeting

    25.01.2022, 16:41:01: IMAP - Disconnected


    bzw. bei GMX


    25.01.2022, 16:46:33: IMAP - Connecting to IMAP server imap.gmx.de on port 993

    25.01.2022, 16:46:33: IMAP - Initiating TLS handshake

    >25.01.2022, 16:46:33: IMAP - Certificate S/N: 070E7CD59BB7AFD73E8A206219C4F011, algorithm: RSA (2048 bits), issued from 4/28/2021 4:51:17 AM to 5/3/2022 11:59:59 PM, for 8 host(s): mail.gmx.net, mail.gmx.de, smtp.gmx.net, smtp.gmx.de, imap.gmx.net, imap.gmx.de, pop.gmx.net, pop.gmx.de.

    >25.01.2022, 16:46:33: IMAP - Owner: Private Organization, HRB 7666, Montabaur, Rheinland-Pfalz, DE, DE, Rheinland-Pfalz, Montabaur, 1&1 Mail & Media GmbH, mail.gmx.net.

    >25.01.2022, 16:46:33: IMAP - Issuer: DE, T-Systems International GmbH, T-Systems Trust Center, Nordrhein Westfalen, 57250, Netphen, Untere Industriestr. 20, TeleSec ServerPass Extended Validation Class 3 CA.

    25.01.2022, 16:46:33: IMAP - TLS handshake complete

    25.01.2022, 16:46:33: IMAP - Connected to IMAP server (imap.gmx.de)

    !25.01.2022, 16:46:33: IMAP - Server reports error. The response is: BYE out-of-sync data before server greeting

    !25.01.2022, 16:46:33: IMAP - BYE out-of-sync data before server greeting

    25.01.2022, 16:46:39: IMAP - Disconnected


    Das Ganze tritt auf zwei PCs auf, beide mit Windows 10 Pro 21H2 und TB 9.3 bzw. 9.5, jeweils 64bit. An den Account Settings in TB habe ich ewig nichts mehr geändert - und wie gesagt: Bis heute früh gab es auch keine Probleme.


    Zwischendrin hat es heute auch kurzfristig mal für ein paar Minuten funktioniert. Der ionos-Support weiß angeblich von nichts und rät mir, meine Mailboxen neu anzulegen, "damit sich das System wieder synchronisiert".


    Interessanter Weise funktioniert der Zugriff auf die gleichen Mailboxen (ebenfalls IMAP) über das "On-Board"-Mailprogramm von meinem iPhone problemlos. Mail Accounts anderer Anbieter (z.B. Posteo) funktionieren in den beiden betroffenen TB-Installation ebenfalls nach wie vor einwandfrei. Außerdem kann ich berichten, dass das Backup meiner 1&1 und GMX Mail Accounts per MailStore vom gleichen Rechner aus ebenfalls funktioniert - scheint also irgendwas zwischen TB und 1&1/ionos, bzw. GMX, bzw. eventuell sogar United Internet zu "klemmen" ...


    Was tun? :/