TLS 1.0, 1.1, 1.2 usw. welche The Bat!-Version?

  • Ich hab noch Version 7.4.16 installiert.

    Wie gesagt, für TLS 1.2 wird mindestens v8.4.0.4 benötigt.


    Mit GMail hat man mittlerweile auch Verbindungsprobleme mit einer alten TB!-Version (s. "Google und The Bat"), denn dafür braucht man zwar kein TLS 1.2, aber seit kurzem unbedingt OAuth. TB! v7 z.B. unterstützt zwar OAuth, jedoch findet die Einrichtung über eine veraltete und damit unsichere Browser-Engine statt und wird daher von Google verweigert. OAuth ist also zwar vorhanden, kann aber nicht eingerichtet werden.


    TB! v7 ist mittlerweile wie Windows 7, also sehr veraltet.

  • TB! v7 z.B. unterstützt zwar OAuth, jedoch findet die Einrichtung über eine veraltete und damit unsichere Browser-Engine statt und wird daher von Google verweigert.

    Ich habe neulich bemerkt, dass es auch auf v9.5.1 zutrifft. Obwohl darin bereits CEF integriert ist, wird der interne Browser von Google als unsicher angesehen und die OAuth-Einrichtung darüber verweigert. Man muss also trotzdem einen externen Browser öffnen.


    Ist es bei v10 genauso? Hat's jemand schon getestet?

  • Interessante Erfahrung zu OAUTH meinerseits:
    Ich hatte ja kürzlich geschrieben, dass ich auf Version 10.x upgegradet hatte und dann ein paar Tage nach dem irgendwann mal genannten Abschaltttermin von Google aufgefordert worden war, OAUTH für eine sichere Verbindung (für mein GMail-Konto) einzurichten. Hat auch problemlos geklappt.
    Dann bin ich wegen der fehlerhaften Leertastengeschichte beim Scrollen irgendwann wieder auf die 9.5.1 zurückgegangen (einfach Backup zurückgespielt). Nun habe ich nachgesehen und bemerkt, dass ich damals OAUTH noch nicht eingerichtet hatte und dies unter "Authentifikation" auch nicht möglich ist. Der Punkt ist ausgegraut. Trotzdem funktioniert der Transport fehlerlos, zumindest der Nachrichtenempfang.

  • ...OAUTH für eine sichere Verbindung (für mein GMail-Konto) einzurichten. Hat auch problemlos geklappt.

    Weißt du noch, ob du alles in TB! gemacht hast oder einen externen Browser aufrufen musstest?


    irgendwann wieder auf die 9.5.1 zurückgegangen

    Die OAuth-Token werden übrigens in der Datei ACCOUNT.ATB gespeichert. Und darin wohl von allen Konten, da sie sich im MAIL- und nicht in dem jeweiligen Konto-Verzeichnis befindet. Beim Downgrade ist sie bei dir wohl dort geblieben. Wenn du sie löschst, wird wahrscheinlich auch die OAuth-Option wieder verfügbar sein. OAuth müsste dann aber sicherlich erneut eingerichtet werden.


    Trotzdem funktioniert der Transport fehlerlos, zumindest der Nachrichtenempfang.

    Welche Option ist denn in v9 unter Authentifikation aktiviert? Standard?


    In dem Thread "Google und The Bat" hast du ja noch geschrieben, dass es bei dir mit Standard nicht mehr geht.


    Und falls OAuth aktiviert ist, dann klingt es so, als ob ein in einer Programmversion eingerichtetes Token auch in einer anderen funktionieren würde, was aber u.U. ein Sicherheitsrisiko darstellen könnte. Das ist dann aber ein Problem von Google, wenn sie so etwas erlauben.

  • Ich hatte mich bei der Einrichtung an Deine ausführliche Anleitung gehalten. Ich konnte nur nicht meinen Standardbrowser nehmen, da dort wohl zu viel blockiert wird, und hatte daher einen anderen genommen.
    In der Authentifikation ist jetzt bei mir "Standard" eingestellt. OAUTH ist ausgegraut und kann von mir nicht angewählt werden.

  • Am 30.5. bin ich von V7 auf V10.0.9 umgestiegen

    • mir steht bald dasselbe upgrade (aktuell von V7 auf 10.0.10) wegen TLS 1.0, TLS 1.1 bevor. Es würde mich freuen, wenn du (MaG) mir/uns deine Erfahrungen mitteilen würdest, die du während des Upgrades gemacht hast. Hast du vielleicht Empfehlungen, auf die ich unbedingt achten sollte, um problemlos umzusteigen ?

      Wie groß war denn dein "Schock" über die Änderungen zwischen V7 und V10 ? :) Ich denke du warst mit der V7 genauso zufrieden wie ich und der Upgrade erfolgt nur notgedrungen.

      Du arbeitest ja jetzt schon ein paar Wochen mit der V10. Bist du zufrieden mit dieser Version und wie umfangreich waren die nötigen Anpassungen ?

      Danke im voraus.

      arnie