neuer Versuch TB! (8.x→10.x) und PGP (GPG4Win)

  • Hallo Miteinander,


    ich benutze noch die TB! Pro 8.8.9. und dem internen PGP. Ich hatte im vergangenen Jahr mal nachgefragt wie es mit dem Umstig auf die Version 9.x und PGP sei. Gwen hat mir damals abgeraten.


    Nun ist die Version 10 erschienen und es gibt bei Ritlabs einen neuen Beitrag zum Thema https://www.ritlabs.com/de/news/7749/


    Ich habe heute mal versucht die 8.8.9 mit Gpg4Win zum laufen zu bekommen, was mir aber nicht gelungen ist.


    Wie ist denn das Meinungsbild hier?

    Mit den besten Grüssen aussem Pott


    - HepCat -



    Meine Evolution der E-Mailreader seit 1992: Crosspoint - ab 1998 AK-Mail - seit 2009: The Bat Professionel - ?

    Version TB! 8.8.9 64bit, seit dem 15.05.22 TB! 10.0.x 64bit, aktuell nach einem nervenaufreibenden Updatemarathon 10.0.9 64 bit.

  • ch habe heute mal versucht die 8.8.9 mit Gpg4Win zum laufen zu bekommen, was mir aber nicht gelungen ist.

    Und was klappt nicht?

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Und was klappt nicht?

    Gpg4Win 4.0.2 kennt wohl keine sec- bzw. pubring.pgp mehr die aber anscheinend von TB! noch gewünscht werden?

    Mit den besten Grüssen aussem Pott


    - HepCat -



    Meine Evolution der E-Mailreader seit 1992: Crosspoint - ab 1998 AK-Mail - seit 2009: The Bat Professionel - ?

    Version TB! 8.8.9 64bit, seit dem 15.05.22 TB! 10.0.x 64bit, aktuell nach einem nervenaufreibenden Updatemarathon 10.0.9 64 bit.

  • Was The Bat! will ist, is da uninteressant, das ignorierst du was unter Optionen → OpenPGP → Einstellungen → Dateien zu den Schlüsselringen steht.

    Du musst nur Schlüsselverwaltung für Externe OpenPGP-Schlüsselmanager einstellen zu Kleppatra C:\Program Files (x86)\Gpg4win\bin\kleopatra.exe

    Und unter Optionen → OpenPGP → version auswählen das GnuPG setzen.


    Ansonsten verwaltet GnuPG alles selbst, es findet alleine was es braucht, es muss nur der Pfad gesetzt korrekt sein, also das muss auch in der Umgebungsvariable PATH drin sein: C:\Program Files (x86)\Gpg4win\..\GnuPG\bin

    Soweit ich weiß macht aber der Installer das.

    Neu starten des Windows nicht vergessen!


    Schau mal das Verzeichnis %AppData%\gnupg an, dort sind die Dateien von GnuPG.

    GnuPG - What’s new in 2.1

    GnuPG - What’s new in 2.1


    Was willst du denn mit pubring und secring? Sind das die alten aus dem internen The Bat! PGP?

    Einfach nach C:\Users\DEINEWINDWOSNAME\AppData\Roaming\gnupg> kopieren, beim Starten konvertiert gpg die dann.

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    7 Mal editiert, zuletzt von GwenDragon ()

  • GwenDragon Danke für die ausführliche Beschreibung. Leider zeigt sich jetzt ein weiteres Merkwürdiges verhalten.


    1. Installiert sind TB! 8.8.9 und das aktuelle Gpg4win 4.0.2

    2. Gpg4win lässt sich NUR problemlos starten, wenn es vorher als Administrator installiert wurde. Anderfalls verweigert es den Start mit einer Fehlermeldung

    3. Die alten Schlüsselringe *ring.pgp wurde fehlerfrei eingelesen und auch als gültig dargestellt.

    4. Ich habe mit versucht eine signierte E-Mail an einen anderen Account von mir zu versenden.

    5. Nach dem Klick auf "jetzt versenden" schließ TB! und startet wenige Augenblicke später wieder. Die E-Mail befindet sich weiter im Ausgangskorb.

    6. TB! als Administrator ausgeführt, bis auf den selbständigen Neustart das gleiche Verhalten wie unter 5.

    7. Bin frustriert .... :-/


    Ich hoffe ich bekomme den alten Zustand wieder hin.

    Mit den besten Grüssen aussem Pott


    - HepCat -



    Meine Evolution der E-Mailreader seit 1992: Crosspoint - ab 1998 AK-Mail - seit 2009: The Bat Professionel - ?

    Version TB! 8.8.9 64bit, seit dem 15.05.22 TB! 10.0.x 64bit, aktuell nach einem nervenaufreibenden Updatemarathon 10.0.9 64 bit.

  • Ich installiere GPG4Win erst nach Wechsel ins im Administrator, sonst starten manche dienst nicht richtig. Nicht als normaler Windows Nutzer mit Als Administrator starten…!!!! Und Window neu starten! Manche älter Windows mucken rum.


    Gratuliere dass die Schlüsselringe korrekt importiert wurden ;)


    Funktioniert GnuPG denn in der Eingabeaufforderung?

    geht das?

    echo 42|gpg -ea


    - - - -


    Mit 8.8.9 muss ich mal testen.

    //edit: Ich kann mit 8.8.9 32bit auf Windows 11 Signieren und entschlüsseln.

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Einmal editiert, zuletzt von GwenDragon ()

  • Ich installiere GPG4Win erst nach Wechsel ins im Administrator, sonst starten manche dienst nicht richtig. Nicht als normaler Windows Nutzer mit Als Administrator starten…!!!! Und Window neu starten! Manche älter Windows mucken rum.

    Ich melde mich bei Installtionen immer mit dem Administratorkonto an. Windows habe ich nach der Installation neu gestartet.


    Funktioniert GnuPG denn in der Eingabeaufforderung?

    geht das?

    Jaein . GPG mäkelt über die fehlende User-ID :-/


    Eigentlich war meine Ursprungsfrage ob die neue TB! 10.x in Verbindung mit PGP brauchbar ist? Dann brauchen wir beide nicht mehr mit der 8.8.9 experimentieren. Signieren ist für mich wichtiger als verschlüsseln ...

    Mit den besten Grüssen aussem Pott


    - HepCat -



    Meine Evolution der E-Mailreader seit 1992: Crosspoint - ab 1998 AK-Mail - seit 2009: The Bat Professionel - ?

    Version TB! 8.8.9 64bit, seit dem 15.05.22 TB! 10.0.x 64bit, aktuell nach einem nervenaufreibenden Updatemarathon 10.0.9 64 bit.

  • Ist das bei dir The Bat! 8.8.9 32bit oder 64bit?

    Welches Windows genau?

    Verwendest du irgendwelche Spamfilterprogramme oder Antivirus/Internet-Sicherheitsprogramme?

    Kann es sein, das das Passwortfenster zur Eingabe im Hintergrund verdeckt ist?


    Deinstalliere doch GPG4Win.

    Starte Windows neu

    Login als Administrator

    Installiere GPG4Win

    Starte Windows neu


    Eigentlich war meine Ursprungsfrage ob die neue TB! 10.x in Verbindung mit PGP brauchbar ist?

    Ja, klappt bei mir.


    Zitat

    Jaein . GPG mäkelt über die fehlende User-ID :-/

    Na, dann starte das wenigsten korrekt.

    Ja, logisch. Bei mir ist immer eine User-ID als standard gesetzt.

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Einmal editiert, zuletzt von GwenDragon () aus folgendem Grund: Ein Beitrag von GwenDragon mit diesem Beitrag zusammengefügt.

  • Ist das bei dir The Bat! 8.8.9 32bit oder 64bit?

    Welches Windows genau?

    64 bit

    Windows 10 Pro, Build 19044.1706


    Verwendest du irgendwelche Spamfilterprogramme oder Antivirus/Internet-Sicherheitsprogramme?

    Nein. Nur den M$ - Defender


    Deinstalliere doch GPG4Win.

    Starte Windows neu

    Login als Administrator

    Installiere GPG4Win

    Starte Windows neu

    Genau so bin ich vorgegangen. Bin derzeit auch mit dem Administratorenkonto angemeldet.

    Mit den besten Grüssen aussem Pott


    - HepCat -



    Meine Evolution der E-Mailreader seit 1992: Crosspoint - ab 1998 AK-Mail - seit 2009: The Bat Professionel - ?

    Version TB! 8.8.9 64bit, seit dem 15.05.22 TB! 10.0.x 64bit, aktuell nach einem nervenaufreibenden Updatemarathon 10.0.9 64 bit.

  • 64 bit

    Vielleicht hat die 8.8.9 64 bit ein Problem mit GnuPG.

    //Edit: Ja, die 64bit stürzt ab. Hat also was mit The Bat 8.8.9 64bit zu tun!




    Bin derzeit auch mit dem Administratorenkonto angemeldet.

    Muss ich mal prüfen ob es damit zusammen hängt.
    /Edit: Nee, egal welches Windows-Konto.


    Die 10.0.3 64 läuft mit GPG4Win 4.0.2 ohne Absturz, kann Signieren/Ver-/Entschlüsseln.

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    4 Mal editiert, zuletzt von GwenDragon () aus folgendem Grund: Ein Beitrag von GwenDragon mit diesem Beitrag zusammengefügt.

  • Die 10.0.3 64 läuft mit GPG4Win 4.0.2 ohne Absturz, kann Signieren/Ver-/Entschlüsseln.

    GwenDragon vielen Dank für Deine Mühe. Ich werdfe dann nachher mal die aktuelle 10.x installieren.


    Mal eine naive Frage, da Du ja auch noch die 32 bit version nutzt, vermutlich wegen XMP. Wie verhält sich die 32bit Version anders als die 64 bit? Auf einem 64 bit Windoof?

    Mit den besten Grüssen aussem Pott


    - HepCat -



    Meine Evolution der E-Mailreader seit 1992: Crosspoint - ab 1998 AK-Mail - seit 2009: The Bat Professionel - ?

    Version TB! 8.8.9 64bit, seit dem 15.05.22 TB! 10.0.x 64bit, aktuell nach einem nervenaufreibenden Updatemarathon 10.0.9 64 bit.

  • GwenDragon vielen Dank für Deine Mühe.

    Gern geschehen.

    Ich werdfe dann nachher mal die aktuelle 10.x installieren.

    Datensicherung des Mailverzeichnisses nicht vergessen!

    Und du hast hoffentlich vor einiger Zeit auf eine Lizenz für die 10er hoch gestuft?

    Mal eine naive Frage, da Du ja auch noch die 32 bit version nutzt, vermutlich wegen XMP. Wie verhält sich die 32bit Version anders als die 64 bit? Auf einem 64 bit Windoof?

    Wegen XMP (Makros) und Regula (lokaler Spamfilter).
    Wenn die nicht brauchts, kannst auch die The Bat! 10 (64bit) nehmen,

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Und du hast hoffentlich vor einiger Zeit auf eine Lizenz für die 10er hoch gestuft?

    Leider nein. Hatte am 29.12.21 auf eine 9.x upgegradtet, die aber aus bekannten Gründen nicht installiert. Habe damals 40.11 € incl. USt bezahlt. Ist anscheinend jetzt wieder günstiger geworden. Von 9 nach 10 kostet aktuell 17,95 + USt.

    Mit den besten Grüssen aussem Pott


    - HepCat -



    Meine Evolution der E-Mailreader seit 1992: Crosspoint - ab 1998 AK-Mail - seit 2009: The Bat Professionel - ?

    Version TB! 8.8.9 64bit, seit dem 15.05.22 TB! 10.0.x 64bit, aktuell nach einem nervenaufreibenden Updatemarathon 10.0.9 64 bit.

  • Leider nein. Hatte am 29.12.21 auf eine 9.x upgegradtet

    Die ist auch für die 10er gültig.

    Schau:

    Lizenzen für The Bat! 9, die zwischen dem 1. Juni 2021 und dem 28. April 2022 gekauft wurden, sind für alle Versionen von The Bat! v9 und The Bat! v10 gültig. Ab Version The Bat! 11.0 werden diese Lizenzen nicht gültig.

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Es ist vollbracht.

    Nachdem ich gestern gesehen habe, dass es jetzt zwei Versionen gibt, mit NAU oder mit ohne NAU, habe ich mich erst einmal wieder durch das Forum und einen aktuellen, langen, Fred zur 10.0.1/3 The Bat! 10.0.1 gelesen und beschlossen mit NAU zu installieren, zumal, so hoffe ich wenigstens, TB! nicht auf die Idee kommt hier irgendetwas Eigenmächtiges zu veranstalten.

    Soweit scheint es mit PGP und Gpg4Win zu funktionieren.

    Danke noch einmal.

    Mit den besten Grüssen aussem Pott


    - HepCat -



    Meine Evolution der E-Mailreader seit 1992: Crosspoint - ab 1998 AK-Mail - seit 2009: The Bat Professionel - ?

    Version TB! 8.8.9 64bit, seit dem 15.05.22 TB! 10.0.x 64bit, aktuell nach einem nervenaufreibenden Updatemarathon 10.0.9 64 bit.

  • GwenDragon

    Hat den Titel des Themas von „neuer Versuch TB! und PGP“ zu „neuer Versuch TB! (8.x→10.x) und PGP (GPG4Win)“ geändert.