GMX IMAP-Ordner-Synchronisation

  • Hallo zusammen,


    die Fledermaus oder auch GMX macht mich seit einiger Zeit wahnsinnig und ich komme leider nicht dahinter, neuste Version von Voyager, neu installiert, von Grund auf neu eingerichtet, zig mal Ordner aktualisiert usw.

    Ich habe das Problem auch nur mit meinem GMX-Konto.


    Alle IMAP-Ordner werden korrekt syncronisiert, außer die Inbox/Posteingang. Dort habe ich das seltsame Phänomen, wenn ich eine E-Mail aus dem Posteingang in einen anderen Ordner (mit oder ohne Filter) auf dem Client (Voyager) verschiebe, dann bleibt eine Kopie dieser E-Mail im Posteingang auf dem Server (GMX) zurück - ist aber für Voyager dann nicht mehr sichtbar und auch nicht über andere Clients z.B. K-9 Mail (ebenfalls IMAP). Wenn ich das Ganze auf dem GMX-Server mache, passt es natürlich und alles wird korrekt synchronisiert. Die Einstellungen von GMX habe ich schon durch, aber nichts gefunden - bei The Bat oder Voyger bin ich bis jetzt nicht fündig geworden...


    Kurzes Beisspiel: eBay-eMail kommt im Posteingang an und wird dann via Voyager in den eBay-Ordner verschoben. Die eBay eMail ist jetzt nicht mehr im Posteingang sondern im eBay-Ordner - soweit alles gut.


    Jetzt logge ich mich beim GMX Web-Interface ein und siehe da ich habe eine eBay-eMail im Posteingang und exakt die selbe im eBay-Ordner. Die eBay-eMail vom Posteingang ist aber nicht mehr Sichtbar für Voyager. ;(


    Hat jemand vielleicht eine Idee an was das liegen kann?

  • Die hatte ich auch schon in Verdacht, habe ich inzwischen aber deaktiviert und ich kann es sogar manuell nachstellen, sprich per drag and drop. Alles eMails die ich verschiebe in the Bat kopieren sich auf dem Server.


    Ich hatte noch AntispamSniper in Verdacht weil ich der auch einiges an "Aufmerksamkeit" gebraucht hat bei der Installation aber der ist inzwischen auch schon deaktiviert.

  • Alle IMAP-Ordner werden korrekt syncronisiert

    Sind die lokalen Ordner, in die du verschiebst, definitiv auf dem Server vorhanden? Wenn nicht, dann kann dort natürlich auch nicht verschoben werden, so dass die betreffenden Nachrichten im Posteingang bleiben.


    Ansonsten kann ich es nicht bestätigen. Wenn ich eine Nachricht in The Bat! aus Eingang per Drag'n'Drop in einen anderen Ordner verschiebe, wird sie auch auf dem Server verschoben und bleibet nicht mehr in Posteingang.

  • Die Ordner sind vorhanden und es hat ja auch schonmal funktioniert aber ich kann mich nicht erinnern irgendetwas umgestellt zu haben, was dieses Verhalten erklären würde. Eigentlich wollte ich ein Video erstellen da das Problem wirklich sehr seltsam ist!

    Wegen der Dateigröße und der Datensicherheit habe ich mich für Screenshots entschieden in denen ich das Webinterface von GMX und The Bat Voyager Side by Side habe.


    Hier beide mal geöffnet mit Focus auf die 3 Spam eMails. Alle anderen eMails wurden über Server-seitige Filter einsortiert weil es sorum ja funktioniert.


    Jetzt verschiebe ich die 3 Spam eMails via Voyager in den Junk mail Ordner (siehe Stausleiste).

    Im letzten Screeshot kann man erkennen das in der Inbox von TB die eMails nicht mehr vorhanden sind dafür aber im Junk mail Ordner - so wie man es erwartet. Das Webinterface von GMX zeigt das die besagten eMails im Junk mail Ordner sind aber auch noch im Posteingang. Im Posteingang wiederum sollten Sie aber nicht mehr sein und das ist leider keine aktualisierungs Problem oder ähnliches weil ich auch nach mehrfachen aktualisieren, Neustarts, clear cache und auch IMAP Folder connects und disconnects sich nichts geändert hat.


    Gibt es vielleicht irgendwelche speziellen IMAP Einstellungen oder was man im Umgang mit GMX beachten muß?
    Die IMAP-Specific Download preferences hatte ich auch schon auf "Get entire Message" gestellt - ohne Erfolg.

    Ich werde vielleicht mal einen Test mit The Bat machen wenn es dort nicht nachvollziehbar ist liegt es vielleicht an Voyager!?

  • Das Webinterface von GMX zeigt das die besagten eMails im Junk mail Ordner sind aber auch noch im Posteingang

    Und du kannst mit diesen im Posteingang gebliebenen Nachrichten ganz normal arbeiten - sie z.B. öffnen, darauf antworten, sie woanders kopieren oder verschieben? Es sind also definitiv keine Schattenkopien o.ä., sondern ganz normale und physisch präsente Nachtrichten?


    Kannst du es testweise mit einem anderen Programm wie z.B. Thunderbird testen? Wird dort verschoben oder auch nur kopiert?


    Gibt es vielleicht irgendwelche speziellen IMAP Einstellungen oder was man im Umgang mit GMX beachten muß?

    Ich habe mir nach meinem Test (fast) alle Einstellungen im GMX-Webmailer angeschaut und konnte nichts zu diesem Verhalten finden.


    liegt es vielleicht an Voyager!?

    Ich habe übersehen, dass es um Voyager geht. Glaube zwar nicht, dass es einen Unterschied ausmacht, aber vielleicht hat der Voyager doch eine Macke. Melde das mal mit deinen Screenshots dem Ritlabs Support (mehr unter "Wie kann man Fehler oder Wünsche an Ritlabs weitergeben?"). Vielleicht ist der Fehler bereits bekannt.

  • Und du kannst mit diesen im Posteingang gebliebenen Nachrichten ganz normal arbeiten - sie z.B. öffnen, darauf antworten, sie woanders kopieren oder verschieben? Es sind also definitiv keine Schattenkopien o.ä., sondern ganz normale und physisch präsente Nachtrichten?

    Es scheint eine ganz normale Kopie zu sein, ich kann zumindest alles damit machen was man auch mit einer eMail so machen kann, also nichts Aufälliges.


    Kannst du es testweise mit einem anderen Programm wie z.B. Thunderbird testen? Wird dort verschoben oder auch nur kopiert?

    Ich hab auf dem Handy K-9 Mail und dort funktioniert alles so wie es soll, grade eben nochmal getestet. Auch die anderen Accounts wie Google und directBOX funktionieren mit K-9 Mail und mit The Bat Voyager. Die Kombination GMX und Voyager macht aber irgendwie Probleme.


    Ich habe mir nach meinem Test (fast) alle Einstellungen im GMX-Webmailer angeschaut und konnte nichts zu diesem Verhalten finden.

    OK. Was mir hierzu noch aufgefallen ist das TB beim automatischen einrichten der accounts bei IMAP fast immer die Ports 465 und 993 mit TLS verwendet und nicht 587 und 993 wie von GMX empfohlen - aber die empfohlenen Ports funktionieren eh nicht bei mir.


    Ich habe übersehen, dass es um Voyager geht. Glaube zwar nicht, dass es einen Unterschied ausmacht, aber vielleicht hat der Voyager doch eine Macke. Melde das mal mit deinen Screenshots dem Ritlabs Support (mehr unter "Wie kann man Fehler oder Wünsche an Ritlabs weitergeben?"). Vielleicht ist der Fehler bereits bekannt.

    OK - Danke! Das werde ich mal machen und dann berichten.

    Vielen Dank auf jedenfall schon mal für deine Mühen :thumbup:

  • Hallo,


    hier die Antwort vom Ritlabs support: Ich vermute das es ein bekanntes "Problem" ist da die Antwort sehr schnell kam und es auch gleich auf anhieb funktioniert hat - wie auch immer.


    Kurz zusammengefasst:

    Compact folder after each message deletion" unter "Account\Properties\Mail management\IMAP Fine-Tune und alles ist wunderbar!


    Begründung:

    In IMAP4 accounts the email program sends commands to the mail server. These can be processed by the server with certain delay, that's why enforcing the compacting of folders made the difference - the commands were executed by the server right away.


    Klingt für mich so ein bisschen wie einen "refresh" zu erzwingen, wobei in meinem Fall die ungewollten Kopien der eMails auch nicht nach einiger Zeit verschwunden wären. Kann ja vielleicht auch für andere "refresh" oder "sync" Problemchen ganz hilfreich sein - wer weiss ;)


    Time: 08/12/2022 09:02:25

    From:

    RITLABS Support


    Hello,


    Thank you for contacting us.
    Please try to enable the option "Compact folder after each message deletion" under the menu "Account\Properties\Mail management\IMAP Fine-Tune" in Voyager, save changes and move messages to the junk folder. Does the "Inbox" folder update straight away?


    Do you experience the same issue when you move messages between other folders of that account?


    [ Quote ]

    Time: 08/12/2022 14:05:39

    From:
    [26566] (HiKO) Heiko Lange


    Hello,


    the issue was with every folder inside the GMX account but now the compact folder trick is working!
    I don't quite understand why it works now but would it be advisable to enable the option for my other accounts or why is it not on by default?
    Thank you very much!!!


    KR,
    Heiko


    [ Quote ]

    Time: 08/12/2022 14:29:10

    From:
    RITLABS Support


    In IMAP4 accounts the email program sends commands to the mail server. These can be processed by the server with certain delay, that's why enforcing the compacting of folders made the difference - the commands were executed by the server right away.

  • OK. Die Option Ordner nach jedem Löschen einer Nachricht komprimieren war bei mir aktiviert. Standardmäßig ist sie wohl deaktiviert. Wenn es tatsächlich daran liegt, dann erklärt es, wieso es bei mir klappte.


    Aus der Online-Hilfe:

    Auf einigen Servern können Nachrichten erst nach dem Komprimieren der IMAP-Ordner gelöscht werden. Dieser Prozess lässt sich durch Aktivieren der Option Ordner nach jedem Löschen einer Nachricht komprimieren automatisieren.

    Jetzt weiß man etwas mehr. Danke für das Feedback! :thumbup: