Reihenfolge der Tabs bei Mails im Text- UND HTML-Format (HTML zuerst anzeigen)

  • Moin!
    Ich hoffe, das allgemeine Thema passt hierher.
    Ich bekomme von der Postbank gelegentlich Mails mit Angeboten geschickt.
    Bei diesen befindet sich der "Text-Tab" in der Anlage (bei mir unten) an erster Stelle und der HTML-Tab an zweiter.

    Deshalb sehe ich im Vorschaufenster als erstes den Text:

    "Sehr geehrte Damen und Herren, leider unterstützt Ihr Mailprogramm oder Ihr Mailanbieter keine HTML-Darstellung."

    Quatsch! Natürlich unterstützt mein Programm HTML, nur muss ich diesen Tab erst anklicken.

    Kann ich irgendwie die Reihenfolge dieser Tabs ändern oder erzwingen, dass mir immer der Inhalt des HTML-Tabs anstatt des Text-Tabs angezeigt wird?

    TheBat! Pro 10.x (64 Bit) NAU • Win 11x64 Pro • keine PlugIns

  • Hi,

    die Reihenfolge der Tabs entspricht dem, was in den Benutzereinstellungen im Bereich Betrachter | Editor eingestellt ist. Siehe dort das Auswahlmenü HTML-Nachrichten anzeigen als und Nur-Text und HTML-Nachrichten anzeigen als.

  • die Reihenfolge der Tabs entspricht dem, was in den Benutzereinstellungen im Bereich Betrachter | Editor eingestellt ist. Siehe dort das Auswahlmenü HTML-Nachrichten anzeigen als und Nur-Text und HTML-Nachrichten anzeigen als.

    Tja, leider scheint das bei mir nicht zu stimmen. Siehe Screenshot.

    TheBat! Pro 10.x (64 Bit) NAU • Win 11x64 Pro • keine PlugIns

  • Du must "HTML und Nur-Text" im Dropdown für den Abschnitt "Nur-Text und HTML-Nachrichten anzeigen" wählen, bestätigen und dann notfalls mal den Ordner im Konto wechseln, damit es aktualisiert wird.


    The Bat! Pro 11.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.4.x | XMP + Regula

    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Mit Reihenfolge meinte ich die in den DropDown-Feldern.

    Bei HTML und Nur-Text-Version wird zuerst der HTML-Reiter, dann der Text-Reiter angezeigt.

    Bei Nur-Text und HTML zuerst der Text-, dann der HTML-Reiter.

  • Eigentlich ist bei Ralf alles richtig eingestellt. Seine Einstellung Nur-HTML bewirkt nämlich, dass bei einer Nur-Text und HTML-Mail immer nur der HTML-Teil gezeigt wird. Der Nur-Text-Teil wird ganz weggelassen. Es gibt also nicht mal einen Reiter dafür. Wieso bei dieser Einstellung dennoch der Nur-Text-Teil sichtbar wird und dazu auch noch zuerst, ist ein Rätsel. Vielleicht ist die Mail falsch erstellt worden. Dann muss man wahrscheinlich in der Tat die andere Einstellung HTML- und Nur-Text-Version ausprobieren. Wobei der einzige Unterschied zwischen diesen beiden Einstellungen ist eben die Sichtbarkeit der beiden Reiter. Ansonsten muss in beiden Fällen immer zuerst der HTML-Teil zu sehen sein.

    2 Mal editiert, zuletzt von sanyok (8. Juni 2024 um 17:59) aus folgendem Grund: Einstellung -> Einstellungen

  • Ich habe inzwischen sämtliche Einstellungen durchprobiert, sogar "HTML-Nachrichtenteile als Anhänge anzeigen", auch danach den Ordner gewechselt und sogar TB! neu gestartet. Es ändert sich genau gar nichts. Es sieht immer gleich aus.

    TheBat! Pro 10.x (64 Bit) NAU • Win 11x64 Pro • keine PlugIns

  • Es betrifft bisher nur die Nachrichten der Postbank.

    Die meisten anderen Newsletter kommen inzwischen nur noch im HTML-Format beziehungsweise habe ich hier gerade einen erhalten, den ich umschalten kann. Da steht dann aber der Text-Tab an zweiter Stelle und der HTML-Tab an erster. Bei der Einstellung "Nur als HTML anzeigen" passiert auch genau das, ich sehe dann überhaupt keine Tabs, sondern nur den reinen HTML-Newsletter. Dadurch fällt mir dann gar nicht auf, dass es überhaupt noch einen anderen Teil gibt.

    TheBat! Pro 10.x (64 Bit) NAU • Win 11x64 Pro • keine PlugIns

  • Es betrifft bisher nur die Nachrichten der Postbank.

    Kannst du so eine Nachricht editieren und dann hier für Tests anhängen?

    Bei der Einstellung "Nur als HTML anzeigen" passiert auch genau das, ich sehe dann überhaupt keine Tabs, sondern nur den reinen HTML-Newsletter. Dadurch fällt mir dann gar nicht auf, dass es überhaupt noch einen anderen Teil gibt.

    Das meinte ich. In beiden Fällen muss der HTML-Teil immer zuerst sichtbar sein und bei der Nur-HTML Einstellung sieht man lediglich keine Reiter/Tabs und kann daher nicht umschalten, was du aber sowieso nicht willst, wie ich dich verstanden habe. Daher ist es in deinem Fall egal, welche der beiden Einstellungen du wählst. Und weil du sagst, dass andere HTML-Mails richtig dargestellt werden, sind deine aktuellen Einstellungen aus dem Screenshot also richtig.

    Es stimmt daher etwas mit den Postbank-Mails nicht. Es kann z.B. sein, dass sie in Wirklichkeit reine Text-Mails sind, die den HTML-Teil lediglich als so eine Art Anhang haben. In so einem Fall würde keine der beiden Einstellungen greifen, sondern immer der Nur-Text-Teil angezeigt.

    Und welche Programmversion nutzt du denn gerade? Du wolltest doch die v11 antesten. Passiert es also mit v10, mit v11 oder mit beiden?

  • Ich habe mir die v11 noch nicht heruntergeladen und benutze momentan noch die 10.5.2.1.
    Das mit der Nachricht zum Testen werde ich eventuell morgen mal machen. Komme gerade von einem ausgefüllten Wahltag.

    TheBat! Pro 10.x (64 Bit) NAU • Win 11x64 Pro • keine PlugIns

  • Ich denke, das hängt wohl mit der S/MIME-Signatur der Mail zusammen. Ich erinnere mich nicht genau, da war mal was früher.


    The Bat! Pro 11.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.4.x | XMP + Regula

    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Ralf Brinkmann Mach doch mal einen Bugreport für Ritlabs und sende denen das Mail.
    Sollen die schauen, ob das Mail falsch aufgebaut ist oder von The Bat! die Text- und HTML-Teile falsch dekodiert werden.
    Ich bestätige den auch im Ritlabs-Bugtracker.

    Und wende dich auch mal an den Ritlabs-Support.


    The Bat! Pro 11.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.4.x | XMP + Regula

    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Einmal editiert, zuletzt von GwenDragon (11. Juni 2024 um 12:22)

  • Bei mir wird der Text-Teil der angehängten Nachricht ebenfalls zuerst angezeigt und es muss wohl in der Tat an der digitalen Signatur liegen. Ich habe hier nämlich eine Nur-Text und HTML Nachricht gefunden, die auch signiert ist, und bei ihr wird ebenfalls der Nur-Text-Teil zuerst angezeigt. Offensichtlich liegt's also am Programm. Da müssen tatsächlich Ritlabs drüberschauen. Diesen Bug, falls es einer ist, kann ich jedenfalls bestätigen.

  • Habe jetzt gerade diesen BT-Eintrag von Gwen gefunden:

    #0002265: Preview: OpenPGP signed HTML mail does not show as HTML

    Er betrifft ein ähnliches Verhalten, wenn man selbst eine signierte HTML-Nachricht erstellt. Das Problem ist also bereits im letzten Jahr gemeldet worden. Allerdings schreibt Gwen dort, dass es angeblich in v11.0.3 behoben worden sei. Entweder wurde es also komplett behoben oder die Behebung betrifft nur selbst erstellte Nachrichten.

  • Der Bug ist auch wieder da in 11.2.1

    Ja, eben. Ich weiß allerdings nicht, wie es mit der Nachricht von Ralf in v11.0.3 gestanden hätte. Aber da das Problem weiterhin bzw. wieder besteht, muss man es erneut melden.

    Es fällt zudem auf, dass es, wie Ralf bereits selbst bemerkt hat, keine Rolle spielt, ob die Option HTML-Nachrichtenteile als Anhänge anzeigen aktiviert oder deaktiviert ist. In beiden Fällen sieht man den HTML-Teil (Nachricht.html) als Anhang, was meine obige Vermutung bestätigt, dass hier eine Textnachricht mit einem HTML-Anhang erstellt wurde.