OAuth-Aufforderung nach dem Ruhezustand

  • Gibt es irgendwo eine Möglichkeit, um einzustellen, dass TheBat bei der Nutzung von OAUTH nicht den Standard-Browser verwendet?

    Ich habe in meinem Standard-Browser FireFox NoScript aktiviert und hebel auf diese Art und Weise eine sinnvolle Nutzung aus, da dann immer wieder ein Fenster für die Verifizierung aufpoppt. Wenn ich Standardbrowser auf Edge umstelle, dann funktioniert es problemlos im Hintergrund.

  • Soweit ich weiß, wird das Token mittlerweile über den internen Browser erstellt. Bei Bedarf kann man angezeigte URL auch in einen externen Browser kopieren, was aber nicht erforderlich ist. Ich habe erst neulich eine OAuth-Verbindung mit Outlook.com komplett über TB! erstellt.

    Und da das Token nur einmal erstellt wird, braucht man das alles auch nur einmal. Also kannst du kurz auf Edge umstellen, das Token erstellen und dann wieder auf FF zurück.

  • Soweit ich weiß, wird das Token mittlerweile über den internen Browser erstellt. Bei Bedarf kann man angezeigte URL auch in einen externen Browser kopieren, was aber nicht erforderlich ist. Ich habe erst neulich eine OAuth-Verbindung mit Outlook.com komplett über TB! erstellt.

    Und da das Token nur einmal erstellt wird, braucht man das alles auch nur einmal. Also kannst du kurz auf Edge umstellen, das Token erstellen und dann wieder auf FF zurück.

    Das hatte leider nicht funktioniert. Ich konnte mich manuell anmelden (im FF), Mails abrufen, aber beim nächsten Start von TheBat oder nach dem Hibernate des Rechners wurde irgendwann wieder das Auth-Fenster geöffnet.

    Nach dem Wechsel auf Edge als Standardbrowser musste ich auch nicht noch einmal neu authentifizieren. Das hatte sofort automatisch geklappt.

    Ich habe das jetzt noch einmal hin- und hergeschaltet und es funktioniert erst einmal wieder. Irgendwie komisch. Ich bin gar nicht auf die Idee gekommen, noch einmal den Standard auf den FF zurückzusetzen. Da das ein unwichtiges Konto war, hatte ich es ignoriert. Nur die permanenten Popup-Fenster für die Authentifizierung waren nervig.

    Ich werde das jetzt noch einmal weiter beobachten.


    @Gwen: Der Haken ist leider nicht gesetzt. Sonst hätte das geholfen. Aber dann ist wiederum unklar, wieso der Wechsel des Standardbrowsers bei mir auf den ersten Blick die Lösung des Problems war.


    Möglicherweise habe "ich" auch irgendwas mal kaputt gemacht, als ich vor ein paar Wochen aus Versehen unter Stress auf den "Alle Standard-Apps zurücksetzen" Button klickte. :(

    Den Button dort so prominent zu platzieren und kein rückgängig anzubieten... Bin am Ende aber selber schuld.

  • Ich habe kein Konto für Exchange, aber oAuth sollte mit dem internen HTML-Browser (ist ein Chromium-Ding) von The Bat! klappen.


     The Bat! Pro 11.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.4.x | XMP + Regula 

    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    3 Mal editiert, zuletzt von GwenDragon (1. Juli 2024 um 14:16)

  • wurde irgendwann wieder das Auth-Fenster geöffnet.

    Das sollte natürlich nicht vorkommen, weil es nur eine einmalige Sache ist. Es hat wahrscheinlich mit der Erstellung des Tokens nicht geklappt. Jemand hatte schon mal hier im Forum ein ähnliches oder gar das gleiche Problem. Deswegen habe ich damals in die Anleitung aufgenommen, dass man die Datei ACCOUNT.ATB aus dem MAIL-Verzeichnis löschen bzw. sichern und verschieben und danach es noch einmal versuchen sollte.

    Das hat übrigens vor ein paar Monaten nicht immer geholfen, wurde daher an Ritlabs gemeldet und sie haben v11.2 herausgebracht, die u.a. dieses OAuth-Problem mit MS-Diensten behebt, wie man auch dem Changelog entnehmen kann. Seit dieser Version müsste es also wieder klappen. Wenn du noch eine ältere hast, dann aktualisiere sie.

    Wie ich bereits geschrieben habe, habe ich es wohl gleich nach dem Release der v11.2 getestet und es klappte ohne Probleme. Wenn du die neuste v11.2.1 hast und es damit nicht klappt, dann haben Ritlabs oder MS wieder etwas verändert. Dann solltest du es an Ritlabs melden. Sie werden wahrscheinlich von dir Logs etc. haben wollen.

  • Diesen Morgen nach dem Aufwachen aus Hibernate kam das Popup-Fenster wieder. Ich habe die 11.2 und werde jetzt erst einmal updaten. Dabei hatte sich übrigens das Update-Fenster nach dem "Versuch" des Neustartes nicht geschlossen.

    Ich glaube aber jetzt, dass das Problem ein anderes ist. Ich hatte ja geschrieben, dass es ein unwichtiges Konto ist, damit kommen da sehr selten Mails. Ich habe daher erst jetzt festgestellt, dass die Authentifikation trotz des Fensters erfolgreich war:

    Zitat

    02.07.2024, 08:08:04: IMAP - IMAP-Server Authentifikation OK - IMAP-Server meldet: "********@gmail.com authenticated (Success)"

    Da wir in letzter Zeit auch bei anderen Programmen festgestellt hatten, dass nach dem Aufwachen des Rechners plötzlich versteckte Formulare angezeigt wurden, scheint das möglicherweise ein Bug von Microsoft (Windows) zu sein, den es seit ein paar Wochen gibt.

    In dem anderen Fall wurden für einige Fenster, die geschlossen, aber nicht zerstört waren, beim Aufwachen ein DoShow getriggert. Das war Windows 11 und ich habe Windows 10. Aber möglicherweise ist das hier ein ähnliches Problem.

    Ich kann das Verhalten jedenfalls nicht provozieren. Somit könnte der Edge als Standardbrowser auch nicht die Lösung gewesen sein, wie ich es zuerst vermutete.

  • TheBat ist inkl. Daten auf einer SSD. Eine Festplatte, die ich im System habe, muss ich als Wechselplatte im BIOS eintragen, da sie ansonsten nach dem Aufwachen verschwindet. (Inkompatibilität Motherboard & Festplatte) Das sollte aber sicherlich nicht das Problem sein?

    Ich gehe davon aus, dass alles ausgeschaltet wird, auch wenn ich Engergiesparen statt Ruhezustand wähle.

    Laut Energiesparplan wird die Platte nach 0 min, also standardmäßig nicht ausgeschaltet.

    Zitat

    Es passiert also nur nach dem Ruhezustand?

    Und wenn du TB! nach dem Aufwachen neu startest?

    Das muss ich weiter beobachten. Bislang hat mich die Situation immer nur genervt.

    Da TheBat immer noch ab und zu nicht sauber schließt, lasse ich es im Normalfall offen. Die nicht aktualisierten Uhrzeiten am nächsten Tag "repariere" ich per Hand.

  • Nach einem Ruhezustand erscheint das Fenster auch.

    Wenn TheBat geschlossen war und nach dem Ruhezustand wieder geöffnet wurde, dann erscheint das Fenster nicht. (nur 1x getestet)

    Ich weiß auch nicht, ob es relevant ist, ob TheBat das aktive Fenster beim Hibernate ist. Das könnte ich nur nebenbei beobachten.

    Jedenfalls scheint es mit größter Wahrscheinlichkeit eine Folge des Hibernate zu sein.


    Zum Ändern des Titels fehlen mir Berechtigungen oder übersehe ich da etwas?

  • Zum Ändern des Titels fehlen mir Berechtigungen oder übersehe ich da etwas?

    Ich weiß nicht, ob nur die Moderatoren das dürfen. Wenn du oben bei "Thema bearbeiten" → Erweitert nichts aufrufen darfst, sind die Editierrechte nach einiger Zeit eingeschränkt.

    Wie soll der Titel nun heißen?


     The Bat! Pro 11.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.4.x | XMP + Regula 

    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • So wie sich das entwickelt hat, hat der Titel ja gar nichts mehr mit dem Thema zu tun.

    "OAUth-Aufforderung nach Hibernate"

    wäre sicherlich passender. Oder was denkst Du?

  • Wenn TheBat geschlossen war und nach dem Ruhezustand wieder geöffnet wurde, dann erscheint das Fenster nicht. (nur 1x getestet)

    Ich meinte, wenn das während des Ruhezustandes geöffnete Programm nach dem Aufwachen zuerst komplett geschlossen und dann wieder gestartet wird. Aber mittlerweile nehme ich an, dass wenn das Programm bei dir neu gestartet wird, egal zu welchem Zeitpunkt, es ohne Probleme bis zum nächsten Ruhezustand funktioniert. Daraus folgt, dass mit dem erstellten Token alles in Ordnung ist, nur dass wahrscheinlich das Programm es nach dem Aufwachen nicht findet und daher eine erneute OAuth-Registrierung fordert.

    Ritlabs müssen sich das näher anschauen. Melde das irgendwie an sie.

  • sanyok 3. Juli 2024 um 13:30

    Hat den Titel des Themas von „OAUth nicht über Standard-Browser“ zu „OAuth-Aufforderung nach dem Ruhezustand“ geändert.