Aktives Konto

  • Hallo,
    ich habe einen gemeinsamen Ordner angelegt, wohin gefilterte Mails verschoben werden. Möchte ich nun eine Mail beantworten, so wird diese in den Postausgang des aktiven Kontos gestellt (Einstellungen/Aktives Konto).
    Leider ist immer das erste Konto der Liste ausgewählt bzw. aktiv. Das ist aber oftmals nicht das Konto, über das die Mail bei mir angekommen ist, und so werden dann Mails unter einer Adresse verschickt, mit der der Empfänger wenig anfangen kann.
    Gibt es eine Möglichkeit, TB so einzustellen, dass Antworten aus einem gemeinsamen Ordner immer unter der Adresse veschickt werden, an die die erste Mail gerichtet war?


    Viele Grüße,
    Rolf

  • Code
    %IF:"%OTOADDR"="hans@example.org":"%ACCOUNT='hans'":""%-
    %IF:"%OTOADDR"="fritz@example.org":"%ACCOUNT='fritz'":""%-


    Das in die Antwortvorlage kopieren und nach eigenen Bedürfnissen anpassen. Das betrifft zum einen die Mail-Adresse und zum anderen den Account der verwendet werden soll.


    Habs nicht getestet, sollte aber gehen.

  • hy bernd.
    danke auch !


    es reicht ja dann wenn man diese bedingungen alle im erste konto bei der antwortvorlage reinschreibt, da bat ja das erste konto immer verwendet, wenn man aus einem gemeinsamen oder virtuellen(gemeinsamen) ordner was verschickt :denk:

  • Zitat
    Code
    %IF:"%OTOADDR"="hans@example.org":"%ACCOUNT='hans'":""%-
    %IF:"%OTOADDR"="fritz@example.org":"%ACCOUNT='fritz'":""%-


    Das in die Antwortvorlage kopieren und nach eigenen Bedürfnissen anpassen. Das betrifft zum einen die Mail-Adresse und zum anderen den Account der verwendet werden soll.


    Hallo!


    Sorry, dass ich ein soooo altes Thema aufmache, aber da es thematisch einfach sehr sehr gut hierzu passt, packe ich meine Anfrage mal hier rein:


    Meine Kollegin nutzt The Bat und damit mehrere Email-Accounts (POP3/SMTP). Nun haben wir bei einem generellen EDV-Update gesehen, dass es eine neuere Version (für die unsere Lizenz noch gültig ist) gibt, und diese installiert. Wir benutzen Version 4.0.38 Pro.


    Seitdem verwirrt The Bat die Absenderemailadressen: Wenn sie (wir nennen sie einfach mal Karin) eine Mail an karin@example.org bekommt und auf Antworten klickt, wird Gerd@example.org als aktives Konto ausgewählt obwohl weiterhin Karin@example.org im „VON“-Feld steht. „Gerd“ ist nicht über die „mailto:“-Funktion als Hauptkonto aktiviert!


    Nun hatte ich mich schon sehr gefreut, als ich diesen Thread hier gefunden habe und habe das auch gleich probiert mit den Antwortvorlagen, aber leider funktioniert es nicht. Ich habe die Zeilen bei beiden Kontos auch für die Email-Aliase (karin@example.org UND karin.nachname@example.org) gesetzt, um ganz sicher zu gehen, aber auch das half nichts.


    Deshalb 2 Fragen:


    Gab es Änderungen in der „Scriptsprache“, so dass dieses Script (siehe Quote) zwar noch in einer 2.x-TB-Version funzt, aber in 4.0.38 nicht mehr?


    Wie genau muss das aktive Konto spezifiert werden: Reicht „karin“ oder lieber „karin@example.org“?


    Vielen Dank im Voraus für die Antworten und liebe Grüße,


    Jakob

  • Ich war mal so frei, die Domains auf example.org zu ändern, damit Gerd und Karin bei der anderen Domain nicht so viel Spam von dir bekommen ;)


    Zum Problem: Bei %ACCOUNT muss der Name des Kontos so drin stehen, wie er auch im Programm bezeichnet ist. Wie das nun bei euch ist, musst du natürlich selbst wissen.


    Zitat

    Seitdem verwirrt The Bat die Absenderemailadressen: Wenn sie (wir nennen sie einfach mal Karin) eine Mail an karin@example.org bekommt und auf Antworten klickt, wird Gerd@example.org als aktives Konto ausgewählt obwohl weiterhin Karin@example.org im „VON“-Feld steht. „Gerd“ ist nicht über die „mailto:“-Funktion als Hauptkonto aktiviert!


    Wenn man auf "Antworten" drückt, wird immer das Konto genommen, welches markiert ist. Das hat mit dem mailto überhaupt nichts zu tun, das betrifft nur Links im Internet-Browser.


    Sind die Mails zufällig in einem gemeinsamen Ordner? Dann brauchst du die Vorlage natürlich auf jeden Fall, da das Programm sonst nicht weiß welches Konto es nehmen soll. Vermutlich liegt hier der Fehler.

  • Lieber Bernd, danke für deine schnelle Reaktion!


    Ich war mal so frei, die Domains auf example.org zu ändern, damit Gerd und Karin bei der anderen Domain nicht so viel Spam von dir bekommen ;)


    Danke! Das waren zwar schon Beispieladressen, aber example.org ist natürlich noch deutlicher.


    Zitat


    Wenn man auf "Antworten" drückt, wird immer das Konto genommen, welches markiert ist. Das hat mit dem mailto überhaupt nichts zu tun, das betrifft nur Links im Internet-Browser.


    Hm, aber wenn die „mailto:“-Einstellung nur den Browser betrifft, warum sollte dann der Beitrag…

    Hat sich das Thema mit dem Beitrag erledigt?


    was geändert haben? Dort liest sich das in der Tat so, dass mit der mailto-Option das Standardkonto definiert wird.


    Zitat

    Sind die Mails zufällig in einem gemeinsamen Ordner? Dann brauchst du die Vorlage natürlich auf jeden Fall, da das Programm sonst nicht weiß welches Konto es nehmen soll. Vermutlich liegt hier der Fehler.


    Ja, gemeinsamer Ordner ist der Fall!! Ich weiß nicht, wie meine Kollegin das früher gemacht hat, aber TB ist dann anscheinend früher von der Mailadresse im TO-Field ausgegangen, und wenn diese mit einem Account korrespondiert, hat er automatisch den Absender geändert. Anscheinend tut er das aber in 4.0.38 nicht mehr.


    Ich werde das gleich mal überprüfen.


    Vielen Dank nochmal.


    Jakob

  • Zitat

    Danke! Das waren zwar schon Beispieladressen, aber example.org ist natürlich noch deutlicher.


    Dann benutze nicht die Adresse von fremden Leuten als Beispiel. Möchtest du doch sicher auch nicht, dass wir deine E-Mail-Adresse hier ständig schreiben ;) Die Domain example.org ist speziell für solche Sachen vorgesehen. Ich bin aber auch nicht frei von Fehlern, ich habe früher auch oft irgendwelche anderen Domains verwendet.


    Zitat

    Hm, aber wenn die „mailto:“-Einstellung nur den Browser betrifft, warum sollte dann der Beitrag…was geändert haben? Dort liest sich das in der Tat so, dass mit der mailto-Option das Standardkonto definiert wird.


    Da der Beitrag danach war dachte ich, dass es darauf vielleicht auch einen Einfluss hat. Da ich das Programm selbst schon lange nicht mehr nutze, kann ich es schwer testen. Meine Vorlage mit dem %ACCOUNT sollte aber schon funktionieren. Ansonsten bräuchte man Beispiel-Header von solchen Mails um zu prüfen was wirklich im Empfänger steht.


  • Da der Beitrag danach war dachte ich, dass es darauf vielleicht auch einen Einfluss hat. Da ich das Programm selbst schon lange nicht mehr nutze, kann ich es schwer testen. Meine Vorlage mit dem %ACCOUNT sollte aber schon funktionieren. Ansonsten bräuchte man Beispiel-Header von solchen Mails um zu prüfen was wirklich im Empfänger steht.


    Ok. Also in der Tat werden, wenn ich die „mailto:“-Einstellung für eines der beiden Konten setze, Mails aus einem gemeinsamen Ordner heraus mit diesem Konto verschickt. Das habe ich also erstmal eingestellt, damit im Zweifel die Mails von Karins Konto geschickt werden.


    Dann habe ich außerdem rausgefunden, dass es ja neben kontospezifischen Antwort-Vorlagen auch noch „gemeinsame Ordner“-spezifische Antwort-Vorlagen gibt. Seit ich die Zeilen da reingepackt habe, geht es.


    Dann habe ich noch ein

    Code
    %ACCOUNT='gerd@example.org'%-

    in die „Neue Mail“-Vorlage von Gerds gemeinsamem Ordner und bei Karin natürlich entsprechend gesetzt, und nun läuft alles so, wie es soll.


    Vielen Dank für die Hilfe!


    Lg,


    Jakob