Backup Batch

  • Das Tutorial #7 zu The Bat! + K9 Backup läst sich nicht Downloaden ?
    Irgend wie komme ich immer wieder auf die Startseite :(


    Bekomme beim Starten der Batchdatei immer den Fehler:


    FEHLER: Datei "D:\Backup\TheBat!_Backup\07.12.2003"\TheBat!.zip nicht gefunden!
    Drücken Sie eine beliebige Taste . . .


    Was soll mir das sagen ?

  • Die Pfade hab ich angepast !
    Nur wie soll es den beim ersten Start die Datei TheBat!.zip finden ?
    Die gibts doch noch garnicht ?


    Und ich war eingelogt auf der Seite !

  • Naja .. das Tutorial hilft mir eigentlich nicht weiter :(
    Den Windows Taskplanner mag ich nicht ;)


    Ich lass das Backup einfach über eine Batchdatei mit The Bat! starten.

  • Kann ich schon :D


    Aber da ich The Bat! eh über eine Batch starte damit vorher K9 gestartet wird,
    bring ich das da grade noch mit rein.
    Und so wie ich das lese wird ja geprüft ob es am selben Tag schon ein Backup gab.


    Nur hab ich immer noch ein Problem mit dem obengenante Fehler.

  • Mhhh, bei mir funktioniert es unter XP home incl. SP.


    Meine Batch sieht so aus (pkzip im gleichen Verzeichnis):


    Das einzig zu ändernde ist dieses:

    Code
    :: Welche Dateien sollen gesichert werden?
    :: The Bat! Installationsverzeichnis
    set SOURCE_DIR="c:\programme\bat"
    
    
    :: Wo sollen die gesicherten abgelegt werden?
    set TARGET_DIR="E:\system\backup\thebat_k9_backup\%DATE%"



    MfG
    caschy

  • Konnte folgendes finden:



    Vieleicht ist mein Mailverzeichniss zu groß ?

  • So geht es leider doch nicht :(


    Er macht es dann nur ein einziges mal.


    Weil wenn ich


    Zitat


    \%DATE%


    entferne trift


    Zitat


    if exist %TARGET_DIR% goto end


    immer zu wenn ich es einmal ausgeführt habe !