[Problem gelöst] Unbekanntes ZA-Zertifikat

  • Hallo Zusammen,


    leider erhalte ich beim Mailabruf über TLS immer folgende Meldung:


    Code
    Der Server hat während der Session kein Wurzelzertifikat
    übergeben und es existiert kein entsprechendes Wurzelzertifikat
    in Ihrem Adressbuch.


    Mein Provider ist all-inkl.com und dieser hat mir gesagt ich solle die Direkt-Adresse, also nicht meine Domain, zum abrufen nehmen.
    Sie lautet: ddxxxxx.kasserver.com


    Folgender Log wird mir ausgegeben:



    Des weiteren habe ich die Zertifikate auf
    http://www.usertrust.com/cacerts/ herunter geladen und in mein
    Adressbuch unter Trusted Root CA importiert. Auch hier zeigte sich keine Änderung. Nur welches das richtige ist weiss ich natürlich auch nicht.


    Der Support ist zwar schnell, nett und sehr gut, aber bis jetzt konnte er mir nicht weiterhelfen.


    Vielleicht ist das ein spezielles The Bat! Problem...


    Hab auch schon RootCA.ABD gelöscht, wie es mal zu einem ähnlichen Problem stand. Die Datei wurde zwar wieder angelegt, hatte aber keine Auswirkung.


    Wäre schade wenn ich TLS aufgrund der Meldung, die man immer bestätigen muss damit die Mails dann doch abgerufen werde, nicht nutzen könnte.


    Vielen Dank schonmal...


    MfG
    DJoTW

  • kleiner Nachtrag:
    in dem Zertifikat UTN-USERFirst-Hardware, das auch in meinem Adressbuch ist, steht folgendes:


    Code
    Dieses Zertifikat ist gültig
    
    
    The Bat! can use this certificate for: message encryption - no, 
    verifing digital singature of a message - no, TLS connections - no.


    Hat das was zu sagen, das bei TLS connections - no dran steht?

  • leider ist das Update für XP... bei mir läuft TB auf Win2000 SP4...
    das einzige Stammzertifikatsupdate für Win2000 hab ich vom 27.09.2006 gefunden und dieses eingespielt...


    nachdem ich die Datei gelöscht und TB neu gestartet habe kommt wieder die Meldung!


    Wenn ich den IE aufmache und unter Zertifikate nachschaue sind diese auch vorhanden, nur TB will die scheinbar nicht benutzen...

  • :yahoo:


    halber Tag und viele Zertifikate später...


    Lösung gefunden:


    Ich bin mit Firefox auf https://kasserver.com, dann hab ich unten rechts auf das Schloss geklickt und danach auf Anzeigen / Details (siehe Bild)


    Jetzt konnte ich die Zertifikatshierachie sehen...


    im Trusted Root CA von TB ist AddTrust External CA Root nicht bekannt und auch nach einem Stammzertifikats Update (auch das nur für XP) ist dieses nicht vorhanden (im IE demzufolge auch nicht).
    Firefox hingegen ist das bekannt!!
    Deswegen funktioniert der Mailabruf mit Thunderbird, das ich zwischenzeitlich auch getestet habe, problemlos!


    Also habe ich mir das Zertifikat AddTrustExternalCARoot.crt heruntergeladen und in TB importiert!
    Musste es aber zu Vertrauten hinzufügen, da es sonst als ungültig angezeigt wird.


    Ich weiss jetzt nicht ob das so richtig war, aber es muss wohl so sein denn danach ging der Mailabruf ohne diese Meldung!


    Gibt es für TB nicht eine RootCA.ABD die alles enthält bzw. wird diese nicht ab und zu mal aktualisiert? Oder hängt diese vom Betriebssystem ab?

  • Zitat


    Gibt es für TB nicht eine RootCA.ABD die alles enthält bzw. wird diese nicht ab und zu mal aktualisiert? Oder hängt diese vom Betriebssystem ab?


    Ist bei XP vorinstalliert -> Software -> Windows-Komponenten hinzufügen/entfernen -> Aktualisierung von Stammzertfikaten. Ob es das bei Windows 2000 gibt :nixwiss: .

  • @maddox
    ja, das ist mir schon klar das es sowas gibt...
    die Frage ist ob TB aber auf die Stammzertifikate von Win drauf zu greift und RootCA.ABD dann aktualisiert! Wenn ja, dann ist es gut...


    dabei gibt es aber dann nur ein Problem...
    Laut Liste auf http://support.microsoft.com/kb/931125/en-us ist AddTrust External CA Root das ich benötigt habe im Stammzertifikatsupdate nicht dabei...


    oder hast Du in Deiner RootCA.ABD diese drin? :denk:

  • Zitat


    @maddox
    ja, das ist mir schon klar das es sowas gibt...
    die Frage ist ob TB aber auf die Stammzertifikate von Win drauf zu greift und RootCA.ABD dann aktualisiert! Wenn ja, dann ist es gut...


    Ja, TB greift darauf zu.


    Zitat

    dabei gibt es aber dann nur ein Problem...
    Laut Liste auf http://support.microsoft.com/kb/931125/en-us ist AddTrust External CA Root das ich benötigt habe im Stammzertifikatsupdate nicht dabei...


    oder hast Du in Deiner RootCA.ABD diese drin? :denk:


    Nein, ist bei mir nicht mit drin. Folgende Meldung erscheint bei mir (beim Aufruf der Seite):


    [Blockierte Grafik: http://upload.batboard.net/images/bild1069b.jpg]

  • ja so sieht das ganze im IE aus...


    und in TB sind diese Zertifikate auch vorhanden nur das Ausstellerzertifikat wird nicht angezeigt... in Firefox aber wird die Hierachie mit angezeigt!


    von daher... lassen wir es gut sein... das Problem ist ja jetzt gelöst!