The Bat!@wine - Ein aktueller Bericht

  • Sind denn die genauen Größen bereits bekannt?

    Nee, aber in meinem eigenen Versandt-Ordner sind alle Mails mit Anhängen kleiner als 400 KByte erfolgreich versandt worden.


    Und als Workaround empfiehlt es sich, auf die wine Version v6.9 zurück zu gehen, etwa so (Debian und Freundinnen):

    Code
    root@Archimedes:~# for PKG in wine-devel wine-devel-amd64 wine-devel-dbg:amd64 wine-devel-dbg:i386 wine-devel-dev wine-devel-i386:i386 winehq-devel;do apt-get install ${PKG}=6.9~buster-1;done;


    Anschließend die wine-Pakete auf hold setzen, dann werden die nicht mehr mit aktualisiert:


    Code
    root@Archimedes:~# (for PKG in wine-devel wine-devel-amd64 wine-devel-dbg:amd64 wine-devel-dbg:i386 wine-devel-dev wine-devel-i386:i386 winehq-devel;do echo "${PKG} hold";done;) | dpkg --set-selections

    Das betrifft die wine-development Pakete. Wer das offizielle Paket aus seiner Distribution verwendet, ist wahrscheinlich safe.


    Die wine-Version v6.9 vom 21. Mai 2021 ist die derzeit letzte funktionsfähige.

  • Hallo Fledermäuse@Pinguine!


    Entwarnung!


    Seit einer der letzten Versionen von wine funktioniert der Nachrichtenversand inkl. Anhänge wieder. Die aktuelle Version von wine ist vorgestern (30. Juli 2021) veröffentlicht worden und hat die Versionnummer: 6.14.


    Warum das allerdings nicht funktioniert hat, bleibt ein Rätsel.

    Ferner besteht der Fehler The Bat! v9.3.4.12: Missing content in TTreeViews on Windows versions higher than 8 weiterhin.


    Getestet mit The Bat! Versionen ab v9.3.4.0 (msi).

  • Hallo liebe Pinguinfreund:innen!


    Bevor morgen Abend eine neue wine-Version (dann kommt v6.20) erscheint, berichte ich mal vom aktuellen Zwischenstand:

    Soweit läuft alles normal, außer, das wine ein Problem mit einem Steuerelement von Delphi (TTreeView) hat:

    The Bat! v9.3.4.12: Missing content in TTreeViews on Windows versions higher than 8

    Das Problem tritt auch bei aktuellen The Bat!-Versionen auf und ist ein wine-Problem, das wiederum dann erscheint, wenn man einen originalen NVIDIA-Graphic-Treiber verwendet...


    Hier ein kleiner Workaround:

    1. wine installieren, die verwendete Windows-Version wird durch wineboot auf Windows 10 gesetzt
    2. The Bat! mit dem Windows-Installer (MSI) von Ritlabs Downloadseite installieren
    3. per winecfg die Windows-Version auf Windows 8 setzen

    läuft...


    ...und zum Schluss - das Wetter meine Konfiguration:


    Es gibt keine Linux-Version von The Bat! und Ritlabs hat auch keine in Aussicht gestellt, dennoch fliegt die Fledermaus im Pinguinland.
    Mehr dazu, mit mehr oder weniger aktuellen Flugberichten:


    The Bat!:
    Batboard - Anfang: The Bat!@wine - Ein aktueller Bericht
    Batboard - aktueller Post: The Bat!@wine - Ein aktueller Bericht
    Bugtracker: RitLABs Bugtracker (Anmeldung erforderlich)
    Letzte Änderungen in The Bat!: Changelog (Anmeldung erforderlich)


    wine:
    The Bat! in wines-AppDB: The Bat! auf wine
    The Bat! auf wine installieren (Englisch): Three ways To install The Bat! on wine
    The Bat! in wines-Bugtracker: The Bat!s Macken mit wine


    Meine alltägliche Konfiguration:
    Daten der Fledermaus:
    produktiv:

    The Bat! Professional: Version 9.4.3.1 32bit (i386)

    testen: The Bat! Professional (32bit + 64bit): aktuelle Betaversion


    Mein Linux - Ausgabe von uname -srvmo: Linux 5.10.0-9-amd64 #1 SMP Debian 5.10.70-1 (2021-09-30) x86_64 GNU/Linux Devuan 4/chimaera

    Desktop: Plasma/KDE 64bit


    Plasma/KDE-Version: 5.21.5
    Wine-Version: 6.19
    PlayOnLinux-Version: nicht installiert


    Stand: 21. Oktober 2021, 18:59 Uhr


    (This info was created by tb_getinfo)