XMP mit HTML-Vorlage

  • Hallo,


    ich nutze das XMP z.B. für die Anrede und die Anlagen. Leider funktioniert es nicht mehr, wenn man in der jetzt aktuellen The Bat!-Version die Standardvorlagen auf HTML umstellt. Gibt es da irgendwie eine Möglichkeit, es trotzdem zu nutzen?

  • Hallo sanyok,


    z.B. die Standardvorlage für neue Nachrichten:


    Sehr geehrte%IF:"%ABToGender"="1":"r Herr %ABToNamePrefix":""%-
    %IF:"%ABToGender"="2":" Frau %ABToNamePrefix":%-
    %IF:"%ABToGender"="0":" Damen und Herren"%ABToLastName,


    %Cursor


    --
    Mit freundlichen Grüßen,
    %FROMNAME


    %_A="%XMP_StrTrim('%ATTACHMENTS')"%-
    %IF:|%_A|=|<none>|:|%_A=""|:||%-
    %IF:|%_A|<>||:|Anlagen:
    o) %XMP_StrRepl("%ATTACHMENTS",", ","%-
    %XMP_StrC(#\r\n o) #)")|:||


    Wenn ich die auf HTML-Format umschalte, klappt das mit der Anrede und den Anhängen nicht mehr.


    Gruß,
    Petro

  • Hallo Bernd,
    :doh:
    Du hast natürlich recht, mit der Anrede hat das jetzt nichts zu tun. Irgendwie war ich wohl der Meinung, daß ich das auch von Gaijins Homepage habe.


    Zu Deiner Frage:
    Das scheint unabhängig voneinander zu sein, es ändert nichts, wenn ich den Anhänge-Teil rausnehme.


    So sieht es aus, wenn ich auf "Neue Nachricht" klicke:


    Sehr geehrte
    /spanspan>




    --
    Mit freundlichen Grüßen,
    Karin Muster


    <>||:|Anlagen:
    o) <none>|:||



    Das /spanspan> war halt sonst nicht da. Und er liest auch den Nachnamen nicht mehr aus.


    Bei den Anhängen sieht es dann so aus:


    <>||:|Anlagen:
    o) Damentisch.pdf|:||


    statt so:


    Anlagen:
    o) Damentisch.pdf


    Gruß,
    Petro

    * The Bat! Professional Edition Version 9.5 (32-bit) Christmas Edition*



    Einmal editiert, zuletzt von Petrocelli ()

  • Ich habe eigentlich immer gedacht, daß auch diese Zeichen einen bestimmten Zweck haben. Aber anscheinend gehts auch ohne ... klappt tatsächlich.


    Jetzt bräuchte ich eigentlich nur noch einen Tip wegen der Anrede, da stelle ich die Frage besser nochmal unter "Makros + Regenechsen".


    Danke dir,
    Petro

  • Nachtrag:


    Ich glaube, ich weiß jetzt, wofür diese Zeichen gut waren. Vorher stand die Anlagenaufzählung nur da, wenn es auch Anlagen gab. Jetzt steht sie immer da, bei ohne Anlagen mit "none".


    Naja, man kann wohl nicht alles haben ...


    Gruß,
    Petro