Regula rausgeworfen und nicht mehr hinzufügbar

  • Hi!


    Ich weiß, Regula wurde weder für Voyager noch für Vista weiterentwickel. Trotzdem hat es unter Vista mit Voyager auf USB-Stick bei mir bislang sehr gut funktioniert. Nun ist es plötzlich aus der Installation verschwunden. Beim Versuch, das Plugin hinzuzufügen, erhalte ich die angefügte Fehlermeldung. (hoffe, das klappt)


    Ich habe regula.tbp gelöscht und neu in das Verzeichnis kopiert, weil ich dachte, die Datei könnte evtl. defekt sein, hat aber nichts gebracht.
    Aufgetaucht ist der Fehler plötzlich, vorher keine Updates, weder Vista noch TBVoyager, in der Version Voyager 4.0.34. Update auf letzte Version 4.1.11 hat nichts geändert.


    Hat jemand eine Idee, was hier passiert sein könnte. Wenn Regula für diese Konstellation tatsächlich nicht geeignet ist, muß ich mich nach einer Alternative umsehen. Da es aber unter derselben Konfiguration bislang wunderbar funktioniert hat, liegt es ja vielleicht doch an etwas anderem. Ich würde es jedenfalls gerne behalten.


    Vielen Dank,


    windhorse

  • Zitat


    Hast du auch unter Vista die Pro Version im Einsatz? Wenn ja, kannst du dort Regula problemlos einbinden?


    Ich habe Voyager Pro nur auf dem USB-Stick installiert. Soll ich es testweise auch auf Festplatte unter Vista installieren und dort die Regula-Einbindung testen?


    Läßt sich sagen, woran solche Access-Violation-Meldungen grundsätzlich liegen können, oder ist das zu kompliziert?

  • Eine zusätzl. Testinstallation würde mich einen Installationskey kosten :unsure:


    Deshalb hab ich andersrum getestet und versuchsweise die freie Version des AntispamSniper Plugins auf dem USB-Stick unter Voyager Pro installiert. Es ließ sich ohne Fehlermeldung hinzufügen.


    Nun weiß ich allerdings nicht, welchen Schluß man für den Fehler beim Regula Plugin daraus ziehen kann.


    Ich würde Gaijin ja gerne treu bleiben. Aber Phalanx kann ich leider nicht mobil mitnehmen, es muß auf dem Rechner installiert sein oder zumindest Rechte haben, oder sehe ich das falsch?

  • Zitat


    Ich habe Voyager Pro nur auf dem USB-Stick installiert. Soll ich es testweise auch auf Festplatte unter Vista installieren und dort die Regula-Einbindung testen?


    Nicht Voyager, sondern TB! auf die Festplatte testweise installieren. Dafür braucht man keine Aktivierung. So kann man sehen, ob es bei dir an Vista, also am OS oder an Voyager, also am Programm bzw. seinen Einstellungen liegt. Testweise könnte man auch die Datei GLOBAL.INI sichern und entfernen. Vielleicht ist darin irgendein Eintrag enthalten, der stört.

  • Zitat

    Bei Gaijin steht: "Installation: Keine (portabel)"
    http://www.gaijin.at/dlphalanx.php


    OK, danke für den Hinweis. Dann werde ich, wenn ich mal etwas mehr Zeit habe, auf jeden Fall versuchen, Phalanx einzurichten. Soweit ich gesehen habe, verlangt es recht viele Einstellungen, die sich bei zahlreichen Konten doch summieren. Außerdem bin ich nicht sicher, ob es sich mit meinem Webfilter Proxomitron verträgt, der auch auf den localhost zugreift. Werde ich ja sehen.


    Derzeit habe ich das AntispamSniper Plugin testweise installiert. Die reine Funktion ist bis jetzt gut, die Erkennung ist aber bislang nicht berauschend, hat allerdings auch kein Spamtraining durchlaufen wie seinerzeit Regula. Ich weiß gar nicht, ob das bei AntispamSniper vorgesehen ist, werde aber beobachten, wie schnell es lernt oder eben nicht.


    Ich weiß nicht, wie es Euch geht, aber bei mir ist das Spamaufkommen in letzter Zeit ohnedies dramatisch reduziert, weil die diversen Provider schon das meiste aussortieren, was natürlich den Nachteil fehlender Kontrolle hat. Dadurch ist das Problem aber derzeit nicht ganz so drängend. Auf längere Sicht erscheint mit Gaijins Phalanx sinnvoll, wenn es tatsächlich portabel ist, zumal Regula ja nicht weiterentwickelt wird.


    sanyok
    Auch Dir noch Dank für die Anregungen, die ich bei Gelegenheit probieren werde.

  • Zitat

    Ich weiß gar nicht, ob das bei AntispamSniper vorgesehen ist, werde aber beobachten, wie schnell es lernt oder eben nicht.


    Das Trainieren ist eigentlich bei jedem Plug-in vorgesehen. Das Verfahren ist auch bei allen gleich: zuerst viele Junk-Nachrichten markieren und auf "Als Junk klassifizieren" klicken und danach viele Nicht-Junk-Nachrichten markieren und auf "Als Nicht-Junk klassifizieren" klicken. Ist einfach und geht schnell.



    Zitat

    zumal Regula ja nicht weiterentwickelt wird.


    Es funktioniert auch so prächtig. Vielleicht ist das u.a. der Grund, wieso nicht weiterentwickelt wird... ;)

  • Zitat


    Das Trainieren ist eigentlich bei jedem Plug-in vorgesehen. Das Verfahren ist auch bei allen gleich: zuerst viele Junk-Nachrichten markieren und auf "Als Junk klassifizieren" klicken und danach viele Nicht-Junk-Nachrichten markieren und auf "Als Nicht-Junk klassifizieren" klicken. Ist einfach und geht schnell.


    Das stimmt wohl. Aber woher nehmen und nicht stehlen ;) Ich bewahre meine Spammails jedenfalls nicht auf. Sind denn die Spampakete hier auf der Seite (von 2003) noch hilfreich, oder hat sich seitdem zuviel verändert?


    Zitat


    Es funktioniert auch so prächtig. Vielleicht ist das u.a. der Grund, wieso nicht weiterentwickelt wird... ;)


    Durchaus möglich. Es wäre sicherlich interessant, Gaijins Grund zu kennen. Ich habe jedenfalls nirgendwo gesehen, daß er Regula als kompatibel mit Voyager, TB 4 oder Vista bezeichnete. Da nahm ich entsprechend an, das habe etwas zu bedeuten und habe mich nicht übermäßig gewundert, als Regula eines Tages nicht mehr funktioniert hat.


    Um noch einmal auf eine Anregung von Dir zurückzukommen. Wenn ich, wie Du rätst, die global.ini nach Sicherung vom Stick entferne, wird dann eine neue erstellt, oder wie würde das funktionieren?


    Mich würde natürlich auch interessieren, ob Regula bei anderen Usern in der Verbindung Voyager und Vista problemlos arbeitet.

  • Zitat


    Sind denn die Spampakete hier auf der Seite (von 2003) noch hilfreich, oder hat sich seitdem zuviel verändert?


    Nimm zuerst die und später kannst du die Junk-Datenbank mit deinen Junk-Nachrichten füttern.



    Zitat


    Ich habe jedenfalls nirgendwo gesehen, daß er Regula als kompatibel mit Voyager, TB 4 oder Vista bezeichnete.


    Funktioniert aber mit TB! v4.x und Vista 32-/64-Bit.



    Zitat


    Wenn ich, wie Du rätst, die global.ini nach Sicherung vom Stick entferne, wird dann eine neue erstellt, oder wie würde das funktionieren?


    Die GLOBAL.INI bei Voyager ist wie der Registry-Zweig "RIT" bei TB! Er wird immer neu erstellt, allerdings ohne die alten Einträge. So wird u.a. auch der "RegistrationBlock" fehlen. Daher vorher unbedingt sichern!


    Wenn das Einbinden danach klappt, dann lag es an irgendeinem Eintrag in der INI.

  • Zitat


    Funktioniert aber mit TB! v4.x und Vista 32-/64-Bit.


    Es freut mich, das zu hören!


    Zitat


    Die GLOBAL.INI bei Voyager ist wie der Registry-Zweig "RIT" bei TB! Er wird immer neu erstellt, allerdings ohne die alten Einträge. So wird u.a. auch der "RegistrationBlock" fehlen. Daher vorher unbedingt sichern!


    Wenn das Einbinden danach klappt, dann lag es an irgendeinem Eintrag in der INI.


    Also: An der global.ini liegt es nicht. Dieselbe Fehlermeldung tritt auch bei neuer global.ini auf.


    Nächster Versuch:


    TB! 4.1.1 Home unter Vista auf Festplatte installiert, ergibt beim Versuch, Regula zu integrieren ebenfalls eine Fehlermeldung, wenn auch mit anderem Text. Sinngemäß (hab's gleich wieder deinstalliert): "Hat entweder internes Problem oder konnte nicht als Plugin qualifiziert werden" ("..or could not qualify as plugin")


    Kannst Du daraus jetzt schließen, ob es an Vista oder Voyager liegt?


    Oder an Regula? Ich hatte den ganzen Regula-Ordner vom Stick auf die Festplatte in den Ordner Programme/The Bat/ kopiert. Die Datei regula.tbp hatte ich ja schon auf dem Stick erneuert, den Rest allerdings noch nicht.


    Noch eine Idee?

  • Zitat


    Kannst Du daraus jetzt schließen, ob es an Vista oder Voyager liegt? Oder an Regula?


    Jedenfalls aber bestimmt nicht an Voyager bzw. TB!, da die beiden Programme unabhängig voneinander funktionieren und es mit beiden nicht klappt.


    Kannst du testweise UAC abschalten, falls noch nicht geschehen?



    Zitat


    Ich hatte den ganzen Regula-Ordner vom Stick auf die Festplatte in den Ordner Programme/The Bat/ kopiert. Die Datei regula.tbp hatte ich ja schon auf dem Stick erneuert, den Rest allerdings noch nicht.


    Hast du "dpcre.dll" auch kopiert? Die Datei kann man ebenfalls von Gaijin's Seite herunterladen und soll eigentlich ins Verzeichnis "System32" kopiert werden, liegt aber z.B. bei mir im TB!-Verzeichnis. Kann daher wahrscheinlich auch einfach neben voyager.exe sein.

  • Zitat


    Kannst du testweise UAC abschalten, falls noch nicht geschehen?


    Ich hatte sie lange abgeschaltet, habe sie dann irgendwann, nachdem alles bestens eingerichtet war, aus Sicherheitsgründen nach Einrichtung eines Nicht-Administrator-Kontos wieder aktiviert. Das war aber lange vor dem Ausfall von Regula. Werde unter Abschaltung noch mal testen.


    Zitat


    Hast du "dpcre.dll" auch kopiert? Die Datei kann man ebenfalls von Gaijin's Seite herunterladen und soll eigentlich ins Verzeichnis "System32" kopiert werden, liegt aber z.B. bei mir im TB!-Verzeichnis. Kann daher wahrscheinlich auch einfach neben voyager.exe sein.


    Ja, da ist sie bei mir auch. Ich war eigentlich fast zu 100% sicher gewesen, daß sie auch unter system32 kopiert hatte. Doch da war sie jetzt nicht (mehr). Kopieren dahin hat für Voyager nichts geändert. Aber ich habe daraufhin noch mal TB auf Festplatte installiert. Da kommt zwar jetzt noch eine Fehlermeldung: "List index out of bounds (0)" - aber das Plugin startet immerhin.


    Also habe ich jetzt die Situation, daß sich das Plugin unter TB einbinden läßt, nicht aber unter Voyager. Kann Dir das einen Hinweis geben? Danke.

  • Zitat


    Da kommt zwar jetzt noch eine Fehlermeldung: "List index out of bounds (0)" - aber das Plugin startet immerhin.


    Der Fehler müsste eigentlich längst behoben worden sein, zumindest in einem anderen Zusammenhang (s. hier und Changelog hier)



    Zitat


    Also habe ich jetzt die Situation, daß sich das Plugin unter TB einbinden läßt, nicht aber unter Voyager. Kann Dir das einen Hinweis geben? Danke.


    Ein paar Vorschläge:
    - kopiere "voyager.lng" ins Voyager-Verzeichnis, dann bekommst du dt. Fehlermeldungen
    - "TBPlugin.ENI" aus ~/MAIL löschen - die Plugins werden hier gespeichert
    - aus "regula.rar" nur die Datei "regula.tbp" entpacken
    - Das AntiVirus-Tool bzw. Security Suite ausschalten - vielleicht stört es
    - UAC abschalten und ausprobieren
    - ein neues Admin-Konto mit Standardeinstellungen erstellen und es dort versuchen
    - Vista im abgesicherten Modus (F5 - nicht F8!) starten und es dort versuchen


    Letztendlich liegt es bei dir wohl an Inkompatibilität. Ich weiß, dass es mit TB! v4.x, Regula 2.2.7 und Vista 32-Bit keine Probleme gibt - habe selbst ausprobiert. Doenerbude hat geschrieben, dass das Plug-in bei ihm auch unter 64-Bit läuft. Wie das aber mit Vista und Voyager steht, weiß ich leider nicht.


    Ich habe jetzt testweise das Plug-in problemlos unter XP in Voyager einbinden können. Zuerst habe ich "dpcre.dll" vergessen, bekam aber die Meldung, dass diese Datei fehlt und danach eine zweite, die du oben erwähnt hast, dass es sich nicht um ein Plug-in handeln könnte (s. Screenshots).


    Daraufhin habe ich "dpcre.dll" ins Voyager-Verzeichnis kopiert, wo also auch voyager.exe liegt, und konnte das Plug-in problemlos einbinden. Außer der TBP habe ich nichts entpackt. Zum Einbinden braucht man also nur "regula.tbp" und "dpcre.dll".

  • Zitat


    Ein paar Vorschläge:
    - kopiere "voyager.lng" ins Voyager-Verzeichnis, dann bekommst du dt. Fehlermeldungen


    Danke, das habe ich bereits. Die engl. Meldung kam nur in der Testinstallation auf Festplatte.


    Werde ich bei Gelegenheit durchgehen. Falls klar wird, woran es liegt, werde ich es hier mitteilen.

    Zitat


    Letztendlich liegt es bei dir wohl an Inkompatibilität. Ich weiß, dass es mit TB! v4.x, Regula 2.2.7 und Vista 32-Bit keine Probleme gibt - habe selbst ausprobiert. Doenerbude hat geschrieben, dass das Plug-in bei ihm auch unter 64-Bit läuft. Wie das aber mit Vista und Voyager steht, weiß ich leider nicht.


    Ich habe jetzt testweise das Plug-in problemlos unter XP in Voyager einbinden können


    Ja, XP machte überhaupt weniger Probleme :cool:


    Nochmal Dank für Deine Mühe.