Beiträge von sotel

    So, nach einiger Zeit mal wieder ein post:


    nach dem Wechsel der Major-Release Nummer von neun auf zehn habe ich lange gehadert, ob ich dem folge. Zumal auch diese fixe Idee, TheBat! nach dem kaputten App-Modell von Microsoft zu folgen, zu Verschlimmbesserungen führten. Da aber die RitLaboranten wohl auch der (Gegen-)Wind ins Gesicht blies und sie sich doch als sehr lernfähig zeigten, habe ich mich mit KMail aus dem KDE-Paket beschäftigt und mal meine Kosten analysiert, die sich bei einem Wechsel von TheBat! zu KMail wohl ergeben würden. Mein Resultat: von den Kosten für meinen Aufwand kann ich mir 128 (in Worten: einhundertachtundzwanzig!) Lizenzen von TheBat! kaufen. Das hätte sich somit amortisiert, wenn RitLabs die Version 118.x.x veröffentlicht.


    Also hab ich eine neue Lizenz gekauft, und deshalb sind jetzt aktuell die Version v10.0.5 (32bit und 64bit, jeweils die NAU-Version) im Test. Als daily work application bleibt vorerst v9.5.1.0 32bit in Gebrauch.

    Und wenn ich mal von den bekannten Fehlern absehe, dann läuft die Installation doch zufriedenstellend. Also folgt hier demnächst ein ausführlicherer Bericht...

    Ich versuche immer wieder, mein Profil aktuell zu halten.


    Doch wenn ich da etwas mit Hilfe des Board-internen Editors eingebe, zersägt der Editor meine vorherige Eingaben, zerstört das Layout - Aufzählungslisten stehen dann in einer Zeile, Text, der bisher in normaler Schrift dort stand, ist dann fett und weitere Scherze.

    Noch schlimmer wird es, wenn ich da statt des Eintippens gar die Dreistigkeit habe, fertiges HTML einzufügen (in der Quellcode-Eingabe):

    ich habe dazu ein Shell-Script (tb_getinfo.sh) geschrieben, das diese Informationen zusammenstellt und HTML-gerecht aufbereitet. Hat immer hervorragend funktioniert, doch seit einiger Zeit mag das der Editor so gar nicht und haut mir die komplette Formatierung um die Öhrchen. Unf fügt völlig wild leere <strong></strong>-Tags in den Profil-Text rein...


    Is' einfach nur nervig.


    Das ist übrigens seit einem Update der Boardsoftware so...

    (Wenn ich mich recht entsinne... Welches Update? Keine Ahnung...! Ist schon eine Zeit, Jahre(?), her...)


    Hat bisher nicht gestört, aber irgendwann ist mal gut mit dem Murks....

    v9.5.1 müsste dann doch auch direkt unter Windows 10 nicht funktionieren.

    Nope.


    Zitat

    Wine (ursprünglich ein Akronym für "Wine Is Not an Emulator") ist eine Kompatibilitätsschicht, die es ermöglicht, Windows-Anwendungen unter POSIX-konformen Betriebssystemen auszuführen, wie z.B. Linux, macOS und BSD. Statt interne Windows-Logik zu simulieren, wie eine virtuelle Maschine oder ein Emulator, übersetzt Wine die Windows-API-Aufrufe in Echtzeit zu entsprechenden POSIX-Aufrufen und eliminiert somit die Performance- und Speichereinbußen, die andere Methoden nach sich ziehen. Wine erlaubt es auf diese Weise, Windows-Anwendungen sauber in Ihre Desktopumgebung zu integrieren. (...)


    Quelle: Über Wine

    WARNUNG!


    Bei der aktuellen wine-Version v7.4 vom 11. März 2022 funktioniert The Bat! v9.5.1.0 nicht mehr:

    Es lässt sich zwar installieren (mit msiexec), startet, aber wichtige Funktionen, z.B. Adressbuch etc. funktionieren nicht. d.h. dass das Adressbuch erst gar nicht geöffnet wird.


    Ein möglicher Grund ist zum Beispiel dieser Bug hier:

    The Bat! v9.3.4.12: Missing content in TTreeViews on Windows versions higher than 8


    Ältere wine-Versionen, z.B. die Vorversion v7.3 funktionieren, wenn man die Windows-Version innerhalb von wine auf Version 8 setzt. Steht auch so in der Bug-Beschreibung und der Intallationsanleitung für TheBat! auf wine.


    Neuere TheBat!-Versionen habe ich nicht getestet.


    WARNUNG!

    Was heißt möglicherweise? Gibt es nähere Infos, welche Drittprogramme betroffen sind?

    The Bat! z.B.


    Auch ich habe ein App-spezifisches Passwort für einige GMail-Accounts angelegt und auch die weniger sichere Authentifizierung (Original-GMail-Text) für diese Konten bei Googles-Accounteinstellungen ausgewählt. Bei diesen Konten hab ich vor einer Woche diese E-Mail bekommen:



    Da ich eigene Domains habe, über die mein kompletter Mailverkehr läuft und die GMail-Adressen nur so "mitlaufen" lassen und kaum benutze, bin ich mal gespannt, was da genau passieren wird....

    Wenn man dieses RitLabs-Geraffel mal ein wenig unter die Lupe nimmt, und wirklich alles händisch installiert, dann geht es irgendwie....

    Also nichts für Anfänger:innen.


    Aber so langsam verliere ich die Lust daran, den RitLaboranten hinterher zu rennen. Und dieses neue Verfahren, das man sein *wohlgemerkt* bezahltes Programm nur dann nutzen kann, wenn man sich online anmeldet, ist inakzeptabel.

    Prinzipiell bevorzuge ich Open-Source-Software: TheBat! war bei mir eine jahrelange Ausnahme, weil ich das Konzept hinter den Features von TheBat! noch so gerade eben hinnehmen konnte.

    Das hat sich schlagartig durch die Einführung der Online-Kontrolle geändert.


    Und KMail hat sich von einem Versuchsprogramm zu einem vollwertigen Mail-Client inkl. Makros gemausert.

    Wenn es also demnächst: Ich bin dann mal weg! heißt, dann wisst Ihr, was die Stunde geschlagen hat.

    Und für ganz experimentierfreudige: KDE, und damit KMail gibt es auch für Windows...!


    Und auch schon altgediente Recken aus der Beta-Liste, z.B. MAU und Gunivortus verlassen die TheBat!-Bühne...

    Der Web-Browser Firefox zeigt mir mit CTRL-J die Liste meiner Downloads, über die ich den genauen Speicherord ersehen kann, wohin ich die Datei runtergeladen habe, und diese direkt öffnen.


    Die Fledermaus gibt mir diese Information leider nicht.

    Keine Ahnung, wovon Du hier sprichst! Und vor allem nicht, was Dein Anliegen ist.

    Wenn ich etwas herunterladen will, dann nehme ich einen Webbrowser und nicht ein Mail-Programm oder Word oder sonstwas!

    Also wäre ein konkretes Beispiel hier sehr hilfreich.


    Ich muß mich dann durchs Dateisystem zu dem Zielverzeichnis navigieren, in das ich in der eMail enthaltene Dateien abgespeichert habe.

    Arbeitest Du mit Windows? (Blöde Frage, sonst hättest Du kein TheBat!, aber nur zur Sicherheit gefragt...)


    Mal angenommen, Du sprichst hier von einer Dateianlage / Attachment, dann wird TheBat! genau den Ordner zum speichern nutzen, den Du bei der letzten Aktion benutzt hast, d.h. um heraus zu finden, wo du beim letzten Mal gespeichert hat, ruf einfach diesen Dialog erneut auf und TheBat! zeigt dir, welcher Ordner das ist. Den zuletzt verwendeten Download-Ordner findest Du auch in der Registry:

    HKEY_CURRENT_USER\Software\RIT\The Bat!, im REG_SZ-Schlüssel: Last save path Unicode.


    Per CMD[.exe] wäre das dann: reg query "HKCU\Software\RIT\The Bat!" /v "Last save path Unicode"


    Ferner ist es sinnvoll, z.B. den Windows-Ordner "Downloads", der bei der Windows-Installation in %userprofile%\Downloads also: C:\Users\<username>\Downloads angelegt wird, für solche Zwecke zu nutzen. Oder in einem anderen Ordner, aber eben immer in dem selben.


    prä-Historie der eMail, wo nach UUCP-Standard Teile

    Ja, und bei meinem CrossPoint konnte ich auch konfigurieren, wo es diese Anhänge ablegt...


    Bei TheBat! kannst du diesen Ordner ebenfalls konfigurieren:



    Wolltest Du das erreichen?


    Wenn Du allerdings ranten wolltst, dann mach das doch bitte bei RitLabs direkt, bzw. in deren Ressourcen.

    Dieses Forum ist dazu wohl eher weniger geeignet.

    Hallo Fledermäuse@Pinguine!


    WARNUNG!


    Bei den aktuellen MSIs vom 18. Februar 2022, Version v10.1 BETA, funktioniert weder die 32bit-Version noch die 64bit-Versionen unter wine!

    Es läßt sich zwar installieren (mit msiexec), aber es startet nicht.


    Die Gründe sind noch unbekannt.


    WARNUNG!

    Ja, genau der!



    sanyok Oh, das ist mein gemeldeter Bug. Leider ist das Problem ungefixt.

    Oh, ich hatte gedacht, der sei schon erledigt. Ich erinnere mich noch schwach, das jemand von Ritlabs sich dazu in der TBBeta-Liste geäußert hat, bin mir aber unsicher, ob das dieser Bug war....


    sotel Bitte, bestätigst du den o.g. Bug auch im Ritlabs-Tracker?

    Aber klar doch, schon erledigt!

    Hallo Leute!


    Ich suche nach dem Bug im Ritlabs Bugtracker, der sich mit dem Popup über einer URL im Vorschaufenster befasst hat. Ritlabs hat da etwas hingedoktert, aber das steht mir jetzt im Wege...


    Keine Ahnung wovon ich rede?


    Hiervon:


    Und das ist mein Problem:


    Ich komme so nicht an den Link dran, d.h. ich kann weder drauf klicken (ist eh bedenklich) noch kann ich die URL kopieren.

    Und im nur-Text-Teil der Mail ist auch nicht immer der selbe Link zu finden, meistens gar nicht.


    Aber wenn ich mich recht erinnere, gabs dazu einen Eintrag im bugtracker. Könnt ihr mir helfen, und kurz den Link zu dem Bug posten?


    Schon mal vielen Dank an alle!