Neue Funktionen
• Autocrypt Level 1 – Automatische E-Mail-Verschlüsselung mit Verwaltung der Schlüssel von Kommunikationspartnern und Empfehlungen beim Versand
• Markdown-Anhänge: Dateien mit den Endungen .md und .markdown werden als text/markdown erkannt und in der Konversationenansicht als Markdown dargestellt
• Neuer Befehl "Bild kopieren" im Kontextmenü der Konversationenansicht und des HTML-Nachrichtenbetrachters
• Der Schlüsselmanager kann jetzt Unterschlüssel zu einem bestehenden OpenPGP-Schlüssel hinzufügen
• Erstellung von ECDSA-/ECDH-Unterschlüsseln (NIST P-256) für bestehende OpenPGP-Schlüssel
• Erstellung von Widerrufszertifikaten für OpenPGP-Schlüssel und Unterschlüssel
• Intelligente Auswahl des passenden Kontos
• Unterstützung für IMAP NOTIFY (RFC 5465): Eine einzige Überwachungsverbindung beobachtet nun alle Postfächer auf Änderungen
• Unterstützung für IMAP UID MOVE (RFC 6851): Nachrichten werden serverseitig atomar verschoben, ohne dass vorübergehend Duplikate entstehen
• OpenPGP-Schlüssel werden jetzt in einer transaktionssicheren SQLite-Schlüsseldatenbank (keyring.db) gespeichert und bei Bedarf geladen
• Textanhänge werden automatisch auf eingebettete OpenPGP-Blöcke überprüft. Schlüsselimport, Entschlüsselung und Signaturprüfung sind dadurch mit einem Klick möglich
• Beim Verschlüsseln wird jetzt immer auch der Schlüssel der Absender einbezogen, sodass die Kopie im Ordner "Versandt" lesbar bleibt
• Unterstützung für PDF-Signaturen: Signaturen prüfen, signieren und antworten sowie signieren und speichern
• Die Funktionen "Verschlüsseln" und "Signieren" stehen jetzt auch in der Schnellantwort der Konversationsansicht zur Verfügung. Die Voreinstellungen werden aus den Kontoeinstellungen übernommen
• Wenn eine Nachricht mit mehreren geheimen Schlüsseln entschlüsselt werden kann, wird jetzt ein Dialog zur Schlüsselauswahl angezeigt
• Unterstützung für die Entschlüsselung von Nachrichten mit ausgeblendeten Empfängern (gpg --throw-keyids, Wildcard-Key-IDs)
• Der Befehl "Öffentlichen Schlüssel kopieren" kopiert im OpenPGP-Schlüsselmanager den öffentlichen Schlüssel des ausgewählten Eintrags in die Zwischenablage
• Der Schlüsselmanager wird jetzt als nicht-modales Fenster geöffnet und blockiert weder die Bedienung des Programms noch dessen Beenden
Verbesserungen
• Das Zielverzeichnis beim Kopieren oder Filtern wird jetzt inkrementell aktualisiert, anstatt die Ordnerliste vollständig neu einzulesen
• Verbesserte Kontrastdarstellung der Textauswahl in der reinen HTML-Ansicht bei Verwendung des dunklen Designs
• Die automatische Entschlüsselung beim Öffnen einer Konversation in der Konversationenansicht wurde wiederhergestellt. Die Entschlüsselung erfolgt ausschließlich im Hintergrund mit bereits entsperrten Schlüsseln und ohne Benutzerrückfragen
• Beim Antworten auf verschlüsselte Nachrichten ist die Verschlüsselung im Editor jetzt standardmäßig aktiviert
Fehlerbehebungen
• Der Fehler, bei dem alle iCloud-Kalendertermine auf denselben Zeitpunkt zusammenfielen (CalDAV multiget hrefs), wurde behoben
• Der Fehler, bei dem die Synchronisierung mit iCloud CalDAV bei Server-URLs ohne Pfadangabe mit 400 Bad Request fehlschlug, wurde behoben
• Der Fehler, bei dem CEF-/HTML-Ansichten deaktiviert wurden, wenn The Bat! mit Administratorrechten ausgeführt wurde, wurde behoben
• Die Zoom-Funktion steht jetzt auch im Nur-Text-Editor sowie in der CEF-Konversationenansicht zur Verfügung
• Ausnahme beim Antworten aus dem Nachrichtenlistenfenster des MailTickers wurde behoben
• Fehler bei Kalenderantworten mit falsch zitiertem Empfänger wurde behoben
• Markierte Menüeinträge waren im hellen Design von Windows 11 nicht sichtbar
• Schriftfarbe für Farbgruppen in der Ordnerliste wurde korrigiert
• Schaltflächen der Editor-Symbolleiste waren im dunklen Design unsichtbar
• Barrierefreiheit: Unterstützung für Screenreader (NVDA) unter Win64 wurde wiederhergestellt
• Barrierefreiheit: Trennzeilen zwischen Datumsgruppen werden nun von Screenreadern angesagt
• Der Fehler, bei dem den IMAP-Betreff-, Absender-, Empfänger-, CC- und BCC-Felder fehlerhaft dargestellt wurden, wenn Server UTF-8-Rohdaten im ENVELOPE-Format zurücklieferten (RFC 9051/6855/6532), wurde beseitigt
• Der Fehler, bei dem die Textanhänge mit Nicht-ASCII-Zeichen in der Vorschau der Konversationenansicht mit fehlerhafter Zeichenkodierung angezeigt wurden, wurde behoben. Sie werden jetzt korrekt nach UTF-8 dekodiert
• Fehler bei der automatischen Ersetzung des Gedankenstrichs im HTML-Editor wurde behoben
• Gesendete Nachrichten werden jetzt immer zusätzlich mit dem eigenen Schlüssel verschlüsselt – auch dann, wenn zum Signieren der Standardschlüssel verwendet wird
• Bei der Entschlüsselung werden jetzt alle passenden Schlüssel ausprobiert, anstatt den Vorgang nach der ersten abgebrochenen Passphrase-Eingabe zu beenden
• Der Verschlüsselungsdialog zeigt jetzt den tatsächlichen Grund an, warum eine Nachricht für einen bestimmten Empfänger nicht verschlüsselt werden kann
• Beim Antworten auf verschlüsselte Nachrichten wird jetzt der entschlüsselte Nachrichtentext zitiert
• Der Fehler wurde behoben, bei dem der Passphrase-Dialog die eingegebene Passphrase verwarf und nach einem Abbruch den falschen Schlüssel auswählte
• Fehlerhafte Zeichendarstellung in entschlüsselten Inline-PGP-Nachrichten der Konversationenansicht wurde behoben (UTF-8 wurde fälschlich mit der Systemcodepage dargestellt)
• Symbole für Verschlüsselung und Signaturen in der Konversationenansicht wurden wiederhergestellt
• Das Trennzeichen zwischen Datum und Uhrzeit geht beim Wiederherstellen aus einer Sicherung nicht mehr verloren
• Ausnahme wurde behoben, die nach der Vorschau einer ICS-Datei, dem Löschen der E-Mail und dem Wechsel in einen anderen Ordner auftreten konnte
• Der Fehler im OAuth-Anmeldeverfahren für Outlook.com und Microsoft 365 wurde behoben