Backup_Batch - Probleme

  • Habe Backup_Batch versucht zu benutzen. Habe das Programmverzeichnis korrekt eingetragen und auch das Ziel- = Backup-Verzeichnis korrekt eingetragen.


    Beim Doppelklick auf die Backup.bat blitzt kurz die DOS-Box auf und man kann wenn man gut ist den Text "Kann Datei backup.bat nicht finden" lesen...


    Sonst passiert nix.


    Habe NT4.0 SP6


    Wohin muß ich mich verneigen damit das blöde Prog das tut was es soll ?? :- )

  • Vielleicht hilft dir ja, wenn du über -Start - Ausführen gehst und dort "cmd" eingibst.


    Dann kannst du über das Eingabe-Fenster die Backup.bat ausführen und siehst vielleicht mehr Fehler.


    2) Hast du in einem der angegebenen Pfade Leerzeichen drin? Wenn ja muss der komplette Pfad in "" gesetzt werden.

  • Danke,...aber das funktioniert auch nicht !


    Der Text der in der DOS-Box kommt lautet : "Die Datei backup.dat kann nicht gefunden werden"


    Man achte auf die Endung : "dat" *?*


    Das einzige was ich in der backup.batch an "dat" finde ist DER Eintrag hier :


    :: Datum der letzten Sicherung speichern
    :: echo %DATE%>backup.dat


    Meint der DIE backup.dat ??


    Wenn ja, wo soll die denn stehen ??

  • Wenn ich das Programm jetzt richtig verstanden habe, dann fehlt dir im Backverzeichnis die Datei backup.dat.


    Dort wird das Datum der letzten Sicherung gespeichert.
    Einfachste Lösung ist die Datei (leer) dort manuell zu erstellen.


    2. Lösung beim 1. Start des Programm den Befehl am Start unter "Heutige Sicherung schon durchgeführt?" nicht durchzuführen indem er mit einem REM auskommentiert wird.


    3. Lösung (etwas Eigenwerbung) :pfeif:
    Versuch es hier: ->
    Hat aber leider knapp 10MB.
    ->
    Vielleicht klappt aber schon diese kleinere Version.

  • Mit den 10 MB warte ich erstmal noch... :- )


    REM ? Wo und wie muß ich das denn da reinschreiben ? Habe keine Ahung von solchem Fachchinesisch... :- )


    Vieleicht sollt´ ich mir auch einfach nen Programm suchen das funktioniert...

  • Bernd
    Es geht um das Backup-Tool was ich mal erstellt habe, wenn ich mich nicht sehr irre, war auch der letzte Eintrag dort von dir ;)


    @Margot
    die 10MB sind leider notwendig, da das Programm eine Datenbankkomponente benötigt, die nicht auf jedem Rechner installiert ist.
    Ansonsten einfach mal mit der anderen Version erst probieren.


    Zur zweiten Frage, du hast doch in der Backup.bat die beiden notwendigen pfade ergänzt, oder?


    um den ersten Befehl zur Suche nach der Backup.dat zu umgehen musst du vor die beiden Zeilen am Anfang der backup.bat jeweils rem schreiben. Damit werden diese Zeilen beim Ablauf ignoriert.


    Wenn Bernd nicht schneller ist und noch interesse besteht, kann ich ja heute abend mal die Datei bearbeiten und per PM verschicken.

  • Cerberus: Keine Ahnung. Ich hab mich nur gewundert, was daran 10 MB groß ist. Immerhin ist selbst die TheBat-Install um einige MB kleiner ;)


    Naja, ich hab einfach immer mein TB-Verzeichnis gepackt und die Sache war für mich erledigt. Machte keine Probleme und hat immer funktioniert :D


    @Margot: In der FAQ steht eine Anleitung wie man ein Backup macht. Registry muss man ja nicht jedes mal mit sichern...

  • @ Bernd
    Die 10MB sind wirklich etwas heftig, werden aber auch nur im Ausnahmefall benötigt.
    Das sind Pakete wie MDAC für den Datenbankzugriff drin.


    Das Tool ist eigentlich auch mehr für Personen gedacht, die sich mit bat-Dateien nicht auskennen aber sonst keine Gedanken machen wollen.
    Grafische Oberflächen sind ja leider immer mehr im kommen :denk: