[Bug] Vorlagen in Filter funktionieren nicht

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • [Bug] Vorlagen in Filter funktionieren nicht

    Dieser Filter soll für Eingehende Nachrichten mit dem Betreff GETKEY ausgeführt werden.
    Aber es wird gar keine Automatische Antwort erzeugt.

    Quellcode

    1. $$$$ TB! Message Filter $$$$
    2. beginFilter
    3. UID: [902752CC.01CF711E.6B4587D9.01380F42]
    4. Name: GETKEY
    5. Filter: {\0D\0A\20`21\0D\0A0`2`0`GETKEY\0D\0A}
    6. Reply template Anbei\20der\20gewünschte\20Schlüssel.\0D\0A\0D\0A%INCLUDE\3D\22%MAILDIR\5Cgwendragon-sig.txt\22\0D\0A\0D\0A%INSERTPGPKEY\3D\22info@gwendragon.de\22\0D\0A%PGPMIME\0D\0A%SIGNCOMPLETE
    7. IsActive
    8. Ignore
    9. endFilter

    Natürlich müsst ihr den Filter anpassen, eine eigene Datei einbinden und einen eigenen PGP-Schlüssel, um zu testen ;)

    Nachvollziehbar?
    Lösung?
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von GwenDragon () aus folgendem Grund: Tags hinzugefügt

  • Ich habe jetzt mal die Filterdatei ACCOUNT.SRB gelöscht, um sicher zu gehen, dass da keine kaputten Filter waren.

    Selbst sowas einfaches als Automatische Antwort klappt nicht!

    Quellcode

    1. $$$$ TB! Message Filter $$$$
    2. beginFilter
    3. UID: [5A15F473.01CF7131.03548140.314FC842]
    4. Name: Antwort
    5. Filter: {\0D\0A\20`2`0`TEST\0D\0A}
    6. Reply template aaaaaaaaaaaaaaaaaaaaaa\0D\0Aam\20%ODate\20um\20%OTime\20schriebst\20Du:\0D\0A\0D\0A%Quotes\0D\0A send
    7. IsActive
    8. Ignore
    9. IsSendNow
    10. endFilter


    Wenn das Mail eintrifft wird nix erstellt.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • GwenDragon schrieb:

    Dieser Filter soll für Eingehende Nachrichten mit dem Betreff GETKEY ausgeführt werden.
    Aber es wird gar keine Automatische Antwort erzeugt.

    Dieser tut hier - naja, außer der Signatur... Aber er filtert auf die Adresse, nicht auf den Betreff.

    Quellcode

    1. $$$$ TB! Message Filter $$$$
    2. beginFilter
    3. UID: [ADB21B4B.01CF7039.28B87D2F.51A2EFED]
    4. Name: Moneo\20Atreides
    5. Filter: {\0D\0A\20`1`0`getpgpkey@example.de\0D\0A}
    6. CreateFormatted NoAttach template %ACCOUNT\3D\22Strato\22%-\0D\0A%TO\3D\22%OFROMNAME\20<%OFROMADDR>\22\0D\0A%SUBJECT\3D\22Mein\20OpenPGP\20Key\207D67BDFE\22\0D\0A%PGPMIME%-\0D\0A%SIGNCOMPLETE%-\0D\0A%ATTACH\3D\22Y:\5CGPG\5C20140515_GPG_Key.asc\22\0D\0AHallo\20%OFROMNAME,\0D\0A\0D\0ADu\20hast\20mit\20Deiner\20Mail\20meinen\20öffentlichen\20OpenPGP\20Schlüssel\20angefordert.\0D\0A\0D\0ADu\20findest\20ihn\20im\20Anhang\20dieser\20Mail.\0D\0A\0D\0A--\20\0D\0AViele\20Grüße\0D\0AMoneo\20Atreides\0D\0A\0D\0A folder \5C\5CStrato\5COutbox
    7. IsActive
    8. Ignore
    9. IsSendNow
    10. endFilter
    Schönen Tach ooch noch!
    MoNeo
    The Bat! Professional Edition 32-bit, 7.2 final, auf Windows 7 (64-bit) Pro (Build 7601) und Win10 64-bit,
    AntiSPAMSniper und Nutzer von Bernds nahezu genialen "Mehrsprachigen Vorlagen" & XMP

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von MoNeo ()

  • Ich glaube langsam, über die Jahre ist irgendwas in manchen Mail-Konten beim Upgrade The Bat!s verbockt worden.
    Selbst sowas einfaches klappt nur bei neu erstellten Konten! Nicht bei alten Bestandskonten.

    Quellcode

    1. $$$$ TB! Message Filter $$$$
    2. beginFilter
    3. UID: [107F76B7.01CF71BD.1D12E8A8.5A996D4A]
    4. Name: Test
    5. Filter: {\0D\0A\20`2`0`TEST\0D\0A}
    6. Reply template \3D\3D\3D\3D\20TEST\20TEST\20TEST\20TEST\20\3D\3D\3D\3D\0D\0A\0D\0AHello\20%OFROMNAME,\0D\0A\0D\0Aat\20%ODate\20%OTime\20you\20wrote:\20\20\20\20\0D\0A\0D\0A%Quotes queue
    7. IsActive
    8. Ignore
    9. IsSendQueue
    10. endFilter


    Selbst in 5.8.8 und 6.3.4 udn 6.4 klappt es nicht.
    Ich habe jetzt mal ein Ticket an Ritlabs abgesetzt.

    Andere Filter wie z. B. Verschieben von Nachrichten in andere Ordner, Priorität ändern, als Geparkt markieren, laufen.
    Alles sehr merkwürdig.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von GwenDragon ()

  • GwenDragon schrieb:

    Nachvollziehbar?
    Lösung?
    Bei mir klappt es mit diesem ersten Filter. Automatische Nachricht wird erstellt, wenn in der empfangenen Nachricht im Betreff "GETKEY" steht. Zusätzlich habe ich nur "Mit anderen Filtern fortfahren" aktiviert.

    Hast du ihn auch in anderen Konten und mit anderen Nachrichten getestet? Für den Test reicht es übrigens aus, wenn man eine Nachricht mit dem o.g. Betreff in den Eingangsordner legt und dann "Erneut filtern" wählt.
  • GwenDragon schrieb:

    Ich habe die Konten restauriert nach der Methide, die mse in POP3-Konten restaurieren, weil Filter nicht mehr funktionieren vorschlug.
    Wie ist es, wenn du ein Konto sicherst, löscht und dann ein neues mit dem gleichen Namen erstellst, jedoch nichts wiederherstellst und hineinkopierst? Also Mailkonto mit Standardeinstellungen und ohne PGP/GPG etc. Einfach den einzigen o.g. Filter erstellen bzw. einfügen und, wie oben beschrieben, eine Test-Mail in den Eingang kopieren und diesen erneut filtern. Wenn es jetzt klappt, dann kannst du die Daten schrittweise nach dem trial and error Prinzip wiederherstellen. Irgendwann wirst du den Fehler entdecken.
  • So, ich habe nur die Ordner kopiert. Leider findet Ctrl Alt Shift L nicht alle Ordner! Da fehlen dann zwei, die werden nicht angezeigt.

    Problem eingegrenzt: es ist irgendwas in der Original-ACCOUNT.CFN.
    Vermutung: es sind meine Konten-Vorlagen, bei denen das Filtern und Erstellung einer automatischen Antwort nicht klappt.

    Und wie kann ich nun weiter vorgehen zum Testen?
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • GwenDragon schrieb:

    Vermutung: es sind meine Konten-Vorlagen, bei denen das Filtern und Erstellung einer automatischen Antwort nicht klappt.

    Du kannst doch den Ordner angeben, in dem die Mail abgelegt wird - die dortige Ordnervorlage sollte die Kontovorlage eigentlich aushebeln.
    Schönen Tach ooch noch!
    MoNeo
    The Bat! Professional Edition 32-bit, 7.2 final, auf Windows 7 (64-bit) Pro (Build 7601) und Win10 64-bit,
    AntiSPAMSniper und Nutzer von Bernds nahezu genialen "Mehrsprachigen Vorlagen" & XMP
  • MoNeo schrieb:

    Du kannst doch den Ordner angeben, in dem die Mail abgelegt wird - die dortige Ordnervorlage sollte die Kontovorlage eigentlich aushebeln.
    Mit Filter bei bestimmtem Betreff In den Ordner verschieben geht ja. Aber es funktioniert nicht mit der Aktion Automatische Antwort erstellen :(

    Ich arbeite mit Makros ja auch schon seit The Bat! 2.x ;)
    Aber irgendwie ist das vertrackt.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von GwenDragon ()

  • GwenDragon schrieb:

    Mit Filter bei bestimmtem Betreff In den Ordner verschieben geht ja. Aber es funktioniert nicht mit der Aktion Automatische Antwort erstellen

    Hmmm, also bei meinem oben angegebenen Filter hat das Konto auf dem die Mail eingeht (CatchAll) keine eigene Vorlage, das Konto von dem aus die Mail dann versendet werden soll (wird) hat die mehrsprachigen Vorlagen von Bernd im Bauch. Diese wird allerdings von der im Filter mitgegebenen Vorlage übersteuert.

    Wenn mich nicht alles täuscht, gibt es doch eine Definition der Reihenfolge, welche Vorlage wann gezogen wird. Und da geht speziell vor allgemein - so war das zumindest noch vor 5 Jahren, wenn mich die Demenz nicht schon zu sehr im Griff hat... IMHO steht dazu sogar was in der Hilfe (hab hier kein TB! - kann ich aber abends mal suchen).
    Schönen Tach ooch noch!
    MoNeo
    The Bat! Professional Edition 32-bit, 7.2 final, auf Windows 7 (64-bit) Pro (Build 7601) und Win10 64-bit,
    AntiSPAMSniper und Nutzer von Bernds nahezu genialen "Mehrsprachigen Vorlagen" & XMP
  • Ja, wie wann welche Vorlage genommen werden, die Reihenfolge ist mir klar.

    Ritlabs Support kanns auch nicht nachvollziehen. Ich werde die trotzdem weiter löchern.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • Tja, liebe Leute, warum's bei mir nicht geht.

    Aus Irgendeinem Grund wollen Makros da in der Antwortvorlage nicht so Recht.
    Damit es mit einer Antwortvorlage klappt,
    1. darf NICHT in den Optionen des Kontos Nachricht Digital SIgnieren gewählt sein
    2. darf die Antwortvorlage im Filter KEINE %INCLUDE oder %QINCLUDE beinhalten, andere Makros wie %Quotes funktieren teilweise auch nicht
    Habt ihr das auch?
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von GwenDragon () aus folgendem Grund: Text umgestellt

  • GwenDragon schrieb:

    Es darf nicht in den Optionen des Kontos Nachricht Digital SIgnieren gewählt sein

    Du meinst, wenn das generelle Signieren im Konto aktiviert ist und ich in der Vorlage noch einmal sage, dass signiert werden soll, passiert - nix?! Negation der positiven Addition, oder was? 8| Bin völlig verwirrt - probier ich demnächst aus.
    Schönen Tach ooch noch!
    MoNeo
    The Bat! Professional Edition 32-bit, 7.2 final, auf Windows 7 (64-bit) Pro (Build 7601) und Win10 64-bit,
    AntiSPAMSniper und Nutzer von Bernds nahezu genialen "Mehrsprachigen Vorlagen" & XMP
  • MoNeo schrieb:

    Du meinst, wenn das generelle Signieren im Konto aktiviert ist und ich in der Vorlage noch einmal sage, dass signiert werden soll, passiert - nix?!
    Es reicht, wenn im Konto eingestellt ist, dass signiert werden soll, in der Vorlage brauchts ja dann nicht drin sein, weil das globale greift. Dann wird keine Antwort erstellt.
    The Bat! Pro 8.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.
  • Für die Filteraktion "Automatische Antwort erstellen" wird eine eigene Vorlage verwendet, die vor allen anderen Vorrang hat. Daher kann es keine Überschneidung oder gegenseitige Störung o.ä. geben.

    Ich habe jetzt den Filter nochmals getestet. In den Kontoeigenschaften ist die Option "Nachricht digital signieren" aktiviert. In der o.g. Vorlage stehen bei mir u.a. die Makros %INCLUDE, %SIGNCOMPLETE und %QUOTES. Die Antwort wird immer automatisch generiert, wenn in der Betreffzeile der Originalnachricht GETKEY steht, und alle Makros werden ausgeführt. Alles funktioniert also. Getestet mit v6.4.0.5 32-Bit.


    GwenDragon schrieb:

    Da fehlen dann zwei, die werden nicht angezeigt.
    Ist wahrscheinlich nicht so tragisch, da man die beiden auch manuell erstellen und die TBBs hineinkopieren kann.


    GwenDragon schrieb:

    Problem eingegrenzt: es ist irgendwas in der Original-ACCOUNT.CFN.
    Die Datei löschen und die Kontoeigenschaften neu einrichten, z.B. anhand der vorgefertigten Screenshots von den alten Kontoeigenschaften.


    GwenDragon schrieb:

    Vermutung: es sind meine Konten-Vorlagen, bei denen das Filtern und Erstellung einer automatischen Antwort nicht klappt.
    S.o. Es kann bei dieser Filteraktion keine Überschneidung mit den Kontovorlagen geben.