OpenPGP: Warum muss ich zweimal das Passwort eingeben

  • Moin GwenDragon

    bin gerade drauf gestoßen, hatte damals schon versucht mit TheBat zu verschlüsseln, es funtioniert auch teileweise ganz gut zumindest in eine Richtung, also von mir zum Arbeitgeber. Dort wird sie entschlüsselt :) im Grunde schreibe ich anderes herum eher selten. Frage: jedes Mal wenn ich eine Mail verschlüssele muss ich passwort eingeben, das ist okay, nur warum muss ich nochmals mit der empfängermail bestätigen? oder kann man das irgendwo abklicken?

    theBat 9.32 64Bit

    Kleopatra

    Version 3.1.11-Gpg4win-3.1.11


    Modedit: Abgeteilt von Umfrage zum Umfang der Benutzung von OpenPGP in The Bat!

  • Bei OpenPGP ist das Passwort für die Signatur der Mail mit deinem Absenderschlüssel da.

    Zur Verschlüsselung brauchst du keines, nur den öffentlichen Empfängerschlüssel.

    Bei der Signatur eines Mails wird bei mir aber nur einmal das Passwort abgefragt.

    Zum Entschlüsseln des Mail vom Empfänger brauchst du dein Passwort des Schlüssels deiner Empfängeradresse.


    Ich kann das gerade nicht besser erklären.

    https://www.heise.de/ct/artike…lung-mit-PGP-4006652.html


    Allerdings solltest du schon in Optionen > OpenPGP > Einstellungen schauen, dass dort in der Karte Allgemein unter Verschlüsselung und Signaturangehakt folgendes ist: [x] Immer mit Standardschlüssel verschlüsseln.
    Wenn nicht, dann bekommst du später die gesendeten Mail nicht mehr selbst angezeigt.

    Das Passwort wird auch zwischengespeichert, das kannst du in der selben Karte unter Passwortphrase-Caching für Entschlüsselung und Signatur einstellen.

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    4 Mal editiert, zuletzt von GwenDragon ()

  • GwenDragon

    Hat den Titel des Themas von „Warum muss ich zweimal das Passwort eingeben“ zu „OpenPGP: Warum muss ich zweimal das Passwort eingeben“ geändert.
  • Das, was Gwen geschrieben hat, kontrolliere bitte zuerst.


    Ich hatte das Problem mit einer zweifachen Passwortabfrage auch schon mal in meiner Windows-Referenzinstallation, dort mit zwei unterschiedlichen Dialogen:

    1. zuerst hat mich The Bat! nach dem Passwort gefragt
    2. dann fragte GnuPG ("Pinentry") ebenfalls nochmal nach.

    Meine Lösung:

    GnuPG vollständig deinstalliert (vorher die GnuPG-Schlüssel gesichert), dann die Registry nach GnuPG-Einträgen durchsucht und deren Reste gelöscht.

    Dann GnuPG neu installiert und, so wie Gwen das oben beschrieben hat, in The Bat! konfiguriert.

    Es gab da wohl in der GnuPG-Software vor einiger Zeit eine Änderung der Registry-Zweige bzw. -schlüssel, die von GnuPG geschrieben und ausgewertet werden.

    Es handelte sich bei mir also um ein Installationsproblem.



    Hier sind zwei Screenshots meiner Einstellungen (Optionen):


    Optionen: OpenPGP / Version auswählen



    und:


    Optionen: OpenPGP / Einstellungen



    (Dort habe ich "Immer mit Standardschlüssel verschlüsseln" nicht ausgewählt, weil GnuPG mich dann nach dem Schlüssel fragt, der zu der Absende-E-Mailadresse passt.)