Startprobleme mit Kleopatra

  • Hallo GwenDragon


    Ich habe leider GPG4Win als Administrator installiert. Danach bekam ich beim Starten von Kleopatra folgende Meldung:


    Kleopatra kann nicht als Administrator ausgeführt werden ohne Dateiberechtigungen im GnuPG Datenordner zu beschädigen.

    Um Zertifikate für andere Nutzer zu verwalten tun Sie dies Bitte mit einem Nutzeraccount und kopieren anschließend das 'AppData\Roaming\gnupg' Verzeichnis mit den korrekten Dateirechten.


    Danach habe ich alles wieder deinstallliert, neu gestartet und dann wieder neu ohne "Administrator" installiert.

    Es änderte sich leider nicht mehr an dem vorigen Malheur.

    Auch das komplette Löschen der Verzeichnisse und der Einträge in der Registry etc. haben das Problem nicht beheben können.

    Tipps aus den Weiten des Internet haben mich auch nicht weitergebracht.

    Die Rechte der Verzeichnisse entsprechen deinem Beitrag im Netz. Daran liegt es wohl auch nicht.


    Weist du vielleicht noch einen Weg dieses Problem zu beseitigen?

  • Um welche Windows-Version und welches GPG4Win geht hier genau?

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Ich habe mich as Admina (das ist der account, der beim Installieren von windows angelegt wurde) eingeloggt, dann GPG4Win ganz normal installiert, dann mit Doppeklick das Kleopatra-Icon auf dem Schreibtisch geklickt und Kleopatra startet.


    Du darfst beim Starten von Kleopatra nicht Ausführen als Administrator wählen.

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • @Arachnophilia Und hast du GPG4Win für alle Benutzer nach C:\Program Files (x86)\GPG4Win und GPG nach C:\Program Files (x86)\GnuPG installiert oder als Portable?

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Einmal editiert, zuletzt von GwenDragon ()

  • Ich hab noch 10.0.19042.985.

    Du hast eine Windows Beta/Insider?

    Ja. Diese Version soll aber ab heute offiziell bei MS zu haben sein.

    Der PC läuft über meinen Server mit Windows Server 2019 und ist an der Dmäne angemeldet.

    Die Vorgängerversion von gpg4win lief super. Bis ich beim Update als Administrator installiert habe.....

    Die Version 3.1.15 ist normal installiert und läuft nicht als portable Version.

    Bei der Installallation lasse ich immer die Standartverzeichnisse stehen.

  • Arachnophilia Ich verstehe auch nicht wo da was verbockt ist, denn in meiner 10.0.19042.985 geht es wundervoll.

    Ich hab’s gerade mit einer installierten Version getestet, als Admina (normaler User, in Administrator-Gruppe) gestartet (nicht als Ausführen als...!).


    Du musst da wohl oder übel im GPG4Win-Forum fragen, das Problem ist zu speziell.

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • Servus GwenDragon


    Ich danke die für die Rückmeldungen.

    Ich habe es schon befürchtet, dass die Behebung des Problems nicht so trivial sein wird.


    PGP nutze ich schon seit der Version 2.6.x von P. Zimmermann. Gefolgt von der Windows Version bis zur Variante von Symantec.

    Und seit einigen Jahren dann mit gpg4win, weil ich lieber mit "Sicherheitssoftware" arbeite die quelloffen sind.


    Dann wende ich mich mal an das gpg4win Forum.

    Vielen Dank nochmals für deine Bemühungen.

  • Die Vorgängerversion von gpg4win lief super.

    Das ist eben eine der Neuerungen in v3.1.15:

    Kleopatra: Das Ausführen mit erhöhten Rechten (als Administrator starten) wird nun verhindert, um zu vermeiden das die Dateirechte im GnuPG Datenordner fehlerhaft gesetzt werden. (T5212)


    und dann wieder neu ohne "Administrator" installiert.

    Es geht also nicht darum, wie man's installiert, sondern wie man's startet.

  • Servus sanyok


    Das habe ich schon verstanden. ;)


    Egal ob ich Kleopatra (nach der Installation ohne Administratorrechten) "normal" starten will oder als Administrator......

    Kleopatra wird immer mit der gleichlautenden Fehlermeldung beendet.

    Hast du einen Lösungsansatz?

    ______________________________________
    Arachnophilia

    Einmal editiert, zuletzt von Arachnophilia () aus folgendem Grund: Bessere Verständlichkeit

  • Moin Sanyok


    Das hatte ich auch geprüft. In der Verknüpfung ist nichts entsprechendes eingestellt.

    Bei der Fehlersuche habe ich aber auch die eigentliche Kleopatra.exe gestartet. In beiden Fällen die gleiche Reaktion.

    Ich habe deinen Hinweis in der Changelog aufgegriffen und die Vorgängerversion installiert. Die funktioniert wieder! :thumbsup:

    Jetzt hoffe ich auf eine Information zur Fehlerbehebung aus dem Gpg4win Forum.

    Bis dahin nutze ich die Version 3.1.14.

    Vielen Dank für den Hinweis!

  • Bei der Fehlersuche habe ich aber auch die eigentliche Kleopatra.exe gestartet.

    Hast du es auch in den Dateieigenschaften von KLEOPATRA.EXE geprüft? Die o.g. Option kann man sowohl bei Verknüpfungen als auch gleich bei ausführbaren Dateien aktivieren.


    Ansonsten solltest du es, wie von Gwen vorgeschlagen, den GPG4Win-Machern melden, denn ab nun wird es immer so sein, wodurch du nicht mehr aktualisieren könntest.