Beiträge von simbabque

    Moin.


    Ich meinem TB! 5.4 werden einige Unterverzeichnisse aus meinem tollen neuen Exchange-Konto nicht angezeigt. Outlook zeigt sie aber an.


    Code
    \\Konto\Inbox\Foo
    \\Konto\Inbox\Foo\Bar  <-- in TB! vorhanden
    \\Konto\Inbox\Foo\Baz  <-- in TB! nicht da


    Bei IMAP konnte man einfach die Folder List aktuallisieren. Bei einem MAPI-Konto scheint es das nicht zu geben. Was kann ich tun?

    Ich hab's rausgefunden. Es gibt zwei Moeglichkeiten:


    • Im Account-Verzeichnis die ACCOUNT.SRB in den anderen Ordner kopieren, TB! neustarten.
    • Im Sorting Office kann man die ganzen Filter-Ordner kopieren, und im anderen Account einfuegen.

    In beiden Faellen muss man danach beigehen, und bei Sortier-Filtern den Namen des Accounts im Ziel-Pfad anpassen. Hurra. :)

    Moin,


    wir haben unsere Firmen-Mails von IMAP auf Exchange umgestellt. Da man ein Konto in TB! scheinbar nicht einfach umaendern kann, musste ich ein neues erstellen. Die Schenllvorlagen zu kopieren ist mir bereits gelungen. Leider habe ich noch nicht herausgefunden, wie ich meine Filter (keine Common Filter) vom alten in den neuen Account bekomme. Natuerlich hatte ich ein Backup gemacht, aber das nuetzt mir herzlich wenig, weil ich damit auch nur das ganze Konto wieder importieren kann.


    Hat jemand einen Tip fuer mich?

    Zitat

    Vergleiche beide LDIFs aus TB! und Exchange und passe die letztere an. Vielleicht klappt es dann.


    Auf die Idee bin ich nicht gekommen. Sehr guter Hinweis, vielen Dank. Wenn ich das gecoded habe, stelle ich es gern zur Verfuegung.

    Zitat

    Er pflegt sie aber nicht in TB!, oder


    Nein. Das ist ein Export aus... Exchange, glaube ich. Ist auch egal, es ist ein Export. Nur ich habe Tb!.


    Zitat

    Wenn man eine LDIF-Datei importiert, die mit TB! erstellt wurde, kann es jedoch sein, dass aktualisiert wird. Muss man testen.


    Woher sollte TB! erkennen, ob die Datei von ihm erstellt wurde? Falls das geht, kann ich das auch in der LDIF dazubasteln.


    Zitat

    Nicht dass ich wüsste. Bei TB! ist fast alles geheim.


    Ich hab ein bisschen damit rumgespielt. Ist sehr wirr. Ist halt binaer, aber folgt irgendwie keinem richtigen Muster. Werde aber weiter experimentieren. Vielleicht gelingt es mir ja, zumindest einen Teil des Adressbuchs zu verstehen.

    Danke fuer deine Antwort. Ich importiere eine neue Datei, die unabhaengig von meinem TB! von einem Kollegen geplfegt wird (bin Einzelkaempfer was TB! angeht). Hatte gehofft dass es moeglich ist, meine Datensaetze zu updaten, statt sie zu ueberschreiben. Das sind etwa 600 Kontakte, aber ich habe bei einigen (20 oder so) eigene Templates und z.B. Handynummern hinterlegt. Die moechte ich natuerlich beibehalten. Im Wesentlichen aendern sich auch keine Eintraege. Es fallen nur welche weg, und neue kommen hinzu (Fluktuation bei den Mitarbeitern). Das alles landet in einem eigenen Ordner/Liste. Ich kann das aber auch in ein eigenes Adressbuch importieren.


    Gibt es fuer die ABD eine Format-Dokumentation? Ich koennte ein Programm basteln, dass die Daten fuer mich aktuallisiert.

    Moin,


    ich habe eine LDIF (oder vCard) Datei mit ungefaehr 600 Adressen, die ich importieren moechte. Wie das funktioniert ist mir bekannt. Die Datei wird regelmaessig aktuallisiert, und ich habe sie in der Vergangenheit auch schon importiert. Dabei trat immer das Problem auf, dass Eintraege, bei denen ich Aenderungen (wie z.B. Templates oder Notizen) gemacht hatte, doppelt erscheinen. Ausserdem werden Eintraege, die in der Datei nicht mehr vorhanden sind natuerlich auch nicht geloescht.


    Letzteres ist nicht so schlimm. Das Problem mit den manuellen Aenderungen wuerde ich aber gerne loesen. In diesem Update wurde ueberall ein Geburtstag und ein Geschlecht hinzugefuegt, und es sind generell neue Eintraege hinzugekommen.


    Hat jemand eine Idee, wie ich das anstellen kann?


    Vielen Dank und Gruss!


    1. Evl kannst du die Einstellungen der Software, die die Projektmails verschickt, dahingehend ändern dass es nicht mehr heißt Projektname: Blubber sondern Projektname [Blubber] oder auch irgendwelche anderen erlaubte Zeichen verwenden, um den Projektnamen zu kennzeichnen. Folgende Zeichen kannst du nicht im Dateinamen verwenden: /\:*"<>|
    2. Wenn du nicht per Drag n Drop exportierst, sondern über "Speichern unter" zuerst im normalen Dateisystem speicherst, bleibt der Betreff fast erhalten, das Re: und weitere Doppelpunkte fallen dabei weg. Es bliebe also Projektname Blubber übrig (mit zwei Leerzeichen).


    Die Mails sind von Hand geschriebene Mails und deren Antworte. Quasi Korrepsondenz zu bestimmten Themen. Ich will die an Tickets in Jira anhaengen. Das geht bequem per Drag&Drop, weil man einfach neue Dateianhaenge 'in die Webseite schmeissen' kann. Ueber Speichern Unter wird (siehe oben) der Doppelpunkt durch ein Leerzeichen ersetzt. "Re " und co bleiben aber bestehen. Dennoch ist das nervig, weil das andere natuerlich viel schneller geht. Mir geht es um den Workflow und um Zeitoptimierung. ;)

    Doppelpunkte sind nur nach einem Laufwerksbuchstaben erlaubt in Windows-Dateinamen.


    Das stimmt. Aber man koennte sie ja zb ersetzen. Das Re: gehoert ja schon irgendwie zum Betreff dazu. Immerhin sagt es aus, dass es sich um eine Antwort handelt. Und TB! macht das da selbst hin.


    Edit: Wenn ich ueber Nachricht >> Speichern gehe, werden die Doppelpunkte durch Leerzeichen ersetzt. Er schlaegt dann als Dateiname vor folgendes vor. Warum .txt und nicht .eml weiss ich noch nicht.

    Code
    Re  Projektname  Mailtitel foo bar fasel.txt

    Moin,


    ich verschiebe oefter Mails aus der Nachrichtenliste (zb Inbox) per Drag&Drop in meinen Browser, um sie in ein Ticketsystem als Dateianhang hinzuzufuegen (Jira). Genau wie wenn man eine Nachricht einfach in den Windows Explorer verschiebt, wird dabei der Dateiname angepasst. Der Dateiname ist der Betreff der Mail, aber ohne "Re:". Leider killt es dabei auch andere Praefixe mit Doppelpunkt im Betreff.


    Ein Beispiel:


    Code
    Re: Projektname: Mailtitel foo bar fasel


    Wenn ich diese Mail in den Explorer ziehe, hat die Datei folgendn Namen:


    Code
    Mailtitel foo bar fasel.eml


    Natuerlich ist das jetzt bloed, weil mein eigenes Praefix Projektname: weg ist. Das finde ich nicht so schoen. Gibt es eine Moeglichkeit, das zu konfigurieren?


    Vielen Dank fuer Eure Hilfe.

    Moin,


    ich habe gerade mein IMAP-Konto mit Einstellungen und globalem Adressbuch ueber ein Backup auf einen neuen Rechner (WinXP nach Win7) verfrachtet. Soweit super. Allerdings funktionieren meine handles (Spitzname?) fuer Adressbuchkontakte nicht mehr. Sie stehen zwar in den Kontakten, aber wenn ich eine neue Nachricht verfasse werden sie in den Adressfeldern nicht erkannt. Ich habe zum Beispiel foo als Handle fuer Max Muster eingetragen. Eigentlich sollte ich jetzt foo im Feld An: eingeben und Tab druecken koennen, damit die Email-Adresse von Max eingefuegt wird. Das geht aber nicht mehr.


    Insgesamt ist die Adressbuch-Autovervollstaendigung sehr traege (war sie auch auf dem alten PC). Kann man die Wartezeit irgendwo einstellen? Thunderbird zum Beispiel ist da deutlich zuegiger. Es reicht, wenn man die ersten paar eindeutigen Buchstaben eines Kontaktes eingibt. Dann kann man zum Text tabben und die Adresse wird sofort mit dem passenden Eintrag aufgefuellt. Ich finde schade, dass TB! das nicht kann. (Oder dass ich die Einstellung nicht finde...).


    Ueber Vorschlaege jeder Art freue ich mich!

    Moin,


    ich habe vorhin auf meinem IMAP-Konto (Server im LAN) mal eine Folder Maintenance durchgefuehrt, weil es manchmal 10 Sekunden oder mehr dauert, bis die Nachrichten in der Inbox (ungefaehr 500+, lange nicht mehr sortiert) geladen werden. Das hat TB! scheinbar dazu veranlasst, alle automatisch oder manuell verschobenen Nachrichten seit Anfang des Jahres in der Inbox wiederherzustellen, und jetzt sind da etwa 77k ungelesene Mails drin. Nachdem ich erstmal kraeftig geschluckt hatte habe ich ein paar von meinen anderen Ordnern ueberprueft (alles noch wo es hingehoert), nach ungelesen gefiltert und alles bis gestern beherzt geloescht. Dann war Ruhe. Als ich das naechste Mal den Ordner gewechselt habe waren die Mails dann aber wieder da. WTF.


    Jetzt habe ich meinen ewig nicht mehr genutzte Thunderbird aktuallisiert und gestartet. Der zeigt die ganzen alten Nachrichten nicht an.


    Hat jemand eine Idee woran das liegen kann? Ich poste gleich noch meine Einstellungen.


    Update: Auf dem Mailserver sind die 77k alten Mails nicht in der Inbox vorhanden. Es scheint also, als haette TB! die irgendwo gecached. Er hat die beim Maintenance Kram tatsaechlich irgendwie "recovered", also scheinbar aus seinem lokalen Cache ausgegraben. Meine Idee war, dass er die von da loescht. Scheinbar ist das nach hinten losgegangen.

    Tja, da habe ich mir so viel Muehe gemacht ein Tutorial zu erstellen, und dann war es doch was ganz simples. Auf HTML bin ich echt mal nicht gekommen. Ich nutze selber nur im Notfall HTML-Mails, zum Beispiel wenn ich eine Tabelle (Datenbankexport) oder einen Screenshot an Kollegen verschicken will. Dann stelle ich genau so auf HTML/Plain Text um und fuege den Kram ein. Dann kommt tatsaechlich die Menueleiste. Ich habe die aber noch nie benutzt, geschweige denn bemerkt. Daumen hoch fuer die Antwort. :D

    Ich bin mir nicht sicher ob das geht und kann es gerade auch nicht testen. Von der Idee her sollte das nicht (ausschliesslich ueber IMAP) moeglich sein, da IMAP deine Mails nicht abholt und lokal abspeichert, sondern dir Zugriff auf die entfernte Struktur ermoeglicht. Es ist zwar moeglich alles abzuholen, aber selten sinnvoll. Gerade mobil ist das keine gute Idee. Der Vorteil liegt ja darin, dass Du die gleiche Struktur ueberall hast. Koenntest Du das lokal anders machen, waerst Du wieder bei POP3.


    Eine Moeglichkeit waere, die Mails in ein zweites Konto zu kopieren und dort zu sortieren. Wenn das Konto nie von irgendwo Mails abruft sollte das ganz gut gehen. Eventuell kann man auch was mit virtuellen Ordnern machen, da bin ich mir nicht sicher, das benutze ich selten. Vielleicht kann da wer anders was zu sagen. In der neusten Version von TB! gibt es Tags. Die koennte ich mir auch nuetzlich vorstellen, vielleicht in Verbindung mit den virtuellen Ordnern.


    Bei Thunderbird gibt es, wenn man ein IMAP-Konto hat auch noch einen "Lokalen Ordner" oder so, unter (nicht untergeordnet) der IMAP-Inbox. Dieser Ordner und seine Kinder sind komplett lokal und werden vom IMAP nicht wahrgenommen. Die kann man dazu nutzen. Ob das in TB! moeglich ist, weiss ich nicht.


    Edit: Ich glaube was Du brauchst sind Common Folders/Gemeinsame? Ordner. Die Mails sind dann aber weg vom IMAP wenn Du sie dahin verschiebst. Du koenntest sie kopieren. Aber dann kriegst Du erstens Redundanz und langfristig sicher auch Inkonsistenz.

    Das finde ich auch nicht schlecht. Vielen Dank dafuer. Redest Du deine Geschaeftskontakte wirklich immer mit "Sehr geehrter Herr" an? Ich kriege meist nur ein "Hallo Herr" oder "Guten Tag Herr". Aber meine Kontakte sind fast nur IT. Obwohl, deine wahrscheinlich auch. Am Besten sind die Amerikaner, die schreiben einfach nur "Vorname,".


    Kann man eigentlich erkennen, ob es mehrere Empfaenger gibt? Ein Makro das die Anzahl der Empfaenger liefert habe ich noch nicht gesehen.


    Ich habe das ganze jetzt zu folgendem QT zusammengewurstet. Das ist mein Quick Template das die Anrede fuer Kontakte mit Land='Deutschland' und alles was nicht im AB steht oder dort kein Land hat regelt.


    Code
    %QT="anrede_nach_zeit" %-
    %IF:"%SETPATTREGEXP='(?:@firma1\.com|@firma2\.ro|@firma3\.de)$'%REGEXPMATCH='%TOADDR'"<>"":%-
    '%IF:"%ABToFirstName"<>"":"%ABToFirstName":"%CAPITAL=%ToFName"':%-
    '%IF:"%ABToGender"="2":"Frau":"Herr" %CAPITAL=%ToLName',


    Das %ABToFirstName hat auf jeden Fall das Problem behoben. Vielen Dank schon mal.