Falscher Absender und falsches Betreff für Message in Messagelist

  • Der Eintrag in der Messagelist einer INBOX zeigt den Absender und das Betreff von einer Spam- bzw. Trojanermessage, aber der Inhalt der MEssage ist völlig OK.


    Wie krieg ich das wieder richtig hin?


    Es handelt sich um ein IMAP4-Konto. Der Fehler kam vermutlich beim Übergang von einem Provider zum nächsten zustande (Internet24 wurde in HostEurope integriert mit vollständiger Übernahme aller Mailkonten und aller Passwörter).


    Dabei wurde vermutlich ein Eintrag in TheBat! falsch mit einem Eintrag im IMAP-Server falsch synchronisiert.

  • Diese Daten werden im Header gespeichert und TB! verändert den Header einer empfangenen Nachricht IMO nie, es sei denn, dass irgendein eingebundenes Plug-in dies macht. Das passierte also bereits auf dem Server. Eventuell war das eine einmalige Sache.


    Ansonsten kann man den Header manuell verändern, indem man die Nachricht z.B. als EML-Datei exportiert, mit einem Text-Editor bearbeitet und anschließend wieder in TB! importiert.

  • Notfalls mal in den Eigenschaften des Ordners IMAP- → Cache löschen.

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Einmal editiert, zuletzt von GwenDragon ()

  • Das Löschen vom Cache könnte geholfen haben. Ich find auf jeden Fall die Nachricht mit dem falschen Absender und falschen Betreff (eine vierstellige Zahl) nicht mehr.


    Aber auch nicht die Nachricht, die dahinter wirklich verborgen war.


    Und TheBat! hat mit der Alpha 55 wieder angefangen, alle Naselang abzustürzen.


    sanyok: das war mehrfach, auch in anderen IMAP-Konten, die ja alle vom Umzug betroffen waren. Einmalig insofern, als das beim ersten Kontakt vom Client (TheBat!) mit dem IMAP-Server auf dem neuen Hoste geschah. Da sind wohl einige IMAP-bezogene Nummern der Message zwischen Server und Client durcheinandergeraten.



    Nachtrag: ich hab die falsch im Index eingetragene Message doch gefunden. Sie wird jetzt korrekt mit Absender und Betreff auf der Message selbst angezeigt.


    Cache löschen war das Zauberwort.