Versions- und Lizenzfrage

  • Ich habe Voyager auf die 6.2.2.10 und alle Konten auf SSL umgestellt.


    Seitdem funktioniert Antispamsniper 3.2.7.5 nicht mehr. Der bisherige Lerneffekt ist weg, es stellt sich auch kein neuer ein, keine einzige Spam-Mail wird erkannt.


    Liegt das am Zusammenspiel mit TB/Voyager 6.2 oder funktionieren Spamfilter grundsätzlich nicht mit SSL?


    Auf der Website des Plugins gibt es keine aktuellere freie Version für TB 6 32-Bit. Ich finde es zwar nicht schön, wenn ein Programm, von dem es seit Jahren eine kostenlose und eine Pro-Version gibt, plötzlich keine freie Version mehr anbietet. Dennoch würde ich eine Lizenz kaufen.
    Es ergibt sich dabei nur die Frage, ob diese Lizenz auch für eine spätere 64-Bit-Version gelten würde. Ich bin nämlich derzeit von Voyager aufgrund seiner unerträglichen Langsamkeit seit Umstellung auf 6.2 und SSL-Konten täglich völlig entnervt. (So liegt meine Hoffnung auf einer 64-Bit-Version von Voyager, die sich aber erstens auf eine unbekannte Zukunft bezieht und deren größere Schnelligkeit zweitens vielleicht nur eine unberechtigte verzweifelte Hoffnung meinerseits darstellt ;) ... )


    Meine Fragen auf Antispamsniper bezogen lauten also zusammengefaßt:


    - Funktioniert die Filterung auch mit SSL-Konten grundsätzlich? (Ich habe von diesen Dingen leider keine Ahnung.)
    - Ist eine freie Version von Antispamsniper für TB6 32-Bit geplant? (Wenn ich sanyoks letzten Beitrag zu 3.3x recht verstehe, eher nicht?)
    - Wäre eine aktuelle Lizenz 3.3x 32-Bit auch für eine künftige 64-Bit-Version zum Betrieb mit einer hoffentlich irgendwann demnächst erscheinenden 64-Bit Version von TB/Voyager gültig?


    Vielen Dank!

  • - Funktioniert die Filterung auch mit SSL-Konten grundsätzlich? (Ich habe von diesen Dingen leider keine Ahnung.)

    Eigentlich müsste es gehen. Man braucht aber eventuell ein Wurzelzertifikat. Auf der Webseite steht u.a.:

    Zitat

    TheBat 5.x shows security warnings when the plug-in filters SSL connections. Here is an instruction how to avoid this: http://antispamsniper.com/forum/viewtopic.php?t=504

    Es wird auf das Forum verlinkt, in dem erklärt wird, wie man das Zertifikat installieren kann.



    - Ist eine freie Version von Antispamsniper für TB6 32-Bit geplant? (Wenn ich sanyoks letzten Beitrag zu 3.3x recht verstehe, eher nicht?)

    Momentan gibt es kostenlos immer noch nur ASS v3.2 als 32-Bit. Wie ich in dem letzten Thread geschrieben habe, braucht man für TB! v5.x oder 6.x aber ASS v3.3. Eine kostenlose v3.3 gibt es nur als 64-Bit. Ob es auch eine v3.3 als 32-Bit geben wird, ist unbekannt. Du kannst diese Frage im ASS-Forum stellen oder sich unmittelbar an den Hersteller über die Kontakt-Seite wenden.



    - Wäre eine aktuelle Lizenz 3.3x 32-Bit auch für eine künftige 64-Bit-Version zum Betrieb mit einer hoffentlich irgendwann demnächst erscheinenden 64-Bit Version von TB/Voyager gültig?

    So viel ich weiß, erhält man eine nicht von der Bit-Version abhängige Lizenz mit lebenslang kostenlosen Upgrades. Daher wird man die erworbene Lizenz höchstwahrscheinlich auch in zehn Jahren mit einer x-beliebigen 32- oder 64-Bit Version nutzen können.


    Die Lizenz kostet übrigens nur ca. 20 EUR brutto. Wenn du von dem Produkt überzeugt bist, dann lohnt sich diese Investition sicherlich. Über TrialPay kann man die Lizenz übrigens sogar kostenlos erhalten. Das steht alles auf der ASS-Webseite.

  • Danke Dir!


    Wenn die Lizenz auch 64-Bit-Versionen beinhaltet, dann werde ich vermutlich bei diesem Plugin bleiben, da es bislang tadellos funktioniert hat.


    Danke auch für den Link bezüglich der Zertifikate. Eigentlich denke ich nicht, daß ich das dort angesprochene Problem habe...


    Zitat

    The plug-in substitutes server SSL certificates during filtering the protected connections. To avoid warning dialogs it is possible to install the plug-in's root certificate in Address Book:


    ... bei mir erscheinen nämlich keine Warnhinweise (außer bei AOL-assoziierten Konten, wo jedoch das manuelle Hinzufügen von deren Zertifikat Abhilfe schuf). Bin aber der Anweisung ersteinmal trotzdem gefolgt. Mal sehen, ob mit dieser Einstellung Spam wieder erkannt wird.


    Allerdings weiß ich nicht, was ich hiervon halten soll:


    Zitat

    The plug-in substitutes server SSL certificates during filtering the protected connections. To avoid warning dialogs it is possible to install the plug-in's root certificate in Address Book:


    Bedeutet das, daß die Originalzertifkate der Server nicht mehr gegen das Zertifikate-Adressbuch abgeglichen werden? Ist das sicherheitsrelevant?

  • Bedeutet das, daß die Originalzertifkate der Server nicht mehr gegen das Zertifikate-Adressbuch abgeglichen werden? Ist das sicherheitsrelevant?

    Die Verbindung von TheBat! zu Spamsniper wird mit einem ziemlich schlecht verschlüsselnden laschen Zertifikat hergestellt. Nach Aussagen von Spamsniper läuft die Verschlüsselung vom Plugin selbst zum Mailserver mit dem Serverzertifikat.
    Ich halte ein schlechtes Zertifikat immer für sicherheitsrelevant.

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • [...]Seitdem funktioniert Antispamsniper 3.2.7.5 nicht mehr. Der bisherige Lerneffekt ist weg,[...]


    Beim Einrichten des AntispamSniper-Plugins wird in Windows ein Ordner erstellt, in dem sich die Regeln für die Filterung befinden. Wenn man diesen Ordner verschiebt, am besten auf eine andere Partition, dann hat man die bisherigen Filterregeln auch nach einer Neuinstallation des Betriebssystems, von TB! oder des Antispam-Plugins gleich wieder zur Verfügung, in dem man in den Plugin-Einstellungen, unter Optionen, den bisherigen, auf einer anderen Partition angelegten/verschobenen Antispam-Ordner, mit den (bisherigen) Filterregeln verweist.

  • GwenDragon: Merci für die Information!


    CCCP99: Danke für die Rückmeldung.


    Zitat

    Beim Einrichten des AntispamSniper-Plugins wird in Windows ein Ordner erstellt, in dem sich die Regeln für die Filterung befinden.


    Ich nehme an, der "Konfigurationsordner", dessen Pfad man in den Optionen einstellt.


    Ich hatte allerdings das Antispamsniper-PlugIn nicht entfernt, nur die neuere Version von TB/Voyager über die alte gespielt und alle Konten auf SSL umgestellt.


    Auch ist die Spam-Statistik noch vorhanden, mittlerweile muß ich sagen gewesen, da ich jetzt die Version 3.3.1.6 installiert habe. (Den alten Antispamsniper-Ordner habe ich umbenannt und auf dem USB-Stick im Voyager-Verzeichnis belassen.)
    Interessanterweise ist auch jetzt in dieser neu installierten Pro-Version die Spam-Statistik noch vorhanden (trotz neuem Ordner, da der alte umbenannt).


    Außerdem war das Auffällige an der Sache, daß die Nicht-Filterung mit einem Nicht-Lernen verbunden war. Das konnte ich über die letzten Wochen an etlichen häufig eingehende Kandidaten beobachten, die ich immer brav aufs Neue als Spam klassifiziert habe. Kein Lerneffekt. Sie wurden nicht erkannt.


    Ich hatte bis jetzt vermutet, daß meine alte Version einfach nicht mit der neuen Version von TB/Voyager zusammenarbeitet, oder daß die Erkennung von Spam an SSL-Konten das Problem war, bzw. eine Kombination aus beidem. Ob die neue Version von ASS nun wieder filtert, werde ich in den nächsten Tagen sehen.

  • So, nach einigen Tagen ist klar, daß auch die aktuelle Pro-Version nicht filtert.


    Die gelernten Informationen sowie Black- und White-Listen sind vorhanden. Wenn ich einen Ordner mit Spam der letzten Tage fülle und ihn manuell von ASS filtern lasse, werden die Spammails auch entsprechend meiner Einstellung brav in den Spamordner verschoben.


    Es scheint klar, daß eingehendene Mails entweder nicht geprüft oder nicht erkannt werden. Aufgetreten ist das Problem wie gesagt nach dem Überinstallieren der aktuellsten Voyager-Version und der unmittelbar danach erfolgten Umstellung aller Konten auf SSL. Es sind nur zwei IMAP-Konten mit Eingang auf Port 993 dabei, alle anderen Eingänge sind POP3 auf Port 995. Es werden jedoch alle Konten nicht gefiltert, nicht nur diejenigen, für die auch IMAP-Versionen bestehen (da gab es wohl irgendein Flag-Problem).


    Auch das Löschen von Spam direkt auf den Servern habe ich meines Wissens nicht eingeschaltet. Jedenfalls sind in "Einstellungen/Konten/" keine Konten aufgeführt und ich habe auch keine manuell hinzugefügt.


    Gibt es denn noch eine Idee, woran das Nichtfiltern liegen könnte? Ich bin für jeden Hinweis dankbar.


    Voyager 6.2.2.10
    Antispam-Sniper Pro 3.3.1.6 (32-Bit)

  • Die AntispamSniper Version für TheBat! 32bit hat derzeit noch die Versionsbezeichnung 3.3.1.5;


    Die habe ich auch heruntergeladen und installiert. Soweit ich mich erinnere, wurde mir aber beim Prüfen auf Updates die 3.3.1.6 angeboten und ich habe diese dann heruntergeladen und installiert.
    Jedenfalls ist definitiv eine Version 3.3.1.6 installiert. Es müßte sich eigentlich um eine 32-Bit-Version handeln. Die installationsdatei dafür heißt sniper-mui-3.3.1.6.exe. (Im Gegensatz dazu heißt die für die 64-Bit-Version sniper-mui-free-3.3.1.6_x64.exe.)
    Ich kann mich auch nicht erinnern, eine 64-Bit-Version installiert zu haben, ich glaube, das ginge auch gar nicht, oder?

  • Folgende Information habe ich im Forum von ASS gefunden:


    Nachdem jemand dort berichtet, daß ASS nach Installation von Voyager 6.2.2 nicht mehr filtert, wird folgende Antwort gegeben:

    Zitat

    This is a bug in current version of Voyager. It is already reported to Ritlabs, so please wait for a new build of Voyager with a fix.


    Eine neue Runde des Wartens also und viel verschwendete Energie...

  • sanyok
    Wie hast Du das denn gemacht, innerhalb von 2 Stunden eine neue Version aus dem Hut zu ziehen? Da hast Du wohl gezaubert!! 8)


    Ich war schon auf eine längere Wartezeit eingestellt, normalerweise sind die Abstände für Voyager ja ziemlich groß. Ich bin neugierig und werde bald berichten, ob's nun läuft.

  • Du wirst es nicht glauben, ich HABE gestern, als ich mich nämlich mit der Angelegenheit befasste, besonders nach diesem Hinweis auf die Folgeversion, nachgesehen. Allerdings eventuell in der Versionshistorie hier auf Batboard, die normalerweise ja immer brandaktuell ist. Daß beides sich um einige Stunden überschnitten hat, wirst Du mir nicht ernsthaft vorwerfen wollen. Für mich war Batboard eben immer die eigentliche Referenz für TB, viel mehr als die Entwicklerwebsite.


    Von nun an werde ich aber unmittelbar vor dem Posten noch einmal bei Ritlabs direkt nachsehen, ob sich auch nichts überschnitten hat. Und Ritlabs wird dann vor Veröffentlichung vielleicht auch die verbreitetsten PlugIns testen...

  • Meist bekommen wir neue Versionen schnell mit, aber wir sind ja nicht immer überall online. Und manchmal übersehn wir was.
    Wir sind auch nur Menschen -- die Freizeit oder Arbeite haben, ohne hier zu sein.
    Es schadet nix, auch mal bei den Herstellern der Lieblingsprogramme nachzusehen ;)

    The Bat! Pro 10.x BETA (32bit) | Win 11 Pro x64 | GnuPG 2.3.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

  • GwenDragon
    Daß Batboard meine 1. Referenz in Sachen TB ist, war als großes Lob gemeint, nicht als Vorwurf!! Im Portal gibt es eine schöne übersichtliche Liste der Veröffentlichungen mit entsprechenden Downloadlinks. (Bei Ritlabs habe ich eine ähnlche jetzt erst nach Suchen auf der englischsprachigen Seite gefunden.) Ob die Liste auf Batboard einen Tag früher oder später aktualisiert wird, ist im Normalfall meist wohl eher unwichtig.


    Was die verfügbare Zeit angeht, so verhält es sich bei mir ganz ähnlich. Ich hatte gestern recherchiert (ich meine sogar, auch bei Ritlabs, bin aber nicht sicher), und war erst heute zum Posten gekommen. Und gleich gab's was auf die Mütze ;)


    Erfreulich: Mit der neuen 6.2.13 läuft AntispamSniper auf den ersten Blick wieder klaglos.