Ungültiges Serverzertifikat für GMail

  • Ich hab im momet auch probleme - was soll das ?
    mal geht es nicht dann geht es wieder...........


    !02.04.2020, 15:44:33: FETCH - TLS-Handshakefehler. Ungültiges Server-Zertifikat. Das Zertifikat kann für diesen Zweck nicht genutzt werden
    02.04.2020, 15:45:24: FETCH - Empfange Nachrichten
    02.04.2020, 15:45:24: FETCH - Verbinde mit POP3-Server pop.gmail.com auf Port 995
    02.04.2020, 15:45:24: FETCH - Einleitung TLS-Handshake
    >02.04.2020, 15:45:24: FETCH - Zertifikat S/N: 0E884B385836D5690800000000320BE3, Algorithmus: 1.2.840.10045.2.1 (256 Bits), ausgestellt von 03.03.2020 09:58:11 bis 26.05.2020 09:58:11, für 1 Host(s): pop.gmail.com.
    >02.04.2020, 15:45:24: FETCH - Besitzer: US, California, Mountain View, Google LLC, pop.gmail.com.
    >02.04.2020, 15:45:24: FETCH - Aussteller: US, Google Trust Services, GTS CA 1O1.
    !02.04.2020, 15:45:24: FETCH - TLS-Handshakefehler. Ungültiges Server-Zertifikat. Das Zertifikat kann für diesen Zweck nicht genutzt werden
    02.04.2020, 15:48:31: FETCH - Empfange Nachrichten
    02.04.2020, 15:48:31: FETCH - Verbinde mit POP3-Server pop.gmail.com auf Port 995
    02.04.2020, 15:48:31: FETCH - Einleitung TLS-Handshake
    >02.04.2020, 15:48:31: FETCH - Zertifikat S/N: 00D80446EA4406BA970800000000320A6A, Algorithmus: RSA (2048 Bits), ausgestellt von 03.03.2020 09:44:10 bis 26.05.2020 09:44:10, für 1 Host(s): pop.gmail.com.
    >02.04.2020, 15:48:31: FETCH - Besitzer: US, California, Mountain View, Google LLC, pop.gmail.com.
    >02.04.2020, 15:48:31: FETCH - Aussteller: US, Google Trust Services, GTS CA 1O1.
    02.04.2020, 15:48:31: FETCH - TLS-Handshake vollständig
    02.04.2020, 15:48:31: FETCH - Verbunden mit dem POP3-Server
    02.04.2020, 15:48:32: FETCH - bestätigt (Standard)
    02.04.2020, 15:48:32: FETCH - 0 Nachricht(en) im Postfach, davon 0 neue
    02.04.2020, 15:48:33: FETCH - Verbindung beendet - 0 Nachricht(en) empfangen

    [size=10]Viele Grüsse Yaqwa
    [color=#ff0000][font='Comic Sans MS, sans-serif'][size=10][b]
    Ps. :
    Ja, ich schreibe Filter mit "d" - fragt mich nicht warum aber mein finger rutscht immer wieder auf das "d" - Nur falls es jemandem auffällt und ich vergessen habe es zu verbessern!

  • Zitat

    >02.04.2020, 15:45:24: FETCH - Zertifikat S/N: 0E884B385836D5690800000000320BE3, Algorithmus: 1.2.840.10045.2.1 (256 Bits), ausgestellt von 03.03.2020 09:58:11 bis 26.05.2020 09:58:11, für 1 Host(s): pop.gmail.com.

    @yaqwa Irgendeine Sicherheitssoftware/Filter-Proxy auf deinem PC funkt bei SSL/TLS über Port 995 dazwischen. Oder der einer der Google Mailserver sendet falsche Zertifikate.

    The Bat! Pro 9.x BETA (32bit) | Win 10 Pro x64 | GnuPG 2.2.x | XMP + Regula


    Wer mich Er oder der Drache nennt, bekommt von der Drachin Pratze und Feuer zu spüren.

    Einmal editiert, zuletzt von GwenDragon ()

  • ok ich schau danke

    [size=10]Viele Grüsse Yaqwa
    [color=#ff0000][font='Comic Sans MS, sans-serif'][size=10][b]
    Ps. :
    Ja, ich schreibe Filter mit "d" - fragt mich nicht warum aber mein finger rutscht immer wieder auf das "d" - Nur falls es jemandem auffällt und ich vergessen habe es zu verbessern!

  • Ich bekomme neuerdings für mein GMail-Konto einen "TLS-Handshakefehler" und "Ungültiges Serverzertifikat". Hat sich da irgendwas geändert?


    07. Apr. 2020, 15:22:24: FETCH - Empfange Nachrichten
    07. Apr. 2020, 15:22:24: FETCH - Verbinde mit POP3-Server pop.gmail.com auf Port 995
    07. Apr. 2020, 15:22:24: FETCH - Einleitung TLS-Handshake
    >07. Apr. 2020, 15:22:24: FETCH - Zertifikat S/N: 0E884B385836D5690800000000320BE3, Algorithmus: 1.2.840.10045.2.1 (256 Bits), ausgestellt von 03. Mrz. 2020 09:58:11 Uhr bis 26. Mai. 2020 09:58:11 Uhr, für 1 Host(s): pop.gmail.com.
    >07. Apr. 2020, 15:22:24: FETCH - Besitzer: US, California, Mountain View, Google LLC, pop.gmail.com.
    >07. Apr. 2020, 15:22:24: FETCH - Aussteller: US, Google Trust Services, GTS CA 1O1.
    !07. Apr. 2020, 15:22:24: FETCH - TLS-Handshakefehler. Ungültiges Server-Zertifikat. Das Zertifikat kann für diesen Zweck nicht genutzt werden

  • Zertifikat S/N: 0E884B385836D5690800000000320BE3, Algorithmus: 1.2.840.10045.2.1 (256 Bits),

    Die richtige Zertifikatsnummer ist D80446EA4406BA970800000000320A6A mit 2048-Bit. So muss das Protokoll aussehen:


    Benutzt du vielleicht auch ASS und/oder ein AntiVirus-Programm (womöglich ESET NOD32) mit eingeschalteter SSL-Untersuchung?

  • Habe seit heute Nachmittag ebenfalls Probleme mit meinem GMAIL-Konto.
    Hier ein Auszug aus der Log-Datei:


    07.04.2020, 18:36:46: IMAP - Einleitung TLS-Handshake
    >07.04.2020, 18:36:46: IMAP - Zertifikat S/N: 5638B010931D05380800000000320BE2, Algorithmus: 1.2.840.10045.2.1 (256 Bits), ausgestellt von 03.03.2020 09:58:11 bis 26.05.2020 09:58:11, für 1 Host(s): imap.gmail.com.
    >07.04.2020, 18:36:46: IMAP - Besitzer: US, California, Mountain View, Google LLC, imap.gmail.com.
    >07.04.2020, 18:36:46: IMAP - Aussteller: US, Google Trust Services, GTS CA 1O1.
    !07.04.2020, 18:36:46: IMAP - TLS-Handshakefehler. Ungültiges Server-Zertifikat. Das Zertifikat kann für diesen Zweck nicht genutzt werden


    Was kann ich tun?

    Die meisten Menschen sind bereit zu lernen, aber nur die wenigsten, sich belehren zu lassen.
    Winston Churchill

  • Nein, ich habe seit längerem nur den Windows Defender und damit lief es auch die ganze Zeit sehr gut. Die Zertifikate habe ich nach GwenDragons Anleitung schon lange auf die Windows-Zertifikate umgestellt.


    Ich habe übrigens gerade festgestellt, dass der Fehler, genau wie in dem von GewnDragon genannten Beitrag (den ich nicht gefunden hatte), nicht andauernd auftritt. Mal klappt es, mal wieder nicht.

  • Die Zertifikate habe ich nach GwenDragons Anleitung schon lange auf die Windows-Zertifikate umgestellt.

    Stelle es auf die interne um. Fehlende Zertifikate kann man ja bei Bedarf importieren.


    Ein lediglich 256-Bit-Zertifikat deutet jedenfalls darauf hin, dass sich etwas dazwischen schaltet (Plugin, AntiJunk, AntiVirus etc.), denn jeder Mailserver verwendet heutzutage ein 2048-Bit-Zertifikat. Falls du noch weitere Konten hast, dann vergleiche das mal selbst.


    Verwendest du vielleicht OAUTH bei GMail?



    Edit:
    Ich habe alle Posts zum GMail-Problem hierher verschoben. Im anderen Thread ging's um fehlende Chiffren und damit um ein ganz anderes Problem.

  • Mich nervt es auch schon den ganzen Tag :-( mal geht es mal nicht. Aber selbst wenn es augenscheinlich geht, wird die noch ungelesene Mail bei Gmail nicht abgerufen. Aufm Handy funktioniert es ^^


    07.04.2020, 20:16:37: FETCH - Empfange Nachrichten
    07.04.2020, 20:16:37: FETCH - Verbinde mit POP3-Server imap.gmail.com auf Port 993
    07.04.2020, 20:16:37: FETCH - Einleitung TLS-Handshake
    >07.04.2020, 20:16:37: FETCH - Zertifikat S/N: 30192987AA4DD903080000000035ED3C, Algorithmus: 1.2.840.10045.2.1 (256 Bits), ausgestellt von 24.03.2020 06:47:59 bis 16.06.2020 06:47:59, für 1 Host(s): imap.gmail.com.
    >07.04.2020, 20:16:37: FETCH - Besitzer: US, California, Mountain View, Google LLC, imap.gmail.com.
    >07.04.2020, 20:16:37: FETCH - Aussteller: US, Google Trust Services, GTS CA 1O1.
    !07.04.2020, 20:16:37: FETCH - TLS-Handshakefehler. Ungültiges Server-Zertifikat. Das Zertifikat kann für diesen Zweck nicht genutzt werden
    07.04.2020, 20:21:47: FETCH - Empfange Nachrichten
    07.04.2020, 20:21:47: FETCH - Verbinde mit POP3-Server imap.gmail.com auf Port 993
    07.04.2020, 20:21:47: FETCH - Einleitung TLS-Handshake
    >07.04.2020, 20:21:47: FETCH - Zertifikat S/N: 0096768414983DDE9C0800000000320A68, Algorithmus: RSA (2048 Bits), ausgestellt von 03.03.2020 09:44:07 bis 26.05.2020 09:44:07, für 1 Host(s): imap.gmail.com.
    >07.04.2020, 20:21:47: FETCH - Besitzer: US, California, Mountain View, Google LLC, imap.gmail.com.
    >07.04.2020, 20:21:47: FETCH - Aussteller: US, Google Trust Services, GTS CA 1O1.
    07.04.2020, 20:21:47: FETCH - TLS-Handshake vollständig

  • Sanyok, gibt es einen kurzen Tipp, wie ich die Zertifikate wieder auf TB!-intern zurückstelle? Ich mache so was nicht jeden Tag. :)


    OAUTH - hm, da war was. Ich bin mir nicht mehr sicher, wie ich das damals eingestellt habe. Wie kann ich das erkennen?

  • Auch mit diesen Einstellungen funktioniert es leider bei mir nicht. Nutze allerdings ein IMAP-Konto - sollte, denke ich, aber keinen Unterschied machen.

    Die meisten Menschen sind bereit zu lernen, aber nur die wenigsten, sich belehren zu lassen.
    Winston Churchill

  • Ich habe von OAUTH auf Standard umgestellt - so wie smash es in dem Screenshot dargestellt hat. Ich habe schon seit längerem (heißer Tipp von GwenDragon) die Einstellung auf Microsoft CryptoApi umgestellt. Da es damit auch nicht klappte, habe ich wieder auf OAUTH zurückgestellt. Inzwischen glaube ich, das Google irgendwas umgestellt hat. Mal klappt es, mal nicht. Wenn es dann einmal funktioniert, dauert es Ewigkeiten bis die Mail im Posteingang zu sehen ist. Ich bin ratlos. ?(

    Die meisten Menschen sind bereit zu lernen, aber nur die wenigsten, sich belehren zu lassen.
    Winston Churchill

    Einmal editiert, zuletzt von Heidrun ()

  • Entschuldigt, ich glaube das war evtl. ein Missverständnis. Meine angehängten Bilder sollten nur als Info dienen wie ich es aktuell eingestellt habe, vielleicht hab ich ja was falsch eingestellt
    und jemand hätte mich dann darauf hingewiesen.
    Ich hatte vorher aber auch auf OAUTH, als ich die Bilder gemacht habe stand es auf Standard weil ich halt rumprobiert habe - jetzt ist es auch wieder auf OAUTH.


    Mal generell gefragt, unabhängig von dem Problem hier gerade - wie sind denn nun die empfohlenen Einstellungen bei Gmail (imap), kann mir das einer genau aufschreiben bitte?
    Und ist das normal das wie im Bild zu sehen, trotz der Eingabe "imap.gmail.com" rechts bei Protokol "POP3" steht?


    @Heidrun bei mir wird keine Mail angezeigt (auch wenn mal ohne Fehlermeldung abgerufen wird) selbst nach längerer Zeit nicht wie du schreibst.
    Hab noch als ungelesen markierte Mails, wenn ich mich direkt bei Gmail einlogge. Mit dem Handy wurden die schon abgerufen aber wie erwähnt, mit thebat werden die nicht angezeigt/abgerufen...^^

  • Benutzt ihr alle TB! v9?


    Benutzt ihr alle AntiSpamSniper (ASS)? Und/oder benutzt ihr alle ESET NOD32 oder ein anderes AntiVirus-Programm bzw. eine Security Suite? Ist in den beiden die Prüfung von SSL-geschützten Verbindungen aktiviert? Die entsprechende Option könnte auch anders lauten.


    Habt ihr alle TB! in die GMail-Liste unsicherer Anwendungen eingetragen?


    Ansonsten kann die Benutzung eines lediglich 256-Bit (statt 2048) und damit heutzutage fast schon unsicheren Zertifikats zu Problemen führen. Wie ich bereits geschrieben habe, deutet es darauf hin, dass sich irgendwas dazwischenschaltet und dieses eigene Zertifikat verwendet. ASS tut das z.B. AntiVirus-Programme tun das auch. Vielleicht noch etwas, wie ein eigener Mail- oder Proxyserver.


    Vielleicht hilft es, das GMail-Konto neu zu erstellen und es mit Standardeinstellungen zu testen.



    07.04.2020, 20:16:37: FETCH - Verbinde mit POP3-Server imap.gmail.com auf Port 993

    Wieso steht bei dir "Verbinde mit POP3-Server", obwohl es doch um einen IMAP-Server geht?


    Und für SMTP sollte es TLS mit Port 465 sein.


    Im Übrigen muss das Protokoll der Verbindung mit einem GMail-IMAP-Server so aussehen:

    Bei dir fehlt einiges.



    Sanyok, gibt es einen kurzen Tipp, wie ich die Zertifikate wieder auf TB!-intern zurückstelle?

    Das mit OAUTH hast du wohl anhand der Screenshots bereits hinbekommen, oder?


    Die Zertifikatsdatenbank ändert man unter "Optionen | S/MIME und TLS..." ganz oben.



    Ich habe schon seit längerem (heißer Tipp von GwenDragon) die Einstellung auf Microsoft CryptoApi umgestellt.

    Hast du die Zertifikatsdatenbank ebenfalls auf die interne umgestellt (s. meinen Satz zuvor).